FORUMS
Post Reply Subscribe to Thread Email Thread

Talking Fix NlpCollectorWakeLock - Awake from 10% to 2%

23rd March 2014, 01:47 AM |#1  
luisbraz's Avatar
OP Senior Member
Flag Faro
Thanks Meter: 55
 
More
I reduced the awake time from around 10% to 2% and increased the battery time.
I discovered huge wakelocks from NlpCollectorWakeLock and NlpWakeLock.
Disabling the “Location Reporting” and “Location History” in “Google location settings” the wakelocks from NlpCollectorWakeLock and NlpWakeLock reduced from a total of 1h in 24h to 7 minutes in 24h.
As a result, my battery life is much better now.
Here goes some screenshots.









Last edited by luisbraz; 23rd March 2014 at 01:43 PM.
The Following 5 Users Say Thank You to luisbraz For This Useful Post: [ View ]
 
 
1st April 2014, 02:31 PM |#2  
XxM4tzexX's Avatar
Senior Member
Flag Neuwied, GER
Thanks Meter: 130
 
More
I think it is no secret that disabling location services will increase your battery life. So its not really a "fix". Any service, especially from google, which is running in background is somehow draining your battery.
The Following User Says Thank You to XxM4tzexX For This Useful Post: [ View ]
1st April 2014, 05:58 PM |#3  
luisbraz's Avatar
OP Senior Member
Flag Faro
Thanks Meter: 55
 
More
But I didn't disable the location services, I just disable the location report and the location history. For me it was a finding, because I didn't no what was causing the drain (wakelocks from NlpCollectorWakeLock and NlpWakeLock), and I want the location services on.
Last edited by luisbraz; 1st April 2014 at 07:10 PM.
The Following 2 Users Say Thank You to luisbraz For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
awake, deep sleep, nlpcollectorwakelock, nlpwakelock
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S 4 Mini General by ThreadRank