Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

X43Z60 Won't turn on but shows up on PC

OP datkwikracer

21st April 2014, 06:41 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
I bought my Kindle Fire HD 7" refurbished from an Ebay seller back in June 2013.

About 2 months ago it started randomly shutting down and wouldn't turn on until after I charged it for a while.

4 nights ago I tried to turn it on but it wouldn't. I figured the battery was dead so i charged it overnight. The next morning it still did not turn on.

I researched a bit but couldn't find anything relevant. I did try resetting by holding the power button for 20, 30 seconds even 2 minutes and nothing.

However when I connect it to my PC through USB, it shows up as if nothing was wrong.

Any help will be greatly appreciated.
21st April 2014, 07:57 AM   |  #2  
stunts513's Avatar
Recognized Contributor
Flag New Braunfels, TX
Thanks Meter: 610
 
2,230 posts
Join Date:Joined: Feb 2013
Donate to Me
More
Quote:
Originally Posted by datkwikracer

I bought my Kindle Fire HD 7" refurbished from an Ebay seller back in June 2013.

About 2 months ago it started randomly shutting down and wouldn't turn on until after I charged it for a while.

4 nights ago I tried to turn it on but it wouldn't. I figured the battery was dead so i charged it overnight. The next morning it still did not turn on.

I researched a bit but couldn't find anything relevant. I did try resetting by holding the power button for 20, 30 seconds even 2 minutes and nothing.

However when I connect it to my PC through USB, it shows up as if nothing was wrong.

Any help will be greatly appreciated.

What is it showing up as, the mtp device? if so i would assume either the backlight went out or the cable for the entire lcd screen section came loose. If it shows up as a omap device then the problem could be worse.
The Following User Says Thank You to stunts513 For This Useful Post: [ View ]
21st April 2014, 09:24 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
Quote:
Originally Posted by stunts513

What is it showing up as, the mtp device? if so i would assume either the backlight went out or the cable for the entire lcd screen section came loose. If it shows up as a omap device then the problem could be worse.

Yeah as an MTP device I think. As in when you connect any device and a window pops up asking if you want to transfer files or sync or open folder or something.

But yeah it seems my screen is the culprit. While it was connected to my pc I held the power button to reset and the pc made the sound it makes when you disconnect a usb device. So I held the power button again while still connected to the pc and shortly after it made the other sound the pc makes when you connect a device. Then the MTP window pops up so I slide to unlock where I think it normally is and I start tapping the screen and then I get some sound from one of my daughters apps.

So it seems to be working except for I can't see anything on the screen. So its obviously something with the screen like you thought. I spoke to Amazon and they offered me an amazon refurbished replacement for $90. Should I go that route?

Its the first and probably the last time I buy refurbished especially if its not from the manufacturer.
21st April 2014, 09:49 AM   |  #4  
stunts513's Avatar
Recognized Contributor
Flag New Braunfels, TX
Thanks Meter: 610
 
2,230 posts
Join Date:Joined: Feb 2013
Donate to Me
More
I don't know their policy too well but I would just double check before they give you a new one and make sure they don't send you the 2013 model as a replacement, that would suck if they did since its not romable.

Sent from my Amazon Kindle Fire HD using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes