Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,137 Members 50,757 Now Online
XDA Developers Android and Mobile Development Forum

[Q] "Sync Calendar" disappeared from all Google account Sync Settings

Tip us?
 
beefweef
Old
#1  
beefweef's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Aug 2012
Default [Q] "Sync Calendar" disappeared from all Google account Sync Settings

I really can't figure this one out. My calendar widget stopped working and for some reason, I don't even have the option of selecting "Sync Calendar" under any of my Google accounts. I have tried deleting and re-adding each individual account, but to no avail. Settings say "Sync is experiencing problems. It will be back momentarily." But I cannot find the source of the problem.
 
R4NDR01D
Old
#2  
R4NDR01D's Avatar
Senior Member
Thanks Meter 71
Posts: 119
Join Date: Apr 2012
Location: Fresno
Quote:
Originally Posted by beefweef View Post
I really can't figure this one out. My calendar widget stopped working and for some reason, I don't even have the option of selecting "Sync Calendar" under any of my Google accounts. I have tried deleting and re-adding each individual account, but to no avail. Settings say "Sync is experiencing problems. It will be back momentarily." But I cannot find the source of the problem.
Make sure you have the Google Calendar app installed.
 
beefweef
Old
#3  
beefweef's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Aug 2012
I do. I've tried using both the Google Calendar app as well as Samsung's stock app... Still the same problem.

Sent from my SCH-I545 using xda app-developers app
 
beefweef
Old
#4  
beefweef's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Aug 2012
I finally found the Google Calendar Sync Troubleshooter.

Here's the step that fixed it for me. Several layers deep in the Troubleshooter, but finally resolved the issue!

We recommend proceeding with these steps only if the above steps don't resolve the issue.

Open your device’s Settings.
Select Applications, then All.
Select Calendar Storage.
Select Clear data. Answer OK when prompted.
Turn Calendar sync off and on in Settings > Accounts > Google > [your affected account], or from within the app using Menu > Refresh on newer devices. If you receive an error message upon opening the Calendar app, close and re-open it to re-activate sync.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes