Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,935 Members 52,568 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Galaxy S II USB connection to computer not working

Tip us?
 
minueta
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Storage [Q] Galaxy S II USB connection to computer not working

When I connect my phone to my computer via USB, the first time it installs drivers and makes a noise. The drivers it installs are "Samsung Mobile Modem Diagnostic Serial Port (WDM) (COM6)", "Samsung Mobile Modem", and "Samsung USB Composite Device."

However, the device does not show up in Windows Explorer, and if I turn USB debugging on, it does not show up as a device I can debug on.

The device is running Android version 4.0.4 with model number SPH-D710.

I have tried installing the Samsung USB Driver for Mobile Phones, but that does not do anything differently when I plug in the phone.

I have tried with both of my cables and it works with neither one.

I have tried dialing *#7284# and changing USB to modem then back to pda and restarting the device, but that makes no difference as well.

The phone used to be a Credo Mobile phone but last year it was flashed to Page Plus. I'm not sure if this could have made the USB connection to the computer stop working as a USB storage device.

The phone shows up in devices and printers as a modem and USB hub.

Any ideas on how I can get it to work with my computer (Windows 7)? I mostly need it to work for USB debugging which is currently impossible.
 
MistahBungle
Old
#2  
Senior Member
Thanks Meter 3,205
Posts: 7,088
Join Date: Nov 2011
Wrong forum, belongs here. I've asked mods to move your thread, sit tight until they do.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
 
minueta
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Thumbs up Found solution

I found a solution:

I had to change it to AP mode by dialing ##8778#. It was set to CP mode, probably from when I had it flashed. Yay!

Found it in this thread: http://forum.xda-developers.com/show....php?t=1956802

Thanks for helping me find the right forum.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes