Android App Review: Manage Your Connections Automagically – XDA TV

Material Design is all the buzz in the Android world right now. … more

Official TWRP Recovery Lands on Micromax Canvas Magnus

With the recent release of Android One, Micromax and MediaTek released fully buildable … more

Update Overload: SuperSU Heavily Updated

There are apps and apps out there. Very few can reach the level of popularity required to stay at … more

Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Service [Q] [q] Camera failed i9500 - revisited (help)

OP duxerica

2nd August 2013, 07:38 PM   |  #1  
OP Junior Member
Flag Sarajevo
Thanks Meter: 1
 
18 posts
Join Date:Joined: Aug 2010
May I have your attention please.

Greeting to all who may be concerned or able to fix camera failed issue on Samsung Galaxy S4 i9500 !!!
I know that there are other threads with similar topic, but I think we should recindle this issue as serious problem.


The story goes:

I bought slightly used S4 i9500 phone with no guarantee. It worked fine, was taking pictures and all. Splendid.

It was on some stock firmware. Some german version I think.
Then crappy and useles bloatware began to bother me. Just mountains of really crappy and uselles meaningless bloatware.
I wanted to remove that horses*it apps and therefore I rooted the phone flashing adam kernel and cofface cwm.

One lovely day i tried to take photo, camera opened with black window and showed camera failed notification with persistancy.
i flashed some newer stock firmware, it opened and was taking pictures till i tried some camera modes (action or something) and it froze with pink screen.

After that event, nothing was helpfull to fix this problem.

1. I flashed countles stock roms, nearly all available custom roms, new and old (think over 20 flashes).
2. Prior to flashing I did: Wiping dalvik, system, data, cache, preload, or full wipe, hard resets, wiping sdcard and external card.
3. Tried also nand erase (it took some time to revive phone afterwards).
4. Tried solutions like clear camera cache and data.
5. Tried turning off phone, taking battery out for some time, with full recharge,
6. Tried non stock camera apps. (e.g. camera fx, camera mx..)
7. Tried removing camera app by deleting it with titanium backup, or with root exploer - then installing it back to system apps with root explorer.
8. Tried switching sd cards- 8gb, 16, 32, 64 gb, no card, and tried settings without saving pics to sd card but internal storage.
9. Tried turning off gps, and location services
10. Tried limiting processes to 4 only.
11. Tried flashing with odin, or via cwm cofface or philz.
12. I opened phone with screwdriver to check for posible visible faults or something - all ok.
13. Flashed official firmware claimed to solve camera problems.

Maybe something more i did?- i cant remember, if i do i will notify about it.

And I ordered camera module from internet, will try to replace it - we will se what happens.

In the meantime, if someone, some wise one, genious or ordinary person, knows how to fix this persisting problem PLEASE HELP!
You will help me, and help others that have this problem.

Samsung officials, if you somehow should read this, take this into consideration. There are many eyes upon you. Provide solution for this.

Any one - SOS
8th September 2013, 08:28 PM   |  #2  
OP Junior Member
Flag Sarajevo
Thanks Meter: 1
 
18 posts
Join Date:Joined: Aug 2010
FIXED IT.

Since no one cared enough to even try to help me with this problem I will not post the solution !

Said enough.
27th October 2013, 04:04 PM   |  #3  
Senior Member
Flag Mumbai
Thanks Meter: 34
 
202 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by duxerica

FIXED IT.

Since no one cared enough to even try to help me with this problem I will not post the solution !

Said enough.

I too like you tried everything and found nothing. Camera takes forever to open. Hope you decide to share the solution.Knowledge should be shared.Don't be bitter about it.I'm sure if someone had a solution they would have posted it.

cheers.
14th November 2013, 11:45 AM   |  #4  
xdamatt's Avatar
Member
Flag Bern
Thanks Meter: 2
 
41 posts
Join Date:Joined: Jan 2008
More
Quote:
Originally Posted by duxerica

FIXED IT.

Since no one cared enough to even try to help me with this problem I will not post the solution !

Said enough.

Likewise, some people may have missed your post or nothing good to add, still I too would like to know what finally worked as I tried most of what you did.

Bests
M
30th April 2014, 02:00 PM   |  #5  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Sep 2011
If you have message "Camera failed"...
First of all try this: Open Camera app from the "Application manager" and do "Clear data", then restart the phone.
Second: Do a Factory reset (of course save your data!).
Third: Reinstall Android OS.
If this not help you, you have a hardware problem. You need to change the camera.
-------------------
Video tutorial:
http://youtu.be/3nzetqisty0
Post Reply Subscribe to Thread

Tags
camera failed, i9500
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes