Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,770,922 Members 44,592 Now Online
XDA Developers Android and Mobile Development Forum

[REQ][MOD] Remove wireless charging pop-up notification

Tip us?
 
CraiaSoftware
Old
#1  
Member - OP
Thanks Meter 13
Posts: 86
Join Date: Oct 2011
Tutorial [REQ][MOD] Remove wireless charging pop-up notification

There is a pop-up that is displayed whenever the S4 is placed on a wireless charger. It is annoying and the phone is unusable during the few seconds it is displayed (I can't even take a screen shot). The notification reads:

Quote:
You have placed the device within range. Now charging Wirelessly...
I would love to have a mod to disable this notification.
 
chris2k5
Old
#2  
Member
Thanks Meter 1
Posts: 35
Join Date: Jun 2007
I would love a way to stop the pop up from coming up as well.
 
CraiaSoftware
Old
#3  
Member - OP
Thanks Meter 13
Posts: 86
Join Date: Oct 2011
Thumbs up SOLVED

My prayers have been answered:

Version 9 of NottachXposed now includes a toggle for the Wireless Charging Notification!

http://forum.xda-developers.com/show....php?t=2285074


Thanks @Nottach !
The Following User Says Thank You to CraiaSoftware For This Useful Post: [ Click to Expand ]
 
chris2k5
Old
#4  
Member
Thanks Meter 1
Posts: 35
Join Date: Jun 2007
Quote:
Originally Posted by CraiaSoftware View Post
My prayers have been answered:

Version 9 of NottachXposed now includes a toggle for the Wireless Charging Notification!

http://forum.xda-developers.com/show....php?t=2285074


Thanks @Nottach !
Thanks!

Confirmed it works! Just install the "Installer.apk" and then install NottachXposed.apk. Go to the Installer.apk app then under modules, check (don't leave it unchecked) the NottachXposed.apk. Then go to NottachXposed.apk and there should be a toggle for wireless charging notification.

It turned off the pop-up notification but the sound and screen still turns on. Not as bothersome if I silence the phone at night.
 
delaneybob
Old
#5  
Senior Member
Thanks Meter 7
Posts: 169
Join Date: Jan 2013
Quote:
Originally Posted by chris2k5 View Post
Thanks!

Confirmed it works! Just install the "Installer.apk" and then install NottachXposed.apk. Go to the Installer.apk app then under modules, check (don't leave it unchecked) the NottachXposed.apk. Then go to NottachXposed.apk and there should be a toggle for wireless charging notification.

It turned off the pop-up notification but the sound and screen still turns on. Not as bothersome if I silence the phone at night.
Do you have AT&T or Verizon?- The fix states it's only tested on AT&T

Thanks
 
chris2k5
Old
#6  
Member
Thanks Meter 1
Posts: 35
Join Date: Jun 2007
Quote:
Originally Posted by delaneybob View Post
Do you have AT&T or Verizon?- The fix states it's only tested on AT&T

Thanks
It worked on my Verizon S4.
 
delaneybob
Old
#7  
Senior Member
Thanks Meter 7
Posts: 169
Join Date: Jan 2013
Quote:
Originally Posted by chris2k5 View Post
It worked on my Verizon S4.
Thanks was about to do it and i saw it only disable the pop up- I am looking to disable the sound- nothing seems to disable the beep as the S4 stops charging at 98% and then trickles to 100%- lot's of disconnects and reconnects. System volume, silent mode etc have been tried. any suggestions would be highly appreciated
 
Rapajez
Old
#8  
Junior Member
Thanks Meter 0
Posts: 14
Join Date: Apr 2011
Quote:
Originally Posted by delaneybob View Post
Thanks was about to do it and i saw it only disable the pop up- I am looking to disable the sound- nothing seems to disable the beep as the S4 stops charging at 98% and then trickles to 100%- lot's of disconnects and reconnects. System volume, silent mode etc have been tried. any suggestions would be highly appreciated
^THIS^

Anyone have a solution now?

The whole point of this system was to sit on my nightstand, so I don't have to fiddle with it in the dark. The beeps and screen constantly popping on and off all night is incredibly annoying. Putting the phone on silent or Air-Plane does not stop the phone from lighting up. It does appear that the phone is lighting up to indicate 100%, and then disconnecting and re-connecting around 98%. I understand why the phone does this, but have no idea why the alerts are needed every 2 minutes.

I guess not enough people are using Qi charging to complain yet.
 
hexitnow
Old
#9  
hexitnow's Avatar
Senior Member
Thanks Meter 333
Posts: 1,005
Join Date: Jun 2013
Location: Idaho

 
DONATE TO ME
Quote:
Originally Posted by Rapajez View Post
^THIS^

Anyone have a solution now?

The whole point of this system was to sit on my nightstand, so I don't have to fiddle with it in the dark. The beeps and screen constantly popping on and off all night is incredibly annoying. Putting the phone on silent or Air-Plane does not stop the phone from lighting up. It does appear that the phone is lighting up to indicate 100%, and then disconnecting and re-connecting around 98%. I understand why the phone does this, but have no idea why the alerts are needed every 2 minutes.

I guess not enough people are using Qi charging to complain yet.
Theres an option in wanam to disable the wireless charging dialog, I dont know if it takes care of the sound too tho.

Hit thanks if I helped you out. Doing a little bit of reading goes a long way. Sent via tapatalk.
and-roms.com
Nvidia Shield Root and More

KR-1:~ KRIEGER$ chown -R US ./base
chown: ./base: No such file or directory
KR-1:~ KRIEGER$ mkdir ./base
KR-1:~ KRIEGER$ chown -R US ./base
ownership changed
 
keithjjo
Old
#10  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Oct 2013
As a new GS4 user, I'll have to say this is my one disappointment. I used inductive charging with my Palm Pre and it worked great. I was hoping that I'd have the same experience with the Qi charging system but now I get woken up between 2 and 3 am each night by the phone cycling the charge. I end up sliding it off the Qi pad so it stops the charging for the night. With the 4.3 update and blocking mode I should be able to turn off notifications but I'll have to test the exceptions so I can still get my emergency texts from our monitoring systems at work. No matter if the notification sound is turned off, the screen will still turn on and off. I'll agree, as the Qi chargers become more popular it may change the way the developers indicate charging but it would have been nice if they would have thought of it from the start.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Calc+ is a Smart and Beautiful Android Calculator

As we’ve said inthe past, there are quite a few calculators available on Android. … more

Get Better Debug Data with Crash Report SDK

Developing an application is a hard and often times ungratifying task. It also requires quite a … more

Navigate to Your Favorite Places with LocationDetector

If you’re enjoying an active way of life, you probablytravel a lot, go fishing, … more

LifeStats Automatic Journal Keeps Tabs of Your Day

Most of us live very active lives. This is after all why we’re fans of mobile … more