Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

/etc/audio_policy.conf from Stock ROM

OP nostupidthing

7th May 2014, 02:35 PM   |  #1  
OP Senior Member
Thanks Meter: 141
 
470 posts
Join Date:Joined: Nov 2012
in cm11/fxp according to /etc/audio_policy.conf

Code:
global_configuration {
  attached_output_devices AUDIO_DEVICE_OUT_SPEAKER|AUDIO_DEVICE_OUT_EARPIECE
  default_output_device AUDIO_DEVICE_OUT_SPEAKER
  attached_input_devices AUDIO_DEVICE_IN_BUILTIN_MIC|AUDIO_DEVICE_IN_VOICE_CALL
}
shouldn't there be a "2nd mic" entry?????

anyone with stock cm can check and tell? thx in advance!!!!!!!!!
8th May 2014, 12:33 PM   |  #2  
Senior Member
Thanks Meter: 38
 
125 posts
Join Date:Joined: Feb 2011
Quote:
Originally Posted by nostupidthing

in cm11/fxp according to /etc/audio_policy.conf

Code:
global_configuration {
  attached_output_devices AUDIO_DEVICE_OUT_SPEAKER|AUDIO_DEVICE_OUT_EARPIECE
  default_output_device AUDIO_DEVICE_OUT_SPEAKER
  attached_input_devices AUDIO_DEVICE_IN_BUILTIN_MIC|AUDIO_DEVICE_IN_VOICE_CALL
}
shouldn't there be a "2nd mic" entry?????

anyone with stock cm can check and tell? thx in advance!!!!!!!!!

just flashed CM11 20140507. The file in cm contains exactly the same part as you quoted.
8th May 2014, 06:26 PM   |  #3  
OP Senior Member
Thanks Meter: 141
 
470 posts
Join Date:Joined: Nov 2012
stock rom???
8th May 2014, 10:26 PM   |  #4  
Junior Member
Flag Merida, Yucatan
Thanks Meter: 3
 
15 posts
Join Date:Joined: Feb 2014
More
Quote:
Originally Posted by nostupidthing

stock rom???

Hi
In Stock Rom .101 have the same
The Following User Says Thank You to Dany MID Zero For This Useful Post: [ View ]
9th May 2014, 02:30 PM   |  #5  
OP Senior Member
Thanks Meter: 141
 
470 posts
Join Date:Joined: Nov 2012
asked over xperia z, same content...

Code:
global_configuration {
  attached_output_devices AUDIO_DEVICE_OUT_SPEAKER|AUDIO_DEVICE_OUT_EARPIECE
  default_output_device AUDIO_DEVICE_OUT_SPEAKER
  attached_input_devices AUDIO_DEVICE_IN_BUILTIN_MIC|AUDIO_DEVICE_IN_VOICE_CALL
}
Reference: http://forum.xda-developers.com/xper...-conf-t2745800

edit: there seems to be a "2nd mic" or "back mic" issue for some xperia devices...
Last edited by nostupidthing; 13th May 2014 at 03:17 PM.
14th May 2014, 07:38 PM   |  #6  
OP Senior Member
Thanks Meter: 141
 
470 posts
Join Date:Joined: Nov 2012
compare between different /etc/audio_policy.conf

Nexus 4 / mako (same CPU)
https://github.com/CyanogenMod/andro...io_policy.conf

Xperia Z / yuga
https://github.com/CyanogenMod/andro...io_policy.conf

Xperia ZR / dogo
https://github.com/CyanogenMod/andro...io_policy.conf

where is our back/2nd mic???
16th May 2014, 12:27 PM   |  #7  
OP Senior Member
Thanks Meter: 141
 
470 posts
Join Date:Joined: Nov 2012
strange, just checked Z1 (honami)'s config, same... but obviously there's a 2nd mic...

BAFFLING!!!!!!!!!!!!!!!!!!!!!!

p.s. reason why i keep asking is that, when revert to stock (forgot which version), video record has normal volume, but in cm/fxp, it's not!!!!!!!!!!!!!!!!!!!!


Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes