Post Reply

Android 4.4 Wakelock

OP wph

10th January 2014, 10:12 AM   |  #1  
OP Senior Member
Thanks Meter: 113
 
420 posts
Join Date:Joined: May 2010
More
Hi,

since Android 4.4 (Android Revolution HD 41.0) I get a huge amount of wakelocks, my phone hardly goes to deep sleep mode.

See screenshot below:



I already tried reflashing the rom, tried a different kernel (Elemental X, latest version), but those things don't help.

Anyone having the same problems? Or found a solution?
Last edited by wph; 10th January 2014 at 12:13 PM.
10th January 2014, 11:12 AM   |  #2  
xcrazydx's Avatar
Senior Member
Thanks Meter: 2,195
 
6,306 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Hi.

Stop double posting

Sent from my HTC One using Tapatalk
10th January 2014, 12:09 PM   |  #3  
OP Senior Member
Thanks Meter: 113
 
420 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by xcrazydx

Hi.

Stop double posting

Sent from my HTC One using Tapatalk

Sorry, my connection failed and now it's posted twice.
Last edited by wph; 10th January 2014 at 12:55 PM.
2nd May 2014, 11:17 AM   |  #4  
Member
Flag Bucharest
Thanks Meter: 7
 
48 posts
Join Date:Joined: Jan 2013
More
any solutions?
I'm having the same problem on stock 4.4.2 with Sense 5.5, wlan_rx_wake keeping my phone awake even after factory reset with nothing installed, just google apps updated, on 4.2.2 i used to get about 45-48 hours with medium usage, nothing extreme, now the same way i don't get over 30 hours, it's killing me! here's a screenshot from BBS
Click image for larger version

Name:	Screenshot_2014-05-02-13-14-01.png
Views:	39
Size:	224.0 KB
ID:	2721127 Click image for larger version

Name:	Screenshot_2014-05-02-13-14-15.jpg
Views:	38
Size:	172.5 KB
ID:	2721128
2nd May 2014, 11:59 AM   |  #5  
Mobzter's Avatar
Senior Member
Thanks Meter: 182
 
1,277 posts
Join Date:Joined: May 2010
maybe try disable cloudprint (found in settings towards the bottom). can take a little time for it to disable when you turn it off. may/may not make a difference.

i read this and seems to make more sense
http://rootzwiki.com/topic/16134-ker...-wlan-rx-wake/

mainly the second post. hope its of some use..
2nd May 2014, 01:31 PM   |  #6  
Member
Flag Bucharest
Thanks Meter: 7
 
48 posts
Join Date:Joined: Jan 2013
More
Thanks for the response, and i will try both options and post the results after.

Sent from my HTC One using XDA Free mobile app
6th May 2014, 12:45 PM   |  #7  
Member
Flag Bucharest
Thanks Meter: 7
 
48 posts
Join Date:Joined: Jan 2013
More
I think it's fixed now, don't know if batteryguru did the job or theWifiFixer app, i tend to believe that WifiFixer did the thing with this setup in "Service" and "Advanced" settings.

Sent from my HTC One using XDA Free mobile app
Attached Thumbnails
Click image for larger version

Name:	1399376631280.jpg
Views:	32
Size:	35.3 KB
ID:	2728719   Click image for larger version

Name:	1399376639953.jpg
Views:	29
Size:	40.4 KB
ID:	2728720   Click image for larger version

Name:	1399376682272.jpg
Views:	26
Size:	70.1 KB
ID:	2728721   Click image for larger version

Name:	1399376689529.jpg
Views:	28
Size:	31.0 KB
ID:	2728722   Click image for larger version

Name:	1399376698363.jpg
Views:	27
Size:	73.4 KB
ID:	2728723  
8th May 2014, 08:45 AM   |  #8  
Member
Flag Bucharest
Thanks Meter: 7
 
48 posts
Join Date:Joined: Jan 2013
More
Best solution
after a lot of searching somebody posted this and this fixed the problem better than wifi fixer or anything else, it's a response from HTC Support.

"got an email from HTC support, which I will copy. so far, my battery is back to normal.

I totally understand your concern on this matter with the battery drainage of the phone, and I will be more than glad to assist you.

I ask you to please go to All apps > Settings > Battery or Power, and disable Fast boot. Then, please go to All apps > Settings > Developer options, and enable USB debugging. After doing this, please perform a Cache reset. This process will delete unwanted and temporary files from your phone. It will not mess up your personal files. Just follow the instructions on the attached file.

COPY OF ATTACHED FILE:

Power the phone off.
Press and hold the Volume Down button and then while still holding the Volume down, press the Power button as well.
You will get a menu giving you options such as: Fastboot, Recovery, Clear Storage, and SIMlock
Navigate to “Recovery” using volume buttons, then press power to select.





The screen will change to display a phone on its back, with the update symbol above it. Momentarily it will change to an image of a phone with a red triangle and exclamation mark.


Press and hold volume up then press the power button for about 3seconds. You will see something very similar to the example shown below.





e:can’t open /cache/recovery/command
e:/ failed to mount /sdcard (no such file or directory exists)
e:/ failed to mount /sdcard (no such file or directory exists)
e:/ failed to mount /sdcard (no such file or directory exists)
A new screen will give you options like Reboot system now, Wipe Cache partition, and Wipe Data/Factory Reset.





Navigate to “Wipe Cache” the volume down button and select with Power.

Navigate to “Reboot Phone” with the volume buttons and select with power."

Hope it helps people that have the same problem.

Here are the results:
Click image for larger version

Name:	2014-05-08 22.29.04.jpg
Views:	8
Size:	153.9 KB
ID:	2733159 Click image for larger version

Name:	2014-05-08 22.29.45.png
Views:	8
Size:	227.1 KB
ID:	2733160
Last edited by alexxero; 8th May 2014 at 11:37 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes