Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,769,124 Members 39,384 Now Online
XDA Developers Android and Mobile Development Forum

[FIX] for Nand USB Init Failed

Tip us?
 
ntatschner
Old
(Last edited by ntatschner; 2nd January 2011 at 09:51 AM.) Reason: Adding info
#1  
Junior Member - OP
Thanks Meter 33
Posts: 15
Join Date: Jan 2010
Default [FIX] for Nand USB Init Failed

Hello Guys/Girls,

As I was struggling with this I though I would share the info to help people get NAND Android installed.

Firstly if you are getting the below message you are most likely missing a couple of file's in the same directory called EnterBootloader and rapitool (which I have included in this post)

"Error Description: USB init failed
Info: .\RSPL\RSPL.cpp (723)"

Simply place those file in the same Directory as the DAF.exe file and vola it should now start the flashing from the DAF.exe file.

I hope this helps.

***
If you are running XP Go to control panel and then active sync while connected in MAGLDR while it states Wait USB...USB and un-check Allow USB then right click the DAF.exe and run as Admin, that should allow you to install.

***
Nigel
Attached Files
File Type: zip Missing files.zip - [Click for QR Code] (92.2 KB, 18721 views)
The Following 31 Users Say Thank You to ntatschner For This Useful Post: [ Click to Expand ]
 
sorinu
Old
#2  
Member
Thanks Meter 0
Posts: 49
Join Date: Dec 2009
Many thanks. I will check now.
_____________________________

Phone: HTC HD2
OS: WM6.5.X + SD Android
Radio: 2.15.50.14
Card: 16 GB Sandisk class 4
 
Dam4rusxp
Old
#3  
Member
Thanks Meter 60
Posts: 90
Join Date: Aug 2010
Oh yeah I understand. That seems to be a bug of the DAF installer. These files normaly get removed after the RUU has run. And they also do in the DAF installer.
THANK YOU!
 
monyozt
Old
#4  
Senior Member
Thanks Meter 90
Posts: 1,296
Join Date: Mar 2008
Location: kudus
still not working

current device :
__________________
Phone:
sprint M8 harman Kardon| Sandisk Extreme 64GB
Blackberry Q10 lastest OS with
Tablet : : Verizon IPAD 4 64GB lastest OS

 
vensterbank
Old
#5  
vensterbank's Avatar
Senior Member
Thanks Meter 40
Posts: 295
Join Date: Nov 2010
Location: Stadskanaal
this aint working for me, its like my pc aint fiding my phone. or the bug fix doesnt help.
however i can use diskdrive mode and htcsync works. so i dont get it.

im just trying to get the new kernel on my stock desire nand.
plz help,
The Following User Says Thank You to vensterbank For This Useful Post: [ Click to Expand ]
 
nbhadusia
Old
#6  
Senior Member
Thanks Meter 30
Posts: 278
Join Date: Dec 2009
Location: London
I was getting the same error. I took these three steps, and all is now working - im not sure if all three 3 steps contributed to success, or any one of them - but taking these measures definately worked for me (im running Windows XP by the way)
The phone should be connected to the PC at all times during these steps.



1) Install MAGLDR using admin rights. This was done by right clicking the Magldr.exe and selecting 'run as', then clicking 2nd option, signing in as a user with admin rights.

2) Open ACTIVESYNC, 'File', then 'Connection Settings' - UNCHECK 'Allow USB connections' Reboot phone

3) Right clicking 'DAF.EXE' file and running with admin rights (like it was done in Step 1 above). Click Next, next untill its searching for USB connection

4) On phone, select option 4.

hopefully, it should all now work

Hope this helps.
The Following 2 Users Say Thank You to nbhadusia For This Useful Post: [ Click to Expand ]
 
mojacho
Old
#7  
Junior Member
Thanks Meter 0
Posts: 4
Join Date: Mar 2009
try your method....
but still error msg come out..
Quote:
[Error happen
Read below for more information

Error Description: send partition data failed
Info: .\RSPL\RSPL.cpp (802)

Error Description:
Info: .\RSPL\RSPL.cpp (545)
it only process till half way..
using windows xp..
 
jimhaddon
Old
#8  
Senior Member
Thanks Meter 17
Posts: 137
Join Date: Dec 2009
Run as administrator!

Sent from my HTC HD2 using XDA App
 
Erkin Ay
Old
#9  
Erkin Ay's Avatar
Senior Member
Thanks Meter 74
Posts: 254
Join Date: Jan 2009
Location: Trichy
Please note that. You must have HSPL 2.08 and Radio Rom 2.15.50.14 on your device
 
Xoombie
Old
#10  
Junior Member
Thanks Meter 2
Posts: 21
Join Date: May 2007
Location: Freiburg

 
DONATE TO ME
Same Error for me.

After Right Klick and Start as Admin it works prompt.

Windows 7 X64

Give it a try.

Xoombie

Tags
fix, nand, usb init failed
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes