FORUMS

OnePlus Addresses Reservation List Cheating

Jake Cooper figured out how to bump his place up on OnePlus’ reservation list and … more

OnePlus 2 Benchmark Scores Show Its Muscle

This video by FoneArena contains all the popular benchmarks being tested on the OnePlus 2, … more

Sony’s Emergence in The Middle: Is The Price Right?

Sony’s Electronics Division is not in its best days, and its smartphone … more

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

[Q] Constant wakelocks with GCM_CONN_ALARM and GCM_CONN (GcmService)

11 posts
Thanks Meter: 0
 
By santiagoroza, Junior Member on 12th May 2014, 09:44 PM
Post Reply Subscribe to Thread Email Thread
My phone (Moto G running stock Android 4.4.2 rooted) NEVER ever gets into deep sleep because of these two deadlocks: GCM_CONN_ALARM and GCM_CONN.

I tried blocking them using Wakelock Terminator (either in Google Play Services or in Android System) but it doesn't seem to do anything at all, either with the keyword filter or the total filter.

The wakelocks only stopped when I disabled GcmService (using the Disable Service app), but now I don't get many notifications (Gmail, Twitter, WhatsApp).

Is there any solution in between? Thanks in advance.
 
 
13th May 2014, 11:13 AM |#2  
bibhu60's Avatar
Senior Member
Flag delhi
Thanks Meter: 53
 
More
Quote:
Originally Posted by santiagoroza

My phone (Moto G running stock Android 4.4.2 rooted) NEVER ever gets into deep sleep because of these two deadlocks: GCM_CONN_ALARM and GCM_CONN.

I tried blocking them using Wakelock Terminator (either in Google Play Services or in Android System) but it doesn't seem to do anything at all, either with the keyword filter or the total filter.

The wakelocks only stopped when I disabled GcmService (using the Disable Service app), but now I don't get many notifications (Gmail, Twitter, WhatsApp).

Is there any solution in between? Thanks in advance.

Why do you need to go in deep sleep you will miss notifications in deep sleep
9th July 2014, 09:49 PM |#3  
Senior Member
Thanks Meter: 42
 
More
I have the same wakelock on my Moto X. IS KILLING"my battery. . Anyone got any ideas. .
10th July 2014, 12:52 AM |#4  
liveroy's Avatar
Senior Member
Flag Stara Zagora
Thanks Meter: 108
 
Donate to Me
More
Quote:
Originally Posted by gsusx

I have the same wakelock on my Moto X. IS KILLING"my battery. . Anyone got any ideas. .

Start uninstalling things like FB, whatsapp, viber, Twitter and so everything that may want to sync periodically.

See if you can filter out what is actually keeping the given service active, thus keeping your device awake.

As a last resort, factory reset and start over.
The Following User Says Thank You to liveroy For This Useful Post: [ View ]
20th July 2014, 06:11 AM |#5  
Senior Member
Thanks Meter: 31
 
More
This popped up for me after using my alarm clock. Even after turning off the alarm, it still appears. Did you ever resolve the issue?
11th March 2015, 08:55 AM |#6  
Junior Member
Thanks Meter: 2
 
More
Unhappy
Nobody has a between solution? Not disabling it nor allowing it to hog our batteries..
10th April 2015, 10:59 AM |#7  
doylefermi's Avatar
Member
Thanks Meter: 63
 
More
Quote:
Originally Posted by santiagoroza

My phone (Moto G running stock Android 4.4.2 rooted) NEVER ever gets into deep sleep because of these two deadlocks: GCM_CONN_ALARM and GCM_CONN.

I tried blocking them using Wakelock Terminator (either in Google Play Services or in Android System) but it doesn't seem to do anything at all, either with the keyword filter or the total filter.

The wakelocks only stopped when I disabled GcmService (using the Disable Service app), but now I don't get many notifications (Gmail, Twitter, WhatsApp).

Is there any solution in between? Thanks in advance.

Use Greenify in Boost mode (works with xposed)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes