Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Question [Q] Xperia play Gingerbread to Jellybean/Kitkat

OP Grover2000

28th May 2014, 12:19 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
Hi can anyone advise what the problem could be?

I have been trying to upgrade my Xperia play from Gingerbread to Jellybean and failed,

My handset is Bootloader unlock Status = No, although O2 unlocked the carrier so I could use any carrier.
So when I goto Sony bootloader unlock site the phone will not goto fastboot mode. Just says Waiting

When I open Fashtool I have successfully rooted the phone, but when I try to Flash the phone rather than go into Fastboot mode the just restarts.

I am using Windows 7 64bit.

Any help on getting this done is greatly appreciated

Grover
28th May 2014, 02:03 PM   |  #2  
Senior Member
Thanks Meter: 41
 
172 posts
Join Date:Joined: Aug 2013
Umm I think only the simlock has been removed. But the bootloader is still locked and cannot be unlocked. and what button are you pressing to go into flashboot?
28th May 2014, 02:34 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by ryanperez

Umm I think only the simlock has been removed. But the bootloader is still locked and cannot be unlocked. and what button are you pressing to go into flashboot?

I have used search button whilst plugining in USB.

Does that mean bootloader is locked, so impossible to unlock?

The sticker on the back of the phone is W46. Read somewhere that using Flashtool may damage the phone.

Thanks in advance

Grover
28th May 2014, 03:41 PM   |  #4  
TheScriptKitty's Avatar
Senior Member
Flag Mexico City
Thanks Meter: 271
 
308 posts
Join Date:Joined: Dec 2013
Donate to Me
More
Info 2
Quote:
Originally Posted by Grover2000

Hi can anyone advise what the problem could be?

I have been trying to upgrade my Xperia play from Gingerbread to Jellybean and failed,

My handset is Bootloader unlock Status = No, although O2 unlocked the carrier so I could use any carrier.
So when I goto Sony bootloader unlock site the phone will not goto fastboot mode. Just says Waiting

When I open Fashtool I have successfully rooted the phone, but when I try to Flash the phone rather than go into Fastboot mode the just restarts.

I am using Windows 7 64bit.

Any help on getting this done is greatly appreciated

Grover

SIM Unlocking the phone inst the same as Unlocking the Bootloader. If you Have Bootloader unlock Status = No you can still unlock your Bootloader via the Test Point method.

If you Unlock your phone with the Test Point method you will not have acces to Fastboot Mode, but you can still Flash Kernels via Flash Mode Using the FTF version of it(insted of a boot.img file).
Look in my signature if you want any FTF kernel.
30th May 2014, 03:22 PM   |  #5  
Senior Member
Thanks Meter: 188
 
497 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by TheScriptKitty

SIM Unlocking the phone inst the same as Unlocking the Bootloader. If you Have Bootloader unlock Status = No you can still unlock your Bootloader via the Test Point method.

If you Unlock your phone with the Test Point method you will not have acces to Fastboot Mode, but you can still Flash Kernels via Flash Mode Using the FTF version

Please note this method only works for xplays made before a certain date. (can't remember exactly when but google will help)

Sent from my R800i using XDA Free mobile app
31st May 2014, 03:39 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by korrectmethod

Please note this method only works for xplays made before a certain date. (can't remember exactly when but google will help)

Sent from my R800i using XDA Free mobile app

I have successfully done the test point via s1 tool method, but I'm not quite sure which version of JB to upload and how to my Xperia Play. Can someone give me a step by step guide on how to flash my phone?

Thanks in advance

Grover
31st May 2014, 07:19 PM   |  #7  
Senior Member
Thanks Meter: 188
 
497 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by Grover2000

I have successfully done the test point via s1 tool method, but I'm not quite sure which version of JB to upload and how to my Xperia Play. Can someone give me a step by step guide on how to flash my phone?

Thanks in advance

Grover

Just read the instructions for whatever kernel you are using, and same with the rom you want to install.

http://forum.xda-developers.com/show...php?p=39047223

Sent from my R800i using XDA Free mobile app
1st June 2014, 08:50 PM   |  #8  
KiraYahiroz's Avatar
Senior Member
Flag London
Thanks Meter: 74
 
201 posts
Join Date:Joined: Apr 2013
More
As above, follow the guide above. Since you unlocked via the testpoint and there's no fastboot, you need to have your kernels in a .ftf file format.

Here's a thread with download links to ftf kernels: http://forum.xda-developers.com/show....php?t=2739559

You will need to use flashtool to flash them. The JB ROM can then be flashed via recovery normally.

My Xperia PLAY was locked to O2 as well and testpoint unlocked, and these have been working fine for me so far... although for some reason my phone stopped working with ICS ROMs. GB and JB still works however.
The Following 2 Users Say Thank You to KiraYahiroz For This Useful Post: [ View ]
2nd June 2014, 12:27 AM   |  #9  
OP Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: May 2014
Thumbs down
Phone bricked.

I flashed the Lupus JB kernal and then entered recovery menu and deleted formatted and now it just a blank screen as if the phone is off yet plugging in the usb is recognised by computer yet flashtools and Sony companion can't repair or recognise.

Any ideas?

Grover
2nd June 2014, 03:46 PM   |  #10  
KiraYahiroz's Avatar
Senior Member
Flag London
Thanks Meter: 74
 
201 posts
Join Date:Joined: Apr 2013
More
Exactly what did you delete/format under recovery? All I did was pick the factory reset option, then wiped cache and dalvik cache, and then flashed the ROM and worked fine for me. I'm using version 8 of the kernel however for the extra data space.

Here are the ftf files for the stock original Sony firmware, which you can use to restore your device if flashing goes wrong (.79 is the latest): http://forum.xda-developers.com/show...57&postcount=2

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes