Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,035 Members 41,665 Now Online
XDA Developers Android and Mobile Development Forum

[Guide] Unbrick Your Sprint S3 ..... (and maybe others)

Tip us?
(Last edited by Homefix; 7th April 2014 at 01:41 AM.) Reason: Wrong Thread
Homefix's Avatar
Senior Member - OP
Thanks Meter 33
Posts: 111
Join Date: Jan 2010
Default [Guide] Unbrick Your Sprint S3 ..... (and maybe others)

Just Realized Im in wrong thread .and don't know how to fix hopefully I will be moved to Q and A

This is just to help out people who may have had a hard time getting other guides to work like I had

I dont have original thread so i will give you my rough draft and will update when possible.
All steps work.

My working image link is at bottom of post

Here is were I made the mistake

These are the 2 files

flashed first and wamo no andro

Ya my bad shouldnt have flashed firmware but i did and payed the price.

Heres my specs.
Android Ver:
Baseband Ver:
Hardware Ver:

haha, so im a knuklehead.

I thought i lost my device (this is still a bad-ass phone, almost too nice to be in a roofers pouch and getten torn up. But it takes really nice pictures of my custom work, and takes em fast so i can get back to work.
I lost 12 hours for stupid mistake,
Not to mention the last device i bricked was my first (Hero) and thought was my last.

The only life left in the device, was red light, when battery removed (when battery was placed in during charge, red light went out in 5 to 10 sec.)
When battery was in unit, no lights at all.
I noticed when usb cable attached to ubuntu, was some kind of Qualcomm Device _DLMODE or somthing.
I will edit this post when i find it again, but anyway that led to nothing.

My first attempts were made following this guide:

I couldnt figure out by reading the threads if how I was to format the fat32 partition default 8 or 4 or 1Mg
I couldnt understand why we would have to try to write the image over and over...Why it wouldnt write it right the first time.

I had a hard time trying to write the image file ..debrick_sph_l710.img to sdcard using my v-box..
(Virtual-Box under windows 8 with Ubuntu 13.10 installed ....Android-Kernel-Build ready ).

After trying all the different ways and different images, I said screw it i give up.
.........Till after dinner
wife made a roasted chicken not gonna be late.

Finally I made my own image from my wifes phone, because we bought them at the same time.
One problem hers isnt rooted and she wasnt about to let me touch it.............
Solution: I bought her a galaxy4 for 49.00 /w upgrade, now i have 2 galaxy 3's. But only one works.:/
That was a pain rooting because she always excepts the firmware upgrades when they come over air.
Couldnt get the "seLinux seAndroid" thing so i just went back to 4.1 for now so that i could adb.

Heres What Did It...


To extract a de-brick image from your phone (an UnBricked Phone) do in an adb shell:
If you know the partition use:
dd if=/dev/block/mmcblk0 of=/sdcard/HomefixSprint_S3_L710.img bs=1048576 count=70
If not use:
dd if=/dev/block/platform/msm_sdcc.1/by-name/modem of=/sdcard/HomefixSprint_S3_L710.img bs=1048576 count=70

C:\Users\dad>adb shell
root@android:/ # busybox dd if=/dev/block/mmcblk0 of=/sdcard/HomefixSprint_S3_L710.img bs=1048576 count=70
0 of=/sdcard/HomefixSprint_S3_L710.img bs=1048576 count=70 <
70+0 records in
70+0 records out
73400320 bytes (70.0MB) copied, 4.578239 seconds, 15.3MB/s

Take that image, copy it to your cygwin directory and write it to an unformatted 16mb sdcard using cygwin:

get EaseUS Partition Master Free Edition-Free For Home Users
and find the sdcard, its about 14.82GB, if u have more than 1 your on your own.
Select that one, and delete all partitions.
Then, New partition, select fat32, and then finish by applying the operations.

Get sdcard info:
cat /proc/partitions

$ cat /proc/partitions
major minor #blocks name

8 0 976762584 sda
8 1 976759808 sda1
8 16 117220824 sdb
8 17 358400 sdb1
8 18 116859904 sdb2
8 32 976762584 sdc
8 33 976759808 sdc1
8 48 244198584 sdd
8 49 244196001 sdd1
8 64 976762584 sde
8 65 976657408 sde1
8 80 976762584 sdf
8 81 976760001 sdf1
8 96 976762584 sdg
8 97 976760001 sdg1
8 112 976075776 sdh
8 113 976074752 sdh1
8 128 15558144 sdi
8 129 15558110 sdi1

$ ls

$ dd if=HomefixSprint_s3_L710.img of=/dev/sdi
143360+0 records in
143360+0 records out
73400320 bytes (73 MB) copied, 338.771 s, 217 kB/s

Put battery in
Connect usb cable
Insert sdcard
Vol-up/Home and Power

I felt the vibration no more than a second after pressing power (along with vol_dwn and home key pressed and held)
As you can imagine, my adrenilin was pumpped to the point of feeling like i smoked a pack of camel ciggirettes, AGAIN, as i try to boot the phone.
I knew i was out of the woods after I saw the samsung logo.
It Skipped past download.
I was able to boot right into my desktop, however there were no signal bars.
and the Baseband ver: was unknown.
I powered down the phone (man that was hard to do) but i did.
Tried to get into download mode but failed at first, recovery failed also.
Finally got to download then i was good.

After I revived the phone I had nothing too loose because now I had 2 S3's, so I played a bit.

Its fun to brick your phone on purpose haha

:The debrick_sph_l710.img or the Debrick_Sprint_S3_L710_4.3.img did not work for me
:I did not need the class 10, class 4 worked too
:I did not need cable attached
:It didnt Matter wich order i put battery, sdcard, usb-cord to boot
:I did not format card
nly took 1 try to write working image each time ( didnt take several attemts) I wrote and tested 3 different images.
:Upon booting It seems to be the same each time ,couple three four sec (out of a few times playing it may have taken 10sec to boot on one occasion).
:I think the issues with ubuntu was,the sdcard was not ejecting properly and corrupting the image.
:If you have a sucssesful write to sdcard, it may not show up in file explorer until you pull out card reader and re-insert it... then it will show up in file explorer as a folder called "image" with bunch of files or somthing in it, then you know it wrote ok.
:for some reason after i haha... BRICKED MY SG3 ON PURPOSE....Oh my GOD....Im SHOT, booted to my homemade image, i was able to boot into recovery as well as Download.

:Not for nothen I tried to:
dd if=/sdcard/recovery.img of=/dev/block/platform/msm_sdcc.1/by-name/recovery
dd if=/sdcard/boot.img of=/dev/block/platform/msm_sdcc.1/by-name/boot
dd if=/sdcard/modem.img of=/dev/block/platform/msm_sdcc.1/by-name/modem
(Remember i was able to boot to system, so adb worked)
Did not work, however it may have worked if i used the syntax...mmcblk0 and such.

My Image Link:
The Following User Says Thank You to Homefix For This Useful Post: [ Click to Expand ]
Junior Member
Thanks Meter 2
Posts: 17
Join Date: Mar 2011
Will your image work if placed on a formated sd card or do I need to do the partion step then copy
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes