Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Update 4.4.2 broke my Bluetooth connection for my Car

OP joseh92

13th February 2014, 06:53 AM   |  #1  
joseh92's Avatar
OP Member
Flag Brentwood
Thanks Meter: 31
 
73 posts
Join Date:Joined: Apr 2012
More
Ever since I updated to the latest update which is 4.4.2 as of now, my built in Bluetooth for my car keeps disconnecting and connecting to my phone.
I've tried various resets and reconfiguring the profiles and connecting the Bluetooth and still nothing. It always disconnects and connects nonstop every minute.

Before this it wouldn't do that. It would connect without a problem and stay connected with no issues.

Anyone know what the deal is? I've asked HTC but like always their customer service doesn't know crap about anything.

Sent from my HTCONE using Tapatalk
13th February 2014, 06:54 AM   |  #2  
joseh92's Avatar
OP Member
Flag Brentwood
Thanks Meter: 31
 
73 posts
Join Date:Joined: Apr 2012
More
Also it's a 2013 Mercedes. I doubt the system is outdated.

Sent from my HTCONE using Tapatalk
14th February 2014, 12:05 AM   |  #3  
Member
Flag Bay Shore
Thanks Meter: 5
 
45 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by joseh92

Ever since I updated to the latest update which is 4.4.2 as of now, my built in Bluetooth for my car keeps disconnecting and connecting to my phone.
I've tried various resets and reconfiguring the profiles and connecting the Bluetooth and still nothing. It always disconnects and connects nonstop every minute.

Before this it wouldn't do that. It would connect without a problem and stay connected with no issues.

Anyone know what the deal is? I've asked HTC but like always their customer service doesn't know crap about anything.

Sent from my HTCONE using Tapatalk

Just submit a technical support email via the HTC website. I've already sent one for an NFC issue not being able to send webpages and URLs to other devices. The more issues you report, the faster they can get to resolving them.

Sent from my HTCONE using XDA Premium 4 mobile app
14th February 2014, 01:36 PM   |  #4  
Member
Thanks Meter: 17
 
64 posts
Join Date:Joined: Oct 2008
Are you using completely stock? I know Bluetooth is one of those things that the custom ROMs have a bit more issues with, and I recall seeing that some of the kernels required updates for Bluetooth functionality.
14th February 2014, 04:07 PM   |  #5  
joseh92's Avatar
OP Member
Flag Brentwood
Thanks Meter: 31
 
73 posts
Join Date:Joined: Apr 2012
More
Ive tried everything but rooting and going custom again. Don't think that will solve it. It doesn't stay connected and no calls can be made or received. I've seen it was an issue with nexus phones with the same update.

Sent from my HTCONE using Tapatalk
15th February 2014, 02:42 AM   |  #6  
Member
Thanks Meter: 17
 
64 posts
Join Date:Joined: Oct 2008
You've stated that you tried everything, but can you see if you can connect only as an audio device and not Handsfree or Messaging? While not ideal, it helps rule out some potential points of failure.
15th February 2014, 06:29 AM   |  #7  
joseh92's Avatar
OP Member
Flag Brentwood
Thanks Meter: 31
 
73 posts
Join Date:Joined: Apr 2012
More
It's always connected as hands-free.

Sent from my HTCONE using Tapatalk
15th February 2014, 10:07 AM   |  #8  
Junior Member
Thanks Meter: 1
 
3 posts
Join Date:Joined: Dec 2008
You're not alone. Since upgrading to 4.4.2 on a bone stock HTC One, I have had the same disconnect issues or better described, it constantly pairs and unpairs, and my contacts will now longer load, I have a 2012 BMW 328i with iDrive. I tried the latest firmware update for my iDrive, but the problems persist. A Google search shows scores of Nexus users who have upgraded to Kit Kat and have lost their bluetooth because of the exact same issues. However, I'm not seeing very many HTC One owners running 4.4.2 with Bluetooth connectivity issues under 4.4.2. I've counted only 5 thus far - you, me, and 3 others.

My wife's Galaxy Note 3 connects to my car with no issues, I've been looking , but have yet to found a solution.
15th February 2014, 10:24 AM   |  #9  
Xerro-Five's Avatar
Senior Member
Flag Vancouver
Thanks Meter: 82
 
229 posts
Join Date:Joined: Apr 2013
More
I briefly had a problem connecting to my car stereo after 4.4.2, but the problem was that it would no longer auto connect. I found out that in 4.4 now shutting of Bluetooth on my phone when not in use prevents it from auto connecting to the stereo when I turn it back on, so I just leave it on all the time and it works well.
All stock btw

For whatever it's worth...

Sent from my HTC One using xda app-developers app
16th February 2014, 12:08 AM   |  #10  
joseh92's Avatar
OP Member
Flag Brentwood
Thanks Meter: 31
 
73 posts
Join Date:Joined: Apr 2012
More
Yeah I've tried everything but no dice, sent various tech problems to HTC. Let's hope they see it and send out a patch 6 months from now

Sent from my HTCONE using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes