FORUMS

Analysis & Opinion

Top Forum Discussions

[ROM][T-320][T-520][T-900] Stock, Deodedex, Rooted, Aroma Installer

25 posts
Thanks Meter: 81
 
By jasongwatts, Junior Member on 8th June 2014, 12:38 AM
Thread Closed Subscribe to Thread Email Thread
GigaWatts Pro v3.0


Choose your own adventure!

Do your own de-bloating with the Aroma Installer.


Stock base
De-odexed
Rooted
Busybox
Zipaligned
Init.d support
Knoxless
Permissions have been modified to allow writing to external SD card.
Secure Storage has been set to FALSE
All languages supported.
Aroma Installer lets you choose which Samsung apps you want to keep, which Google apps you want to keep and your choice between several boot animations, keyboards, file managers, music players, email clients, browsers, and a couple add-ons.

Thanks to Chainfire for SuperSU and CF-Auto Root.
Thanks to Amarullz for his Aroma Installer.
Thanks to the CyanogenMod team and the SlimTeam for their boot animations and a few of their apps.

This rom is still in its infancy so I expect bugs.
Please report them back so I can work on them.

8.4 WiFi is based on T320UEU1AND3
10.1 WiFi is based on T520UEUAND1
12.2 WiFi is currently underdevelopment

Download Links
T-320

T-520



XDA:DevDB Information
GigaWatts Pro, ROM for the Samsung Galaxy Tab Pro 12.2, 10.1, 8.4

Contributors
jasongwatts

Version Information
Status: Testing

Created 2014-06-08
Last Updated 2014-07-16
The Following 32 Users Say Thank You to jasongwatts For This Useful Post: [ View ]
 
 
8th June 2014, 05:09 AM |#2  
SomeGuyDude's Avatar
Senior Member
Thanks Meter: 220
 
More
Downloading now. Curious to check 'er out, and thank you for being one of the only people working on the 10.1 :P
8th June 2014, 10:46 AM |#3  
Member
Flag Paris
Thanks Meter: 1
 
More
Thanks for your work for Galaxy Tab Pro 12.2

Will it work for European Tab Pro 12.2 ?
European Tab pro firmware is T900XXUANB5_T900OXXANB2_XEF

I will try it for my SM-T900 when TWRP recovery will be updated for this tab because there is no way to upgrade to custom firmware for this tab right now huh ?
Last edited by Calimero Oeuf; 8th June 2014 at 11:00 AM.
8th June 2014, 11:53 AM |#4  
Junior Member
Thanks Meter: 2
 
More
Hello
i just installed the room but im stuck at the samsung booting logo.
How much time do i have to wait?
8th June 2014, 02:19 PM |#5  
StifflerServices's Avatar
Senior Member
Flag Columbus, Ohio
Thanks Meter: 7
 
More
Cant wait to try this, can someone refer or point out a custom recovery for the tab? I have the pro 10 T520. did a quick search but didnt see much. TIA
8th June 2014, 05:47 PM |#6  
RagingHarry's Avatar
Senior Member
Flag Havelte
Thanks Meter: 139
 
More
Quote:
Originally Posted by StifflerServices

Cant wait to try this, can someone refer or point out a custom recovery for the tab? I have the pro 10 T520. did a quick search but didnt see much. TIA

From the link in cybertronics kernel http://goo.im/devs/OpenRecovery/picassowifi

Sent from my SM-T520 using Tapatalk
Last edited by RagingHarry; 8th June 2014 at 06:15 PM.
8th June 2014, 08:58 PM |#7  
Junior Member
Thanks Meter: 3
 
More
Edit: reinstalled 1.0 rebooted and was able to get the newest to load but will not load after full wipe, stays stuck on samsung logo boot.

Gave it a shot but stuck on samsung logo at boot. Wiped everything again, installed ROM again and still stuck at logo.

Sent from my HTCONE using XDA Free mobile app


Sent from my HTCONE using XDA Free mobile app
9th June 2014, 01:11 AM |#8  
Senior Member
Thanks Meter: 22
 
More
Tried this rom on my t320. Wifi would not activate but bluetooth did. Also about tablet shows version ana1 not ana3.

Sent from my SM-T320 using XDA Free mobile app
9th June 2014, 01:12 AM |#9  
SomeGuyDude's Avatar
Senior Member
Thanks Meter: 220
 
More
Rolling just fine on 10.1 with the stock kernel. Good stuff! This with Xposed means we can have fun.
The Following User Says Thank You to SomeGuyDude For This Useful Post: [ View ]
9th June 2014, 05:23 AM |#10  
Senior Member
Thanks Meter: 111
 
More
can't wait to get it going on the 8.4 but it's pretty jacked up right now. dev will have to look into it. had a heck of a time restoring my backup but hoping it gets fixed cause the aroma installer is awesome
9th June 2014, 04:24 PM |#11  
Member
Thanks Meter: 34
 
More
Quote:
Originally Posted by SomeGuyDude

Rolling just fine on 10.1 with the stock kernel. Good stuff! This with Xposed means we can have fun.

So... did you have to do anything special to get this going with "no problems?" My 10.1 is rooted, and TWRP is installed. What do I need to wipe? Just Data/Cache/Dalvik? Anything else I should be aware of?

I ask because, apparently not everyone else has has as smooth a load as you have!

Also, is there anything... anything at all... that is not working as it should?

I'm ready to do this, but I'd prefer to do it once and then get nice and comfy with my new (debloated/smooth) ROM.

Thanks!

Read More
Thread Closed Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes