Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,137 Members 50,921 Now Online
XDA Developers Android and Mobile Development Forum

How can I disable the capacitive buttons (back, menu) and physical home button on my

Tip us?
 
Jnn1
Old
#1  
Senior Member - OP
Thanks Meter 57
Posts: 319
Join Date: Nov 2010
Default How can I disable the capacitive buttons (back, menu) and physical home button on my

I'm generally very happy with my galaxy note 10.1, but often find myself unintentionally pressing the home button or menu/back button. This happens especially often in portrait mode, but also in landscape mode, as I tend to hold the tablet with one hand with my thumb on top.

I've searched the forums, and haveroot, but with the kitkat update, I'm not sure what the proper way to mode and disable capacitive and physical buttons are. Even if I lose some screen space, I'd prefer to have soft keys like a nexus tablet, for ease of use in both portrait and landscape mode.

All help and leads very much appreciated!

Sent from my SM-P600 using XDA Premium 4 mobile app
The Following User Says Thank You to Jnn1 For This Useful Post: [ Click to Expand ]
 
Jnn1
Old
(Last edited by Jnn1; 20th May 2014 at 05:00 PM.)
#2  
Senior Member - OP
Thanks Meter 57
Posts: 319
Join Date: Nov 2010
Default [Q] how to space onscreen navigation buttons (softkeys)

Digging around the Internet and other forums, found the answers to my questions (since solutions for other galaxy devices work on ours too). So, in the spirit of sharing,

So, assuming one has root and a file explorer to exploit root and edit texts,


To disable the capacitive menu and back keys:

Add "#" in front of "key 139 menu" and "key 158 back" in the Generic.kl file in system\usr\keylayout folder.


To disable the physical home button:

Delete "WAKE" behind "key 172" in the gpio-keys.kl file in system/usr/keylayout/ folder.


To add onscreen softkeys for back / home / recents:

Add "qemu.hw.mainkeys=0" to build.prop file in the system folder.


One remaining problem, as you can see in the screen shot below, is that the soft keys are spaced out as if the tablet was a phone.

If anyone knew how to fix this, I'd n really appreciate the help! Thanks



Sent from my SM-P600 using XDA Premium 4 mobile app
Attached Thumbnails
Click image for larger version

Name:	1400530113152.jpg
Views:	171
Size:	114.7 KB
ID:	2752763  
The Following 4 Users Say Thank You to Jnn1 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes