Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,690 Members 47,328 Now Online
XDA Developers Android and Mobile Development Forum

Noob rooting probs. Need help

Tip us?
 
watchmuu
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 12
Join Date: May 2014
Default Noob rooting probs. Need help

Basic rundown, I bought an HTC One M8 on tmoblie yesterday, coming off an iphone 4. I've heard you have have have to root your android devices, so that was one of the very first things I did. Shortly after, I was trying to figure out exactly what I could do with the root, and decided to flash a custom ROM. I tried the Google Play edition posted on the dev section of this same forum. Everything worked as planned, except for one huge problem: my data no longer works. I can connect to wifi fine, as well as send texts, but no 4g lte access anymore. Idk if this is a common problem, if I'm doing something simple wrong, etc. I made a backup in TWRP, and saved it to my desktop, and tried restoring my phone to see if that would help, but I must have dne something wrong there too, as it doesn't show any files when I try to restore under TWRP.*

I would greatly appreciate any and all help or tips. I'm new to the android rooting scene and should have taken it more slowly. I thought I had done sufficient research, but I guess I ****ed the pooch somewhere along the way. Thanks in advance.

Sent from my HTC One_M8 using XDA-FORUM, powered by appyet.com
 
mbernusg
Old
#2  
mbernusg's Avatar
Senior Member
Thanks Meter 119
Posts: 1,139
Join Date: Mar 2010
Location: NJ
Change apn to fast.tmobile.com from fast.t-mobile.com
I had same issue that's the fix

Sent from my HTC One_M8 using XDA Free mobile app
The Following 3 Users Say Thank You to mbernusg For This Useful Post: [ Click to Expand ]
 
watchmuu
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 12
Join Date: May 2014
Quote:
Originally Posted by mbernusg View Post
Change apn to fast.tmobile.com from fast.t-mobile.com
I had same issue that's the fix

Sent from my HTC One_M8 using XDA Free mobile app
Thank you so much. Simple fix, never would have figured that out myself.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes