Post Reply

Unhappy I/O performance Issue

OP K3A

24th May 2014, 11:17 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Mar 2014
I have slow performance issue in my device. After investigation I found that it may be related to I/O performance. I used AndroBench to double check this and the results are 1/4 in compare to T889 which is considered to be my device

Click image for larger version

Name:	2014-05-24-SQL Lite.png
Views:	59
Size:	215.8 KB
ID:	2760406

Click image for larger version

Name:	2014-05-24-Rand R-W.png
Views:	53
Size:	232.3 KB
ID:	2760407

Click image for larger version

Name:	2014-05-24-Seq R-W.png
Views:	56
Size:	202.5 KB
ID:	2760408

Click image for larger version

Name:	2014-05-24-all.jpg
Views:	55
Size:	51.8 KB
ID:	2760409

My device is T889, Rooted
ROM Android 4.3, DN3 V3.1.1 LTE
Kernel Version 3.0.31-2118172 se.infra@SEP-135 #1 (Stock)

Background Applications:
Samsung Account (Sync turned off)
Email (using Microsoft exchange)
Gmail (two accounts, contacts, email, and calendar only )
Twitter (Sync turned off)
LinkedIN (Sync LinkedIN Data)
Yahoo mail
Skype (Sync turned off)
Telegram (Sync turned off)
Lync 2013 (Sync turned off)
SoundCloud

Major Applications:
XPrivacy
Smart App Lock
Xposed Installer

I need you advice how to boost I/O performance to the normal level as it should be

Thanks
25th May 2014, 07:57 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Mar 2014
call for experts
Views: 62 without any reply ... please help me
Last edited by K3A; 25th May 2014 at 08:01 AM. Reason: spelling mistake
25th May 2014, 10:26 AM   |  #3  
Coug76's Avatar
Senior Member
Flag East of Seattle
Thanks Meter: 749
 
1,982 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by K3A

Views: 62 without any reply ... please help me

Try using an app that has been updated within the last 2+ years. The one you decided on was last updated in February of 2012. Abandonware is not usually going to give the best results.

Benchmarks are arbitrary and have no real meaning. The one you went with doesn't really say what is being tested. Your results seem to be related to SD card performance. Try a more reputable app such as Antutu or similar if you simply must delve into benchmarking.



Hastily spouted for your befuddlement
25th May 2014, 11:06 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Mar 2014
Question
Quote:
Originally Posted by Coug76

Try using an app that has been updated within the last 2+ years. The one you decided on was last updated in February of 2012. Abandonware is not usually going to give the best results.

Benchmarks are arbitrary and have no real meaning. The one you went with doesn't really say what is being tested. Your results seem to be related to SD card performance. Try a more reputable app such as Antutu or similar if you simply must delve into benchmarking.



Hastily spouted for your befuddlement

Thank you ... I installed the last version of Antutu after that I did unmount to ext-sd card and then I/O test . the result is attached below

Click image for larger version

Name:	Screenshots_2014-05-25-12-58-42.jpg
Views:	61
Size:	45.1 KB
ID:	2762082

appreciate your advice
27th May 2014, 10:13 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
17 posts
Join Date:Joined: Mar 2014
Question call for experts
Is there any quick enhancement that I can add/modify to the kernel that increase the performance of I/O ?
30th May 2014, 11:54 PM   |  #6  
BRANDENDEUCE's Avatar
Senior Member
Flag MEMPHIS
Thanks Meter: 34
 
191 posts
Join Date:Joined: Jul 2008
Donate to Me
More
http://forum.xda-developers.com/show....php?t=2602053

Sent from my SGH-T889 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread

Tags
i/o problem, performance, sqllite
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes