FORUMS

SM-P601 Downgrade from China Kitkat to Jelly Bean Fails. Please help

5 posts
Thanks Meter: 0
 
By poshkid, Junior Member on 31st May 2014, 12:38 PM
Post Reply Subscribe to Thread Email Thread
I tried to downgrade from china SM-P601 kit kat firmware to Jelly Bean version. Then I get the following error at ODIN.

SW REV. CHECK FAIL. DEVICE : 3, BINARY:2

Can anyone of you help , please
 
 
31st May 2014, 01:23 PM |#2  
droidan's Avatar
Senior Member
Thanks Meter: 33
 
More
Quote:
Originally Posted by poshkid

I tried to downgrade from china SM-P601 kit kat firmware to Jelly Bean version. Then I get the following error at ODIN.

SW REV. CHECK FAIL. DEVICE : 3, BINARY:2

Can anyone of you help , please

Maybe you can try try to downgrade to Jellybean from the same region(China).
If it still fails, meaning your current P601 Bootloader doesn't allow to downgrade to Jellybeans once update to KK.
31st May 2014, 04:34 PM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Thumbs up Thanks for the reply
Quote:
Originally Posted by droidan

Maybe you can try try to downgrade to Jellybean from the same region(China).
If it still fails, meaning your current P601 Bootloader doesn't allow to downgrade to Jellybeans once update to KK.

Thank you for the explanation. I tried to use Russian Kitkat version and it worked.

Please don't use the chi a firmware; since it doesnot have google play store or any google stuff.
Russian firmware is ok. It has all google stuff plus extras.

Hope this helps for anyone with a similar issue.
31st May 2014, 04:52 PM |#4  
droidan's Avatar
Senior Member
Thanks Meter: 33
 
More
Quote:
Originally Posted by poshkid

Thank you for the explanation. I tried to use Russian Kitkat version and it worked.

Please don't use the chi a firmware; since it doesnot have google play store or any google stuff.
Russian firmware is ok. It has all google stuff plus extras.

Hope this helps for anyone with a similar issue.

Cool...

Btw, are you downgrading to Jellybean or upgrading to Kitkat from Russian?
Can you explain please....
31st May 2014, 05:37 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Exclamation Russian Kitkat
Quote:
Originally Posted by droidan

Cool...

Btw, are you downgrading to Jellybean or upgrading to Kitkat from Russian?
Can you explain please....

Well, I could only install Russian Kikat version. I guess anyone who tried kitkat on SM-P601 would not be able to downgrade due to boot loader issue.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes