Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Running 4.3 ROMs with Safestrap 3.72?

OP zebra72

26th May 2014, 09:29 PM   |  #1  
OP Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jul 2013
Hi all,

I just bought a new i337 and it came with the NB1 bootloader, NB1 stock, and I followed all the steps to downgrade, etc and have SafeStrap 4.72 running it with a rooted NB1 stock firmware. However, there are some things I like about 4.3, and I would like to run SHOSTOCK (JellyBean version), but I know that I flashed a NB1 Kernel through ODIN as part of running the rooted NB1 stock. Do I have to start over and downgrade it back to MK2? Or is it as simple as just installing the SHOSTOCK for Safestrap in SafeStrap 4.72 even though in the SHOSTOCK thread they don't mention anything about 4.72, just 4.71. I guess I'm just concerned about the kernels not matching with the locked bootloader and all.

Thanks in advance for any help!
26th May 2014, 10:34 PM   |  #2  
Senior Member
Thanks Meter: 1,972
 
1,398 posts
Join Date:Joined: Jun 2012
Donate to Me
Quote:
Originally Posted by zebra72

Hi all,

I just bought a new i337 and it came with the NB1 bootloader, NB1 stock, and I followed all the steps to downgrade, etc and have SafeStrap 4.72 running it with a rooted NB1 stock firmware. However, there are some things I like about 4.3, and I would like to run SHOSTOCK (JellyBean version), but I know that I flashed a NB1 Kernel through ODIN as part of running the rooted NB1 stock. Do I have to start over and downgrade it back to MK2? Or is it as simple as just installing the SHOSTOCK for Safestrap in SafeStrap 4.72 even though in the SHOSTOCK thread they don't mention anything about 4.72, just 4.71. I guess I'm just concerned about the kernels not matching with the locked bootloader and all.

Thanks in advance for any help!

Safestrap v3.72 will mount on both 4.4 and 4.3 kernels. No need to switch back to v3.71.
Last edited by muniz_ri; 26th May 2014 at 10:37 PM.
27th May 2014, 12:43 AM   |  #3  
OP Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by muniz_ri

Safestrap v3.72 will mount on both 4.4 and 4.3 kernels. No need to switch back to v3.71.

Thanks for the quick response and answer.

Just a quick clarification, I cannot use Safestrap 3.71 anyway due to my phone having the NB1 bootloader, right? I thought v 3.71 was only for those on MK2 or below.

Thanks again for all your awesome work on finding workarounds for rooting NB1 phones and above!
The Following User Says Thank You to zebra72 For This Useful Post: [ View ]
27th May 2014, 12:52 AM   |  #4  
Senior Member
Thanks Meter: 1,972
 
1,398 posts
Join Date:Joined: Jun 2012
Donate to Me
Quote:
Originally Posted by zebra72

Thanks for the quick response and answer.

Just a quick clarification, I cannot use Safestrap 3.71 anyway due to my phone having the NB1 bootloader, right? I thought v 3.71 was only for those on MK2 or below.

Thanks again for all your awesome work on finding workarounds for rooting NB1 phones and above!

No the SS version has more to do with your kernel not the BL. You can theoretically flash a 4.3 ROM using SS 3.71 on your 4.4 BL. There are additional requirements like modules, etc that I won't get into.
The Following User Says Thank You to muniz_ri For This Useful Post: [ View ]
1st June 2014, 08:10 AM   |  #5  
OP Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jul 2013
Well, I was trying to installing SHOStock 3.0- safestrap version today, and I kept getting the "cannot mount /system" in SafeStrap while installing. After rebooting a couple of times, I think I stupidly decided to do an advanced wipe of /system (among others). Do I have to go all the way back to stock NB1 (Original NB1), and then start the whole process to MK2->Root -> Safestrap all over again?

Thanks for any help!
1st June 2014, 09:40 AM   |  #6  
Rhymey's Avatar
Member
Thanks Meter: 12
 
74 posts
Join Date:Joined: Apr 2014
More
Quote:
Originally Posted by zebra72

Well, I was trying to installing SHOStock 3.0- safestrap version today, and I kept getting the "cannot mount /system" in SafeStrap while installing. After rebooting a couple of times, I think I stupidly decided to do an advanced wipe of /system (among others). Do I have to go all the way back to stock NB1 (Original NB1), and then start the whole process to MK2->Root -> Safestrap all over again?

Thanks for any help!

Yup. Boot into download mode and start all over.
The Following User Says Thank You to Rhymey For This Useful Post: [ View ]
1st June 2014, 06:45 PM   |  #7  
Senior Member
Thanks Meter: 1,972
 
1,398 posts
Join Date:Joined: Jun 2012
Donate to Me
Quote:
Originally Posted by zebra72

Well, I was trying to installing SHOStock 3.0- safestrap version today, and I kept getting the "cannot mount /system" in SafeStrap while installing. After rebooting a couple of times, I think I stupidly decided to do an advanced wipe of /system (among others). Do I have to go all the way back to stock NB1 (Original NB1), and then start the whole process to MK2->Root -> Safestrap all over again?

Thanks for any help!

Use the downgrade to MK2 file from this thread then root and install safestrap: http://forum.xda-developers.com/show....php?t=2692825
The Following User Says Thank You to muniz_ri For This Useful Post: [ View ]
1st June 2014, 07:14 PM   |  #8  
OP Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by muniz_ri

Use the downgrade to MK2 file from this thread then root and install safestrap: http://forum.xda-developers.com/show....php?t=2692825

Thanks for all the quick replies. Just to recap, ODIN back to Stock NB1 (no need to uninstall the remnants of SafeStrap I have now?), Downgrade to MK2, Root, Safestrap.

Also, I'm not sure what I did wrong when I went from rooted Stock NB1 to try to flash SHOStock 3.0 (which was 4.3). I honestly wasn't paying attention to the messages, so maybe I had a unable to mount /system error then, but then I went to reboot it, just was blank. That's when I decided to be stupid and go to recovery to advanced wipe including /system. I guess now if I want to run SHOStock 3.0, or whatever ROM, I can just install it once I have Safestrap rather than installing the Rooted ROM and kernel, right?

Thanks again!
1st June 2014, 07:24 PM   |  #9  
Senior Member
Thanks Meter: 1,972
 
1,398 posts
Join Date:Joined: Jun 2012
Donate to Me
Quote:
Originally Posted by zebra72

Thanks for all the quick replies. Just to recap, ODIN back to Stock NB1 (no need to uninstall the remnants of SafeStrap I have now?), Downgrade to MK2, Root, Safestrap.

Also, I'm not sure what I did wrong when I went from rooted Stock NB1 to try to flash SHOStock 3.0 (which was 4.3). I honestly wasn't paying attention to the messages, so maybe I had a unable to mount /system error then, but then I went to reboot it, just was blank. That's when I decided to be stupid and go to recovery to advanced wipe including /system. I guess now if I want to run SHOStock 3.0, or whatever ROM, I can just install it once I have Safestrap rather than installing the Rooted ROM and kernel, right?

Thanks again!

No need to odin back to stock NB1, the downgrade file will get you back to a semi-functioning(no-wifi) MK2 at which point you can root and install safestrap. From there go to the SHoStock thread for instructions on how to properly install that particular ROM.
1st June 2014, 08:07 PM   |  #10  
OP Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by muniz_ri

No need to odin back to stock NB1, the downgrade file will get you back to a semi-functioning(no-wifi) MK2 at which point you can root and install safestrap. From there go to the SHoStock thread for instructions on how to properly install that particular ROM.

Thanks again for the quick reply.

Just to clarify, I guess I'm really confused about what kernel I would have if I flash the downgrade file? Would it overwrite the NB1 kernel I flashed after I flashed the rooted stock NB1 in Safestrap? I noticed that in going to rooted stock NB1 (or NC1), you have to ODIN flash the kernel.

Thanks again.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes