Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

lost IMEI after flashing CM11 M5

OP ksio89

7th April 2014, 04:35 PM   |  #1  
ksio89's Avatar
OP Member
Thanks Meter: 10
 
72 posts
Join Date:Joined: May 2013
More
After I flashed CM11 SNAPSHOT M5 on my Brazilian Optimus G E977 model (firmware version E97710d), I faced several crashes with "Subsystem crash" BSOD, with Demigod Handler issue or something like that . Several reboots later, the crashes stopped, however the mobile network was not working. Checked IMEI on status menu it was reported as null. I have a backup of EFS partition performed by FreeGee.

I tried all the tools available that I've found

1-flash a zip package containing the the 3 backed up .img files in CWM Recovery mode;

2-downloaded cwm-lgog_e977-brazil_10b-modem.zip from the EFS and MODEM backup/restore tutorial and flashed the modem zip package (replacing the modem.img with the one from my phone extracted with adb) ;

3-flashing stock firmware;

But still null IMEI and no network signal. Is there anything else I can try? Maybe if I get a specific file from another E977 model?
Last edited by ksio89; 7th April 2014 at 05:17 PM.
7th April 2014, 10:20 PM   |  #2  
metrixx02's Avatar
Senior Member
Flag Izmir
Thanks Meter: 14
 
277 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by ksio89

After I flashed CM11 SNAPSHOT M5 on my Brazilian Optimus G E977 model (firmware version E97710d), I faced several crashes with "Subsystem crash" BSOD, with Demigod Handler issue or something like that . Several reboots later, the crashes stopped, however the mobile network was not working. Checked IMEI on status menu it was reported as null. I have a backup of EFS partition performed by FreeGee.

I tried all the tools available that I've found

1-flash a zip package containing the the 3 backed up .img files in CWM Recovery mode;

2-downloaded cwm-lgog_e977-brazil_10b-modem.zip from the EFS and MODEM backup/restore tutorial and flashed the modem zip package (replacing the modem.img with the one from my phone extracted with adb) ;

3-flashing stock firmware;

But still null IMEI and no network signal. Is there anything else I can try? Maybe if I get a specific file from another E977 model?


my friend can u us any custom rom ?? if u have external modem error (subsystem crash error ) say me i have one idea
The Following User Says Thank You to metrixx02 For This Useful Post: [ View ]
8th April 2014, 12:08 AM   |  #3  
ksio89's Avatar
OP Member
Thanks Meter: 10
 
72 posts
Join Date:Joined: May 2013
More
Yeah, I flashed stock firmware and performed a factory reset, it was clean. Then I proceed to root, install FreeGee, BusyBox and then CWM 6.0.4.7 and then flashed the CM11 M5 ROM, has been stable for a while, then it crashed. This is the report:

"DemiGod Crash Handler : Subsystem Crash! : External_modem (Undefined error)"

BTW, I performed a backup of EFS partition 3 img files with FreeGee.

I had to flash stock firmware once more due to crashing, it's completely unstable with CM11 M5, I'll flash CM11 M4 which was perfectly fine and see if it becomes stable.

EDIT: still crashing with CM11 M4, the latest CM ROM really screwed my phone.

EDIT 2: sent my phone to local repair service and the main board was replaced, with a new IMEI. It seems there was indeed a hardware issue. I had a SIM card which I had it adapted into microSIM format but it wasn't recognized by my OG. After the motherboard replacement, it's being recognized now. I have backed up EFS partitions and modem packages following the tutorials on Q&A. But I'm enjoying stock ROM, it has some nice features which I didn't find in CM11, I'll stick with it for a while. I don't believe there will be any more issues regarding CM11 though.
Last edited by ksio89; 14th April 2014 at 05:01 PM.
6th June 2014, 04:38 PM   |  #4  
metrixx02's Avatar
Senior Member
Flag Izmir
Thanks Meter: 14
 
277 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by ksio89

Yeah, I flashed stock firmware and performed a factory reset, it was clean. Then I proceed to root, install FreeGee, BusyBox and then CWM 6.0.4.7 and then flashed the CM11 M5 ROM, has been stable for a while, then it crashed. This is the report:

"DemiGod Crash Handler : Subsystem Crash! : External_modem (Undefined error)"

BTW, I performed a backup of EFS partition 3 img files with FreeGee.

I had to flash stock firmware once more due to crashing, it's completely unstable with CM11 M5, I'll flash CM11 M4 which was perfectly fine and see if it becomes stable.

EDIT: still crashing with CM11 M4, the latest CM ROM really screwed my phone.

EDIT 2: sent my phone to local repair service and the main board was replaced, with a new IMEI. It seems there was indeed a hardware issue. I had a SIM card which I had it adapted into microSIM format but it wasn't recognized by my OG. After the motherboard replacement, it's being recognized now. I have backed up EFS partitions and modem packages following the tutorials on Q&A. But I'm enjoying stock ROM, it has some nice features which I didn't find in CM11, I'll stick with it for a while. I don't believe there will be any more issues regarding CM11 though.

my friend .hey u here ? u have external moder error now ?

i have one answer this
6th June 2014, 05:50 PM   |  #5  
ksio89's Avatar
OP Member
Thanks Meter: 10
 
72 posts
Join Date:Joined: May 2013
More
No, mate, no errors after the mobo replacement. One of these days I installed CM11 M6 and there were no crashes or errors related to modem. As I said, it was a hardware issue, from what I read, the most probable cause was a not complete functional power state, which caused the tension to drop excessiely, crashing the OS, corrupting the EFS/modem software and wiping the phone IMEI.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes