Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,870 Members 50,084 Now Online
XDA Developers Android and Mobile Development Forum

[ROM] Evervolv | 3.3.0p1 [AOSP 4.3.1] W/UMS support and working BT

Tip us?
 
flintman
Old
(Last edited by flintman; 29th January 2014 at 08:00 PM.)
#1  
Recognized Developer - OP
Thanks Meter 1846
Posts: 577
Join Date: Feb 2011
Location: MASS
Default [ROM] Evervolv | 3.3.0p1 [AOSP 4.3.1] W/UMS support and working BT

For those that don't know what evervolv is, Evervolv is an AOSP (Android Open Source Project) rom. We're fully open sourced and encourage it with no restrictions. The work put into this rom is community driven and and Evervolv Project is made up of numerous members and contributors.

Right now the current source we are working on is Jellybean (Android 4.3).

Current version: 3.3.0p1

Current Items not working/Buggy
Quote:

You tell me what you find.
Quote:
Evervolv Github: https://github.com/Evervolv

Evervolv Gerrit: http://review.evervolv.com/

Evervolv website: http://www.evervolv.com/
(New Site is up Check it out)

Evervolv Bug Tracker: http://bugs.evervolv.com/
(Please have discretion when reporting issues, and be descriptive / helpful. Also understand that we'll have some growing pains with this. So don't expect everything to be perfect.)

Twitter: https://www.twitter.com/wbellavance

IRC: #evervolv
Quote:
[GPL Compliance]
Kernel Source
Quote:
[Download]



Ok here is a Bluetooth Test build. I want to say once the rom starts give it a few before turning on bluetooth for the first time. This seems to take care Bluetooth not starting the first time. Also be patient does take a few to start up. If you get any type of bluetooth error restart before turning on Bluetooth. My first time installing didn't work out so well. After the second time bluetooth had no issues starts right up. So i'm curious on your experience with it. Let me know.

Jellybean 4.3.1 1-27-2014 Test build With BT and MTP/UMS support --Fix reboot with UMS and transfering files


Jellybean 4.3.1 1-29-2014 Test build With BT and MTP/UMS support --This should take care of the BT connection issues as i have connected to a bunch of devices first shot now
Flashing from cm or any other ROM will require a clean install, dirty flashes can cause random reboots and random errors

Quote:


[Disclaimer]
I am not responsible for bricked devices, lost data, etc, etc. You all know the drill.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-08-26-11-44-56.jpg
Views:	7454
Size:	27.8 KB
ID:	2214938  
The Following 42 Users Say Thank You to flintman For This Useful Post: [ Click to Expand ]
 
flintman
Old
(Last edited by flintman; 17th October 2013 at 06:11 PM.)
#2  
Recognized Developer - OP
Thanks Meter 1846
Posts: 577
Join Date: Feb 2011
Location: MASS
For all having issues with UMS and Windows try this

1. Go into Device manager. You will see "MTP USB Device" under portable devices.

2. Right Click it and select update driver software

3. Select Browse my computer for driver software.

4. Select Let me pick from a list of device drivers on my computer

5. Select USB Mass Storage Device then click next.
The Following 5 Users Say Thank You to flintman For This Useful Post: [ Click to Expand ]
 
DanFunky
Old
#3  
Junior Member
Thanks Meter 3
Posts: 18
Join Date: Nov 2007
Location: St. Charles, Missouri
I'm happy to test, and will give feedback, just nervous without an MD5 as I've been burned with that several times.

I got 51FAF49CAAD109204B0368AAF59684DF.
 
flintman
Old
#4  
Recognized Developer - OP
Thanks Meter 1846
Posts: 577
Join Date: Feb 2011
Location: MASS
Quote:
Originally Posted by DanFunky View Post
I'm happy to test, and will give feedback, just nervous without an MD5 as I've been burned with that several times.

I got 51FAF49CAAD109204B0368AAF59684DF.
MD5 51faf49caad109204b0368aaf59684df
The Following User Says Thank You to flintman For This Useful Post: [ Click to Expand ]
 
MerenQue
Old
(Last edited by MerenQue; 26th August 2013 at 04:48 PM.)
#5  
Member
Thanks Meter 22
Posts: 57
Join Date: Mar 2013
With TWRP 2.6.0.0 I wiped TouchPad first than I flashed your ROM with Gapps for Android 4.3: http://wiki.rootzwiki.com/Google_Apps#20130813

Quote:
Current Items not working/Buggy

Quote:
  • No Bluetooth
  • No camera


You tell me what you find.
1.) In my case "Turning Wifi on" doesn' t work.
2.) SOD (“sleep of death”): Screen goes off but I couldn't wake it up by pushing the power button.
3.) Reboots by itself.
 
flintman
Old
#6  
Recognized Developer - OP
Thanks Meter 1846
Posts: 577
Join Date: Feb 2011
Location: MASS
Quote:
Originally Posted by MerenQue View Post
With TWRP 2.6.0.0 I wiped TouchPad first than I flashed your ROM with Gapps for Android 4.3: http://wiki.rootzwiki.com/Google_Apps#20130813


1.) In my case "Turning Wifi on" doesn' t work.
2.) SOD (“sleep of death”): Screen goes off but I couldn't wake it up by pushing the button.
Try to flash with out the gapps and see if it works i have tried both ways with no issue. Also if you can get a logcat that would be great
The Following 2 Users Say Thank You to flintman For This Useful Post: [ Click to Expand ]
 
DanFunky
Old
#7  
Junior Member
Thanks Meter 3
Posts: 18
Join Date: Nov 2007
Location: St. Charles, Missouri
I have no problem with WiFi. multiple users works great so far, and can't be happier.

I did a full reset, wiped everything including SD card and copied it over under WebOS to be sure.

I'm on TWRP 2.3.3.0, and the only thing I've noticed is rebooting into anything like bootloader or recovery always defaults back into the menu with Evervolv selected, but you can always use the menu to select something else.

Love the new toolbox (although the multi-way UI takes some getting used to...trying to please everyone I assume) and updater...I just used it to install GApps which is FANTASTIC!!! Thanks for having core and full GApps.

Great so far, I'll kick the tires more today.
The Following User Says Thank You to DanFunky For This Useful Post: [ Click to Expand ]
 
MerenQue
Old
#8  
Member
Thanks Meter 22
Posts: 57
Join Date: Mar 2013
Quote:
Originally Posted by flintman View Post
Try to flash with out the gapps and see if it works i have tried both ways with no issue. Also if you can get a logcat that would be great
I didn't know that Gapps 4.3 is implemented in Evervolv. Now I've flashed it without the gapps and have no SOD and no Reboots anymore! But still "Turning Wi-Fi on..." - without success.
To make a LogCat for you I tried to install via USB "KernelTuner-4.4.7.apk" - everything fine so far - but I don't have a File Manager to install the apk. Sorry.
 
flintman
Old
#9  
Recognized Developer - OP
Thanks Meter 1846
Posts: 577
Join Date: Feb 2011
Location: MASS
Quote:
Originally Posted by MerenQue View Post
I didn't know that Gapps 4.3 is implemented in Evervolv. Now I've flashed it without the gapps and have no SOD and no Reboots anymore! But still "Turning Wi-Fi on..." - without success.
To make a LogCat for you I tried to install via USB "KernelTuner-4.4.7.apk" - everything fine so far - but I don't have a File Manager to install the apk. Sorry.

I just uploaded another test it's called test 2. Try that out. Also everyone if you could instead of test 1 try test 2 and tell me which one works for everyone.


Thanks.
The Following 2 Users Say Thank You to flintman For This Useful Post: [ Click to Expand ]
 
MerenQue
Old
#10  
Member
Thanks Meter 22
Posts: 57
Join Date: Mar 2013
Default Test 2

WiFi connected successfully!
Big Thanks!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes