So can one root GPE or...?

67 posts
Thanks Meter: 15
By unixon, Member on 3rd June 2014, 05:25 AM
Post Reply Subscribe to Thread Email Thread
Hey guys,

It's been a while since I've been on XDA. Last week I decided to get me an HTC One and so one hour later curiosity has led me to rooting this thing. Only problem is... nothing works. Initially I tried using the "simple" oem unlock. Which should have worked but my terminal gave me a series of error messages informing me that it couldn't access the splash image. So I tried HTC Dev and that doesn't work either. I've spent hours combing every thread on the internet regarding this, and although I've been educated on my initial errors, I've been led in circles.

I am Locked, S-On, 1.54 Hboot, and 4.4.2 Kit Kat. Can I ever root this thing? I'm so surprised that out of all the iterations of the One, the GPE is the one that is impossible to root. Or maybe I'm not paying close enough attention? I've looked at all the S-Off techniques and they don't seem compatible with the GPE? I have no clue. Any help would be great!
3rd June 2014, 02:29 PM |#2  
millicent's Avatar
Senior Member
Flag Montreal
Thanks Meter: 144
the 'simple' unlock method should have worked. I suggest you start again fresh as some things you did might have corrupted some files and reset your device to factory, then reboot to bootloader either via adb or power + vol down, then issue fastboot oem unlock.

you might get some error messages but that should really unlock it. good luck

Sent from my HTC One using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes