Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,905 Members 39,946 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Touch issues even though i have the latest FW?

Tip us?
 
james_lpool
Old
(Last edited by james_lpool; 3rd June 2014 at 08:26 PM.)
#1  
Senior Member - OP
Thanks Meter 10
Posts: 294
Join Date: Apr 2012
Location: Liverpool
Default [Q] Touch issues even though i have the latest FW?

Hi, i have had my tablet for about 1 week, straight after starting it up i had a fw update which is 17.1.1.A.0.402 which i am assuming is the latest?

anyway i have read a lot about the new fw was supposed to fix the touch issues?

I also have the z1 which i still have and is perfect. ive recently updated to 4.4.2 on that and all my issues are fine on there.

my z2 is acting very strange, if i leave it alone for a while sometimes i will go on it and everything on the screen will be frozen, i can't tap anything, i have to press the power button and then swipe to open it again, it is then fine after that.

also i have noticed, and i think its happening a lot when my tablet is a little angled using the case, the screen will be a bit jittery, where as my z1 is really smooth, and i also sometimes have to really tap icons a few times before they register.

i play clash of clans a lot and its been a bit difficult to play as troops aren't selecting as i am tapping on them.

has anyone got any advice?

I have done a factory reset to see if that would fix any issues from the fw update but its still exactly the same.

Thanks

James
Samsung Galaxy S4 I9505
Sony Xperia Z2 Tablet
 
james_lpool
Old
#2  
Senior Member - OP
Thanks Meter 10
Posts: 294
Join Date: Apr 2012
Location: Liverpool
anyone?
Samsung Galaxy S4 I9505
Sony Xperia Z2 Tablet
 
bbarou
Old
(Last edited by bbarou; 4th June 2014 at 08:22 PM.)
#3  
Member
Thanks Meter 17
Posts: 58
Join Date: Jul 2010
Quote:
Originally Posted by james_lpool View Post
anyone?
I installed the new firmware yesterday. While I notice an improvement with the touch problem it's still present. Just install an multitouch app (like this one: https://play.google.com/store/apps/d...abs.multitouch), let your finger trail on the screen and it's definitely obvious (the number on the top right should be the number of fingers touching the screen and it's often not). I tried the same thing on my old Iconia A500 and that's the one thing where it's WAY better than the Z2.

I don't experience anything as strange as you do though, it's mostly usable and I hardly notice it with the new firmware.

I did experience something very strange just BEFORE updating with one specific charger and one specific USB cable , the tablet wouldn't register any touch at all while it's was plugged in. As soon as I unplugged it it would work. The cable was fine with another charger and vice versa;
Weirdest of it all:
This happened while I was testing the output current for each combination of cable/charger and this particular couple was the one giving the "best" results; consistently between 1.1A and 1.2A

I can't reproduce this behaviour with the new firmware. All in all, it's usable for me. Biggest bug would be it not charging while playing power consuming games.
 
james_lpool
Old
#4  
Senior Member - OP
Thanks Meter 10
Posts: 294
Join Date: Apr 2012
Location: Liverpool
I have found mine goes more weird when it goes to sleep and i then wake it up, the screens sensitivity seems to be terrible, i have topress the off button and then start it again then its fine.

it will then mostly stay fine until the screen times out again then the same thing will happen when i wake it.
Samsung Galaxy S4 I9505
Sony Xperia Z2 Tablet
 
Chefproll
Old
#5  
Member
Thanks Meter 22
Posts: 66
Join Date: Apr 2014
James: Same with my 521...
Touchscreen response was REAL BAD after updating to .402, then it went better and better day by day; strange phenomenon.

I also occasionally experience some touchscreen "numbness" after waking up the table with a double-tap, sometimes touch sensitivity suddenly becomes quite low just without any reason; touchscreen has problems detecting touches near the screen corners or doesn't react to touches at all. Solution: Switch to standby, and back on.
At the same time, the Android symbols (Back, Home, last apps) again become difficult to hit.

You can test this by slowly swiping your finger up from the lower bezel towards one of the symbols: If the touchscreen is ok, symbols get highlighted right after your finger reaches the lower edge of the symbol. If the touchscreen malfunctions, you need to move your finger up to the center of the symbols to get them highlighted.
So it smells like a software issue.

Touchscreen problems usually occur two to three times a day of normal use; so I regard it as acceptable - but the problem still isn't fully solved.
 
hasenbein1966
Old
#6  
Senior Member
Thanks Meter 153
Posts: 706
Join Date: Aug 2011
I would say it's a hardware issue which Sony attempts to counterbalance with software patches.

Just like on the Nexus7 (2013). There sfhub released a touchscreen fix which made the problem bearable for most users (with some experimenting with different versions of the fix, because each device is different).

I wrote a PM to sfhub asking him whether he could disclose how his fix works so that Z2 Tablet users perhaps could apply a similar, variable, tailor-made fix to their individual device.

No response, unfortunately.

Perhaps some of you could send the same request to him, and perhaps then he reacts?
 
ChodTheWacko
Old
#7  
Senior Member
Thanks Meter 396
Posts: 1,259
Join Date: Feb 2011
every now and then, after double tap to wake, the tablet is extremely unresponsive.
I also just sleep/wake up again via power button and it's fine after that.

So my but feeling it's a software issue, not hardware issue.

- Frank
Galaxy Note FAQ: http://lishutterbug.com/note
57K and growing!
 
corvuscentaurus
Old
#8  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Jan 2013
Location: berlin
I never had touch problems but after updating to the latest firmware, the tablet is unusable from time to time
 
james_lpool
Old
#9  
Senior Member - OP
Thanks Meter 10
Posts: 294
Join Date: Apr 2012
Location: Liverpool
what's annoying me is that Sony wont seem to admit that there is an issue, i was talking on their live chat to support and they said that's the first time anyone's mentioned that and isn't on any list of any known issues

Which doesn't fill me with confidence on how quick this may get fixed.

The speed in which is gets fixed may determine if i just send the tablet back to Amazon for a full refund, unfortunately i have bought the Sony case and magnetic charger now as well

I'm just really puzzled what to do, what can i do apart from sent it back if Sony wont even acknowledge they are aware of the problem and will release a fix soon

The only thing is because i have now bought the charger and case, i kinda want to keep it.

It was a direct replacement for my Z1 which i still have, and that is also updated to 4.4.2 now, but that shows no touch issues at all.
Samsung Galaxy S4 I9505
Sony Xperia Z2 Tablet
 
hasenbein1966
Old
#10  
Senior Member
Thanks Meter 153
Posts: 706
Join Date: Aug 2011
What's very interesting and revealing:

When Sony was addressed a few days ago regarding battery problems on Tablet Z and a few phones after the Kitkat update, they immediately reacted!

They readily explained that it is a problem with the Google Play Services running amok and that a fix will come.

But it seems that just because this here is a Sony problem (and not one for which another company can be blamed like in the above one), Sony simply doesn't react at all and obviously orders the service employees to lie and say that they haven't heard at all of a touch problem.

Boooo, Sony, shame on you!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Draw a Line and Let Your Device Do the Rest with LineitApp

Over the years, since evenbefore Android entered the scene, we have striven to … more

[APK] Chrome Beta 37 Brings First Traces of Material Design

With Android L on the horizon, it’s no surprise that Google’s … more

Immersive Mode on Unrooted Devices with GMD Full Screen Immersive Mode

Everyone likes screen real estate–no question about that. The … more

Android Wear App Review: EchoWear Song Search – XDA Developer TV

Yesterday on XDA Developer TV, Producer AdamOutler tore down a Samsung … more