Unhappy [Q] Phone Can't flash or back to stock please help

allright so here is what happend to me. i got the htc one x and flashed cm10.2 on it worked good perfectly for a year and then i flashed cm11 that also worked as a charm. then cause i wanted sense back on my htc device i try'd to go back to stock but with root and stuff so i flashed android revolution. the problem with that was when the battery was empty the phone wouln't go back on when the charger was in it so i flashed a RUU and after doing that i was gonna flash back to android revolution to try it again and again the same problem now i want back to stock but it says i cant cause my firmware is higher or something. but also when i flash cwm recovery or twrp i cant flash a zip. also when i sideload i get the error that the file cant be found while i can see the file there. i just want a good working phone back dont care if its viper rom or stock or android revolution please help ?

bootloader info : Relocked ( i can unlock it easely )
emmc-bootmode: disabled
cpu-bootmode : disabled
hwsecure boot : enabled
modem path : off
Contact me

Used Phones


sony ericsson w910i
sony ericsson c902
sony ericsson xperia play (died)
htc one x (stolen)

xperia u [cm11 stable]
htc one x+ [Rooted] (sold)
Nexus 10 [4.4.2] [cm11]
OnePlus one [rooted]