Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,915 Members 42,112 Now Online
XDA Developers Android and Mobile Development Forum

[ion] garbled scratchy sound when making phone calls

Tip us?
 
Spectre51
Old
#1  
Spectre51's Avatar
Recognized Contributor - OP
Thanks Meter 1307
Posts: 3,290
Join Date: Jul 2010

 
DONATE TO ME
Default [ion] garbled scratchy sound when making phone calls

This was being discussed in a unrelated thread so I am starting this one so we can try to figure out what is causing it and who is having this issue.

Basically on stock LT28i. 68 firmware and on LT28h 3.7 firmware I have experienced a garbled scratchy sound when trying to make phone calls. Only thing I have found so far that fixes it is a reboot.

Who else has experienced this issue? I would like to get some more troubleshooting done with everyone before I pass the info along to my Sony Dev contact.

Sent from my Sony Xperia™ ion

Current Phones/Tablets:
Xperia Z1 // Xperia Z Ultra // Lumia 1020 // Xperia Tablet Z // Surface Pro
Accessories
Sony Smartwatch MN2 // Sony Smart Wireless Headset pro MW1 // Smart Bluetooth Handset SBH52 // Z Ultra Power Cover CP12
Past Phones/Tablets:
iPhone 1st Gen/3GS/4S // Nexus One // Dell Streak // Atrix 4g // Lumia 900, 920 // Xperia Play, S, P, ion, TL, Z // iPad 1, 3

Click here for my Xperia firmware downloads.
Use the Thanks button if I helped.
 
-DM-
Old
#2  
Senior Member
Thanks Meter 27
Posts: 108
Join Date: Dec 2010
Quote:
Originally Posted by Spectre51 View Post
This was being discussed in a unrelated thread so I am starting this one so we can try to figure out what is causing it and who is having this issue.

Basically on stock LT28i. 68 firmware and on LT28h 3.7 firmware I have experienced a garbled scratchy sound when trying to make phone calls. Only thing I have found so far that fixes it is a reboot.

Who else has experienced this issue? I would like to get some more troubleshooting done with everyone before I pass the info along to my Sony Dev contact.

Sent from my Sony Xperia™ ion
Happened to me once...didn't think it was a known bug though, this was after I flashed the pre-rooted 6.1.E.3.7...tried to make a few calls when I realized that weird sound, but I could receive calls just fine...did a reboot and back to normal so I didn't think twice about it until I saw your post.
 
lagunabrooks
Old
#3  
Junior Member
Thanks Meter 1
Posts: 5
Join Date: Nov 2010
Location: Laguna Beach
This happens to me several times a week. Since I updated to the latest firmware for the lt28i. Since, upgraded to the latest lt28h, and still have the same issue.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2013-01-24-06-24-40.jpg
Views:	216
Size:	26.1 KB
ID:	1672514  
 
Spectre51
Old
#4  
Spectre51's Avatar
Recognized Contributor - OP
Thanks Meter 1307
Posts: 3,290
Join Date: Jul 2010

 
DONATE TO ME
Default Re: [ion] garbled scratchy sound when making phone calls

So LT28i and LT28h firmware have the issue. Anyone on AT&T firmware have the issue? I'm going to flash back to the AT&T firmware and see if I still get it.

Sent from my Sony Xperia™ ion

Current Phones/Tablets:
Xperia Z1 // Xperia Z Ultra // Lumia 1020 // Xperia Tablet Z // Surface Pro
Accessories
Sony Smartwatch MN2 // Sony Smart Wireless Headset pro MW1 // Smart Bluetooth Handset SBH52 // Z Ultra Power Cover CP12
Past Phones/Tablets:
iPhone 1st Gen/3GS/4S // Nexus One // Dell Streak // Atrix 4g // Lumia 900, 920 // Xperia Play, S, P, ion, TL, Z // iPad 1, 3

Click here for my Xperia firmware downloads.
Use the Thanks button if I helped.
 
wolf0491
Old
#5  
wolf0491's Avatar
Senior Member
Thanks Meter 80
Posts: 861
Join Date: Jan 2009
Default Re: [ion] garbled scratchy sound when making phone calls

I don't remember it on att firmware ever just the lt28h and lt28i versions

Sent from my LT28h using xda app-developers app
Old Phones: Sony Ericsson Xperia X1, Sony Ericsson Xperia x10, HTC Inspire 4G, Motorola Atrix 4G, Sony Xperia Ion
Current Phone: Sony Xperia Z Purple ;]
Running Dirty Unicorns 4.4.4 Rom
Tablet:
ASUS Eee Pad transformer
Running KatKiss JB 4.4.2
johnbyebye Old
#6  
Guest
Thanks Meter
Posts: n/a
Default Re: [ion] garbled scratchy sound when making phone calls

Exact thing happened to me. Only on the international firmware.

Sent from my Optimus G
 
zackspeed
Old
#7  
Senior Member
Thanks Meter 104
Posts: 591
Join Date: Aug 2010
Location: Asheville, NC
I have also run into this. I go to pick up a call or make one and you get all kinds of garble and squeal. I dont recall it ever doing it on the first ICS H firmware but every I and H firmware from then does. Cant say the ATT ones do it as I have never really used them. The only time it seems to do it is when the battery is under 20% or if the device has been on for more than 24 hours with out a re boot.
 
Spectre51
Old
#8  
Spectre51's Avatar
Recognized Contributor - OP
Thanks Meter 1307
Posts: 3,290
Join Date: Jul 2010

 
DONATE TO ME
Default Re: [ion] garbled scratchy sound when making phone calls

What carrier is everyone using that has experienced this? I have had it on AT&T.

Sent from my Sony Xperia™ TL

Current Phones/Tablets:
Xperia Z1 // Xperia Z Ultra // Lumia 1020 // Xperia Tablet Z // Surface Pro
Accessories
Sony Smartwatch MN2 // Sony Smart Wireless Headset pro MW1 // Smart Bluetooth Handset SBH52 // Z Ultra Power Cover CP12
Past Phones/Tablets:
iPhone 1st Gen/3GS/4S // Nexus One // Dell Streak // Atrix 4g // Lumia 900, 920 // Xperia Play, S, P, ion, TL, Z // iPad 1, 3

Click here for my Xperia firmware downloads.
Use the Thanks button if I helped.
 
deathtech
Old
#9  
deathtech's Avatar
Member
Thanks Meter 2
Posts: 35
Join Date: Jul 2011
Default Same

Same here - Lt28at running LT28h on the ATT network. Only cropped up recently.
 
yik12
Old
#10  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jan 2013
Note: I'm on AT&T's network.

I too had this problem when I flashed my LT28at to the LT28i 6.1.E.2.68 build. It appeared to go away for a long while after I reflashed only the modem found in LT28at 6.1.C.1.105 using flashtool. (note: it "appeared" to go away. I don't get very many voice calls...)

Had a failed OTA update the other day which seems to have brought back the initial problems but I cannot verify anything as I am currently at work. A reboot has my phone operating correctly (for now). Will mess with it more later but, from what I read, the lack of reproducibility of this issue may make troubleshooting difficult.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes