Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Galaxy S I9000 only charges with USB cable

OP Drhedphuk

11th June 2014, 02:30 PM   |  #1  
Drhedphuk's Avatar
OP Senior Member
Thanks Meter: 117
 
406 posts
Join Date:Joined: Oct 2012
I am hoping that someone out there can help me. My sgs i9000 does not charge when using the mains charger. It charges when plugged into a laptop is in the USB cable okay though. I have bought, both a new battery and a new charger, but the problem persists. Has anyone had or heard of this problem? Better still, does anyone have a solution?

I thank you all in advance.

Sent from my GT-I9000 using XDA Premium 4 mobile app
11th June 2014, 03:20 PM   |  #2  
aashish.dxa's Avatar
Junior Member
Flag himachal
Thanks Meter: 27
 
28 posts
Join Date:Joined: Apr 2014
More
Take ur phone to service centre

Sent from my GT-S5282 using XDA Premium 4 mobile app
The Following User Says Thank You to aashish.dxa For This Useful Post: [ View ]
11th June 2014, 04:55 PM   |  #3  
idCyber's Avatar
Senior Member
Flag Piatra Neamt
Thanks Meter: 525
 
804 posts
Join Date:Joined: Oct 2012
More
Yeah, your USB port inside the phone is damaged, go to a service center with it to replace the damaged slot

Sent from my GT-I9000 using XDA Premium 4 mobile app
The Following 3 Users Say Thank You to idCyber For This Useful Post: [ View ]
11th June 2014, 05:51 PM   |  #4  
knuckles1978's Avatar
Senior Member
Thanks Meter: 277
 
892 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by idCyber

Yeah, your USB port inside the phone is damaged, go to a service center with it to replace the damaged slot

Sent from my GT-I9000 using XDA Premium 4 mobile app

Thanked you by accident when I went to quote you there

It probably isn't his USB port on the phone if it's charging fine from a laptop with USB cable.

I'd be checking that the charger definitely works by charging another device with it, if you have one. The voltage pins on the phones socket are the same whether you're charging with a charger or plugging into a computers USB, so if one way wasn't working then nothing should be working.

Sent from my GT-I9000 using Tapatalk
The Following User Says Thank You to knuckles1978 For This Useful Post: [ View ]
11th June 2014, 06:25 PM   |  #5  
Drhedphuk's Avatar
OP Senior Member
Thanks Meter: 117
 
406 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by knuckles1978

Thanked you by accident when I went to quote you there

It probably isn't his USB port on the phone if it's charging fine from a laptop with USB cable.

I'd be checking that the charger definitely works by charging another device with it, if you have one. The voltage pins on the phones socket are the same whether you're charging with a charger or plugging into a computers USB, so if one way wasn't working then nothing should be working.

Sent from my GT-I9000 using Tapatalk

Thank you.

The charger charges my wifes phone with no problems. The battery charges in her phone using the mains charger too, so not a battery related problem either.

Sent from my GT-I9000 using XDA Premium 4 mobile app
11th June 2014, 06:31 PM   |  #6  
knuckles1978's Avatar
Senior Member
Thanks Meter: 277
 
892 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by Drhedphuk

Thank you.

The charger charges my wifes phone with no problems. The battery charges in her phone using the mains charger too, so not a battery related problem either.

Sent from my GT-I9000 using XDA Premium 4 mobile app

Could just be the plug on the charger possibly, I've had that happen before. There are two little sprung prongs on one side of it. I've had well used chargers before that I've had to get a pair of pliers and pull them out a little..

The fact that it works on your wife's phone doesn't mean it can't be the plug on your charger. Could just be that your USB port is a tiny bit more worn than hers. Doesn't mean that your port is totally screwed.

Sent from my GT-I9000 using Tapatalk
Last edited by knuckles1978; 11th June 2014 at 06:50 PM.
The Following User Says Thank You to knuckles1978 For This Useful Post: [ View ]
11th June 2014, 07:01 PM   |  #7  
Drhedphuk's Avatar
OP Senior Member
Thanks Meter: 117
 
406 posts
Join Date:Joined: Oct 2012
I have tried three different chargers and none of them charge my phone. I'm very interested in your comment about the USB port being slightly more worn.
I am constantly flashing different Roms etc across using ums/ mtp so that does make sense. Also the USB cable that I use to charge my laptop is an old Nokia cable and the USB connector (phone end) is a little tighter.

Thanks.

Sent from my GT-I9000 using XDA Premium 4 mobile app
9th July 2014, 05:07 PM   |  #8  
sbnaul's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 122
 
282 posts
Join Date:Joined: Apr 2011
More
My phone became a bit wet in the rains (started working after keeping it in rice) and since then even I am facing a similar issue... My auto rotate doesn't go off even after disabling it and my phone only charges even when its connected to the pc... Unable to use it for any sort of data transfer between the phone and the pc... Doesn't get into download mode without using the battery method and odin too doest recognize it... @Drhedphuk if you had some progress please do post here too...
9th July 2014, 09:01 PM   |  #9  
Drhedphuk's Avatar
OP Senior Member
Thanks Meter: 117
 
406 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by sbnaul

My phone became a bit wet in the rains (started working after keeping it in rice) and since then even I am facing a similar issue... My auto rotate doesn't go off even after disabling it and my phone only charges even when its connected to the pc... Unable to use it for any sort of data transfer between the phone and the pc... Doesn't get into download mode without using the battery method and odin too doest recognize it... @Drhedphuk if you had some progress please do post here too...


Hi @sbnaul Unfortunately I haven't had much progress at all. My device connects with Odin & PC etc with no problem, it is just the charging issue using the mains charger. I have discovered that if I push in and hold the usb connector of the mains charger it will charge. Obviously though, none of us have the time to sit there and hold the phone for its charging process. If I have any further progress I will post here. Good Luck with your own problem, that must be a headache.

The Following User Says Thank You to Drhedphuk For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes