Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] It is like hell.... Please help me out from the HELL...

OP gulu20072010

8th June 2014, 04:49 PM   |  #1  
gulu20072010's Avatar
OP Member
Thanks Meter: 2
 
53 posts
Join Date:Joined: Jan 2013
More
I'm from India and I buy SCH-R530U and its working fine but my big big big problem is the charging point or the charger. When I plug the charger its some time charge or some time not. I plug the charger whole night but charge is very slow and I changed the charger and used Indian S2/S3 charger but its not working. Then I check that the USC S3 charger and Indian S2/S3 charger input voltage and output voltage are much difference. So my question is, If I go to Sumsung Care and changed the charger point to Indian S3 I9300, its working or not??? After put Indian S3 charger point to my mobile charging, data transfer or video output working good or not???

Please reply as soon as possible.


Thanks...
10th June 2014, 09:31 AM   |  #2  
ShapesBlue's Avatar
Senior Member
Thanks Meter: 811
 
4,215 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by gulu20072010

I'm from India and I buy SCH-R530U and its working fine but my big big big problem is the charging point or the charger. When I plug the charger its some time charge or some time not. I plug the charger whole night but charge is very slow and I changed the charger and used Indian S2/S3 charger but its not working. Then I check that the USC S3 charger and Indian S2/S3 charger input voltage and output voltage are much difference. So my question is, If I go to Sumsung Care and changed the charger point to Indian S3 I9300, its working or not??? After put Indian S3 charger point to my mobile charging, data transfer or video output working good or not???

Please reply as soon as possible.


Thanks...

First of all your in the USA variant of the S3 Verizon version, your speaking of the US Cellular version. I'd personally trade it for the international S3. It sounds to me like the charging port on the phone is shot. Best bet would be to replace the phone unless you can get someone to fix it or fix it yourself.

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
12th June 2014, 04:00 AM   |  #3  
Member
Thanks Meter: 16
 
75 posts
Join Date:Joined: Oct 2013
More
Agree, sounds like that charging port. Easy solution is to get a wireless receiver and a charging pad (you'll never need the cord in the port again)

Sent from my SCH-I535 using xda app-developers app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes