FORUMS

Analysis & Opinion

Top Forum Discussions

[FIX]Xposed framework lag

1,091 posts
Thanks Meter: 353
 
By Rakuu, Senior Member on 16th June 2014, 07:25 PM
Post Reply Subscribe to Thread Email Thread
For those who expirienced lag/slowness after installing the Xposed framework with no modules or anything, here is a solution:


1. Uninstall Xposed framework
2. Go in /system and open build.prop in a text editor
3. go to the line ( “ro.securestorage.support=true” ) and change it to false
4. Install the xposed framework
5. Clear the app data for S-Health and HealthService
6. Reboot

Credit for this fix goes to cokenet in this thread http://forum.xda-developers.com/show....php?t=2768445


Hope this helps.

Sent from my SAMSUNG-SM-G900A using Tapatalk
Last edited by Rakuu; 17th June 2014 at 06:44 PM.
The Following 12 Users Say Thank You to Rakuu For This Useful Post: [ View ]
 
 
16th June 2014, 10:21 PM |#2  
raynan's Avatar
Senior Member
Thanks Meter: 446
 
More
My solution was to reboot into the recovery, wipe cache and reboot. Not sure if its just temporary, but it seems to work
The Following 2 Users Say Thank You to raynan For This Useful Post: [ View ]
16th June 2014, 10:23 PM |#3  
Senior Member
Flag Mesa
Thanks Meter: 150
 
More
Quote:
Originally Posted by Rakuu

For those who expirienced lag/slowness after installing the Xposed framework with no modules or anything otherwise, here are some possible solutions:

-Disable S-Health
1. Open TiBu
2. Freeze "S-Health" and "healthservice"
3. Reboot

-Disable "secure mode"
1. Uninstall Xposed framework
2. Go in /system and open build.prop in a text editor
3. go to the line ( “ro.securestorage.support=true” ) and change it to false
4. Install the xposed framework
5. Reboot
Credit for this fix goes to cokenet in this thread http://forum.xda-developers.com/show....php?t=2768445


Hope this helps, these can be done in any order. I'll add any other solutions if they are found.

Sent from my SAMSUNG-SM-G900A using Tapatalk

Works great, thanks for pointing that out.
17th June 2014, 07:53 AM |#4  
skyrocketeer's Avatar
Senior Member
Thanks Meter: 129
 
More
In my experience, it wasn't xopsed causing the lag, it was TiBu as it was asking for root access constantly in the background. If you check your super su logs, it might list titanium backup tons of times.

Off-topic: What if I want to use S Health and Xposed? I know Xposed breaks S Health...
17th June 2014, 08:01 AM |#5  
fffft's Avatar
Senior Member
Thanks Meter: 674
 
More
Quote:
Originally Posted by skyrocketeer

Off-topic: What if I want to use S Health and Xposed? I know Xposed breaks S Health...


It doesn't actually. It's an incompatible dependency. There have been a number of threads on the subject, so do a search to confirm the details, but I believe it was the ro.securestorage.support=false property that resolves the issue.
The Following 2 Users Say Thank You to fffft For This Useful Post: [ View ]
17th June 2014, 08:02 AM |#6  
skyrocketeer's Avatar
Senior Member
Thanks Meter: 129
 
More
Just for others' future reference. To fix S health
  1. Make sure the Xposed isn’t installed.
  2. We need to change build.prop file inside the system partition, you can also get it done manually by using a file manager app or get a build prop editor on play store.
  3. Once you find the build.prop file, look for the “ro.securestorage.support=true” line.
  4. Now change the line to “ro.securestorage.support=false”.
  5. Install the Xposed framework again.
  6. The final step is wiping S Health app data, head to System -> App Manager -> ALL -> S Health then wipes the data. Now your Galaxy S5 should be able to runs Xposed framework and S Health simultaneously without any problems.
http://www.andromods.com/fix-trouble...galaxy-s5.html
Last edited by skyrocketeer; 17th June 2014 at 08:12 AM.
The Following 3 Users Say Thank You to skyrocketeer For This Useful Post: [ View ]
17th June 2014, 03:45 PM |#7  
Rakuu's Avatar
OP Senior Member
Houston
Thanks Meter: 353
 
Donate to Me
More
Quote:
Originally Posted by skyrocketeer

Just for others' future reference. To fix S health
[LIST=1][*]Make sure the Xposed isn’t installed.[*]We need to change build.prop file inside the system partition, you can also get it done manually by using a file manager app or get a build prop editor on play store.[*]Once you find the build.prop file, look for the “ro.securestorage.support=true” line.[*]Now change the line to “ro.securestorage.support=false”.[*]Install the Xposed framework again.[*]The final step is wiping S Health app data, head to System -> App Manager -> ALL -> S Health then wipes the data. Now your Galaxy S5 should be able to runs Xposed framework and S Health simultaneously without any problems.

So would it be safe to say that editing the build.prop is the "official solution"?

Sent from my SAMSUNG-SM-G900A using Tapatalk
Last edited by Rakuu; 17th June 2014 at 03:53 PM.
17th June 2014, 06:19 PM |#8  
verks's Avatar
Senior Member
Flag Cleveland, Oh
Thanks Meter: 99
 
More
I would like to hear others results. I rooted last night, changed nothing and have horrible lag.

Sent from my SAMSUNG-SM-G870A using Tapatalk
17th June 2014, 06:35 PM |#9  
dirtydodge's Avatar
Senior Member
Flag Cleveland Tx
Thanks Meter: 294
 
Donate to Me
More
Quote:
Originally Posted by Rakuu

So would it be safe to say that editing the build.prop is the "official solution"?

Sent from my SAMSUNG-SM-G900A using Tapatalk

I changed the Build.Prop as stated and wiped the S Health cache and data and reinstalled xposed framework and so far have not had any problem's with lag

Samsung-SM-G900A
Last edited by dirtydodge; 17th June 2014 at 06:40 PM. Reason: Added My Phone Info
17th June 2014, 06:39 PM |#10  
Rakuu's Avatar
OP Senior Member
Houston
Thanks Meter: 353
 
Donate to Me
More
Quote:
Originally Posted by dirtydodge

I changed the Build.Prop as stated and wiped the S Health cache and data and reinstalled xposed framework and so far have not had any problem's with lag

Alright, ill edit the op.

Sent from my SAMSUNG-SM-G900A using Tapatalk
17th June 2014, 07:19 PM |#11  
fffft's Avatar
Senior Member
Thanks Meter: 674
 
More
Quote:
Originally Posted by Rakuu

So would it be safe to say that editing the build.prop is the "official solution"?

Yes. And you shouldn't need to reinstall Xposed framework either. Just edit the build.prop, wipe cache + Dalvik cache and reboot. That will cure the lag in most cases.

1. Edit the /system/build.prop file, changing ro.securestorage.support=true to ro.securestorage.support=false
2. Wipe cache & Dalvik cache
3. Reboot

Sometimes there may be a secondary cause contributing to the lag. If you have a specific app that is troublesome, it often helps to clear that app's cache and data in the Application manager after doing the above steps.

4. Open the Application Manager (Settings > Applications > Application Manager > All > app name)
5. Clear the app's cache and data
6. Reboot

specific instructions for S-health

Miscellaneous lag tweaks
- Disable S-voice for a more responsive home button

- Freeze Ti backup with Greenify (or close Ti backup when you don't need it). Ti backup frequently requests super user which has been reported to drag some systems down

- Disable system animation. Reduce or turn off system animation:
Settings > General > Developer options > Windows animation scale > off
Settings > General > Developer options > Transition animation scale > off
Settings > General > Developer options > Animator duration scale > off



.
Last edited by fffft; 17th June 2014 at 07:36 PM.

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes