ZArchive Manages Your File Archives

Today smartphones are quite powerful devices that can handle multiple processes at once. In fact, some of … more

Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Android Studio Reaches Release Candidate Status

Android app developers have a few options when comes to Android IDEs. One of the most … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Problem with the partitions on TabPRO?

OP Exlo

22nd June 2014, 09:52 PM   |  #1  
Exlo's Avatar
OP Senior Member
Flag Kopervik
Thanks Meter: 15
 
136 posts
Join Date:Joined: Dec 2009
Donate to Me
More
I own a Galaxy Tab PRO 10.1" Wifi (SM-T520).

I have the stock ROM, rooted and with TWRP. And SDfix...
I have tried fat32 and ext4 on MicroSD, and without MicroSD. No difference.

I cannot boot any custom rom (Stuck at Samsung logo). Sometimes when I try to install a rom, it fails, or reboots TWRP.
I also encountered problem when trying to restore a nandroid. No DATA partition can be written to, restore fails. (after reboot recovery, its no problem to restore)

Angry Birds Epic does not work. It stops at "Loading Levels", and sometimes it fails to start, and says its not installed.
Spotify says that that it cannot be used because it has no storage.

I can access the partitions, but they are not writable. A reboot is getting the internal/external SD to be writabe again.

So, what is the problem with the partitions on TabPRO? or is it the Samsung android rom thats the problem?
Can it be fixed?

Regards,
-Exlo
23rd June 2014, 01:32 PM   |  #2  
dodo99x's Avatar
Senior Member
Flag Ottawa
Thanks Meter: 73
 
331 posts
Join Date:Joined: Apr 2011
More
Try installing FolderMount from the PlayStore. It can detect and fix issues with your partitions. You just need to run it, then reboot. I seem to get issues writing to my data partition after I install TWRP, on my SM-P900. FolderMount fixed it quickly and easily.

https://play.google.com/store/apps/d...evasque.fmount

Sent from my SM-P900 using Tapatalk
The Following User Says Thank You to dodo99x For This Useful Post: [ View ]
24th June 2014, 10:12 AM   |  #3  
Exlo's Avatar
OP Senior Member
Flag Kopervik
Thanks Meter: 15
 
136 posts
Join Date:Joined: Dec 2009
Donate to Me
More
FolderMount did find an error, and fixed it, but same result
And it "fixed" the same problem as the SDfix app did.

But, I still made some progress. I managed to install a custom rom without error, and fully booted.
Team Freeze Rom installed fine. The rom is just under 800Mb. So i thought maybe it was some faulty memory sector on my tab.

Then I tried to flash GigaWatts ROM, and it failed. Same with ProPlus Rom.

When restoring my last nandroid, it fails when writing DATA partition.
Then I tried to restore my first nandroid, from "stock" rom, and it restored just fine.

First nandroid was from internal SD, and latest was from external SD. Made me wondering, so switched yet again another MicroSD, took a nandroid to it, and tried to restore. It fails again at DATA.

Then I tried t install GigaWatts ROM from internal SD, instead of external. Works without error.

Sooo.... I can flash custom ROM`s from Internal Memory, and restore from Internal Memory
Not from external SD.

Still, I do get internal/external SD dropouts, and getting "no space left/no memory to install on", which can be "fixed" by a reboot.(Still, it should`t be like this, and are quite annoying.

But, still no luck on getting past the "Loading Levels" on AngryBirds Epic

Where is the root of the problems? Faulty device? Android ROM? TWRP making trouble?

Please guide me if any logs should be provided to find out where the problems is, if i`m not the only one with these problems.

Regards,
Exlo
24th June 2014, 12:36 PM   |  #4  
dodo99x's Avatar
Senior Member
Flag Ottawa
Thanks Meter: 73
 
331 posts
Join Date:Joined: Apr 2011
More
You can try flashing a stock ROM via Odin, and start from scratch. Factory Reset, Reroot, install twrp, etc. If you still can't write to /data properly, you may need to find a .PIT file and repartition your internal memory using Odin.

Sent from my SM-P900 using Tapatalk
24th June 2014, 01:17 PM   |  #5  
Exlo's Avatar
OP Senior Member
Flag Kopervik
Thanks Meter: 15
 
136 posts
Join Date:Joined: Dec 2009
Donate to Me
More
I have had to reflash stock with Odin 4 times by now, and it has been the same pain every time.
I was hoping not to use re-partition, so I will wait and see if some new info will come by from other users, as I see there are more of the users that struggles with flashing custom rom. (Stuck at samsung logo, installation fails)

So, will hold off for a few days, and if no new info about partitions, rom flashing, low memory, sd cards not mounting correctly, etc, then I will try re-partition...

meanwile, I`ll investigate som more on my own, read overall the internet
26th June 2014, 11:13 AM   |  #6  
Exlo's Avatar
OP Senior Member
Flag Kopervik
Thanks Meter: 15
 
136 posts
Join Date:Joined: Dec 2009
Donate to Me
More
Ok, so i have tried and failed, and learned something on the way

Ext SD is useless for flashing rom, nandroid, etc within TWRP. It does not mount partitions correctly.

If I make sure DATA partition is mounted in recovery, and only use Internal SD, everythin flashes, backups and restores just fine
(Mabye an issure with TWRP?)

SDfix, or FolderMount fixes write permissions to Ext SD in rom to use TitaniumBackup, games, downloads, etc.

Hopes this can help others in simular problems.

And thanks to all that have helped on the way

Regards,
-Exlo
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes