Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,460 Members 40,129 Now Online
XDA Developers Android and Mobile Development Forum

[Q] CyanogenMod 10.2.x won't sent sms

Tip us?
 
Noam Chomsky
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Nov 2013
Arrow [Q] CyanogenMod 10.2.x won't sent sms

Hi everyone,

I just downgraded from cyanogenmod 11 to 10.2.1 - and I found everything works perfectly except for sending sms. E-mails, phone calls - even receiving sms is fine. I try to send an sms and it just gives me a notice saying 'message not sent'. If i look for more details it says 'error -1'.

I've done some googling and found somewhere on another forum that someone else said this was a problem with voice plus in non google voice countries. He didn't say how to fix it though. I've tried uninstalling voice plus, but it didn't seem to work.

I'm based in the UK using three mobile. Everything works fine on cyanogenmod 11 and touchwiz - I downgraded because of the stability issues in the latest cyanogenmod snapshot. Tried Slimrom but it wouldn't load on first boot for some reason.

If anyone could tell me his to get this working in be very grateful.

Thanks a lot.
 
ShapesBlue
Old
(Last edited by ShapesBlue; 29th April 2014 at 09:42 PM.)
#2  
ShapesBlue's Avatar
Senior Member
Thanks Meter 545
Posts: 2,445
Join Date: May 2012
Location: Upstate NY
Quote:
Originally Posted by Noam Chomsky View Post
Hi everyone,

I just downgraded from cyanogenmod 11 to 10.2.1 - and I found everything works perfectly except for sending sms. E-mails, phone calls - even receiving sms is fine. I try to send an sms and it just gives me a notice saying 'message not sent'. If i look for more details it says 'error -1'.

I've done some googling and found somewhere on another forum that someone else said this was a problem with voice plus in non google voice countries. He didn't say how to fix it though. I've tried uninstalling voice plus, but it didn't seem to work.

I'm based in the UK using three mobile. Everything works fine on cyanogenmod 11 and touchwiz - I downgraded because of the stability issues in the latest cyanogenmod snapshot. Tried Slimrom but it wouldn't load on first boot for some reason.

If anyone could tell me his to get this working in be very grateful.

Thanks a lot.
You may want to post this in the international S3 forums as you've posted this in the USA variant of the VZW S3

http://forum.xda-developers.com/galaxy-s3

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
VZW S3 - SOKP/MOAR
SGT2 7.0 - Mokee OS 4.4.2/SOKP
 
Noam Chomsky
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Nov 2013
Quote:
Originally Posted by ShapesBlue View Post
You may want to post this in the international S3 forums as you've posted this in the USA variant of the VZW S3

http://forum.xda-developers.com/galaxy-s3

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
Thanks Shapes - this is a US Verizon S3, I'm just using it in the UK. That's never been a problem until now. I tried the latest stable AOKP, (also JellyBean) and it had exactly the same problem. So I think it's pretty safe to say this is an AOSP JellyBean issue. Does anyone know of a stable KitKat rom for the D2VZW?

I've reinstalled the CM11 M3 snapshot for now, but would love something a bit more reliable. I might check out Synergy Rom, as I think that's based off TouchWiz rather than AOSP - just a bit reluctant to go back to Touchwiz for some reason.
 
ShapesBlue
Old
#4  
ShapesBlue's Avatar
Senior Member
Thanks Meter 545
Posts: 2,445
Join Date: May 2012
Location: Upstate NY
Quote:
Originally Posted by Noam Chomsky View Post
Thanks Shapes - this is a US Verizon S3, I'm just using it in the UK. That's never been a problem until now. I tried the latest stable AOKP, (also JellyBean) and it had exactly the same problem. So I think it's pretty safe to say this is an AOSP JellyBean issue. Does anyone know of a stable KitKat rom for the D2VZW?

I've reinstalled the CM11 M3 snapshot for now, but would love something a bit more reliable. I might check out Synergy Rom, as I think that's based off TouchWiz rather than AOSP - just a bit reluctant to go back to Touchwiz for some reason.
Oh ok. Wasn't sure about that. As far as stable I'd say synergy is good, along with beanstalk to name a few

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
VZW S3 - SOKP/MOAR
SGT2 7.0 - Mokee OS 4.4.2/SOKP
The Following User Says Thank You to ShapesBlue For This Useful Post: [ Click to Expand ]
 
Noam Chomsky
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Nov 2013
Quote:
Originally Posted by ShapesBlue View Post
Oh ok. Wasn't sure about that. As far as stable I'd say synergy is good, along with beanstalk to name a few

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
Cool thanks - I'll try installing it tomorrow. Feel like I've flashed my phone to death in the last couple of days. Seeing as the S5 is now out, how likely is it that development on the S3 Cyanogen roms will continue, do you think?
 
Noam Chomsky
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Nov 2013
Or any S3 rom, for that matter. This phone is probably looking like a pretty old toy by now.
 
ShapesBlue
Old
#7  
ShapesBlue's Avatar
Senior Member
Thanks Meter 545
Posts: 2,445
Join Date: May 2012
Location: Upstate NY
Quote:
Originally Posted by Noam Chomsky View Post
Cool thanks - I'll try installing it tomorrow. Feel like I've flashed my phone to death in the last couple of days. Seeing as the S5 is now out, how likely is it that development on the S3 Cyanogen roms will continue, do you think?
It will continue for now. Beyond 4.4.2 kk I don't think there will be much more for it however, it's a solid phone though and it will live on.

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
VZW S3 - SOKP/MOAR
SGT2 7.0 - Mokee OS 4.4.2/SOKP
The Following User Says Thank You to ShapesBlue For This Useful Post: [ Click to Expand ]
 
Noam Chomsky
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Nov 2013
Quote:
Originally Posted by ShapesBlue View Post
It will continue for now. Beyond 4.4.2 kk I don't think there will be much more for it however, it's a solid phone though and it will live on.

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
I notice Synergy has Verizon s3 users download the d2lte Rom. The d2vzw cyanogenmod page stopped updating nightlies in February, but their d2lte page (which only seems to have started putting out nightlies last month) is very active. Are cm d2lte ROMs compatible with the Verizon s3?

Cheers
 
ShapesBlue
Old
#9  
ShapesBlue's Avatar
Senior Member
Thanks Meter 545
Posts: 2,445
Join Date: May 2012
Location: Upstate NY
Quote:
Originally Posted by Noam Chomsky View Post
I notice Synergy has Verizon s3 users download the d2lte Rom. The d2vzw cyanogenmod page stopped updating nightlies in February, but their d2lte page (which only seems to have started putting out nightlies last month) is very active. Are cm d2lte ROMs compatible with the Verizon s3?

Cheers
Yup sure are. It's a universal build for the S3 and is indeed compatible with the vzw s3

Sent from my SCH-I535 using Xparent ICS Tapatalk 2
VZW S3 - SOKP/MOAR
SGT2 7.0 - Mokee OS 4.4.2/SOKP
The Following User Says Thank You to ShapesBlue For This Useful Post: [ Click to Expand ]
 
katzer1
Old
#10  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Mar 2011
Short answer: I got it to work. Skip to the end of the post if you want to just get the link...

Slightly longer:
  • Device: Samsung S3, US Verizon, SCH-I535
  • OS: d2vzw , CM 10.2.1 - last known stable version
  • Carrier: O2 in the Czech Republic
  • Prior to installing CM, I had it with ancient Android 4.1.2 (I did not do the OTA update). It was slow, full of bloatware etc.

Symptoms:
  • I could receive SMS messages but not send SMS.
  • I never saw "full reception" on the antenna icon on the status bar.
  • I had data when not on wifi - but it was slow.

Steps taken that did not make a difference:
  • Fiddling around with *#*#4636#*#* and trying everything written here: http://wiki.cyanogen.../w/SMSC_Updates
  • Voice+ was not the culprit either. I even under root deleted the apk, rebooted - same deal
  • Fiddling with the carrier mobile networks did not help either

This worked:
http://forum.xda-developers.com/show....php?t=2394689


I hope it helps.
Best regards and drive safely,
Erez

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes