Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,606 Members 48,711 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xposed causing random rebooting?

Tip us?
 
Boot329
Old
#1  
Member - OP
Thanks Meter 3
Posts: 50
Join Date: Jun 2010
Location: Atlanta
Question [Q] Xposed causing random rebooting?

Hello everyone,

I've been using xposed module with no problems until recently I installed the "xMultiWindow" , "Floating Window/App", and "Simple Battery Percentage" through the xposed module.

Now my phone randomly reboots every 5 minutes.. I uninstalled the apps..uninstalled xposed.. and performed a data wipe.. which works until I install xposed.. which continues to randomly reboot.

I have NO idea on how to approach this so any pointers are greatly appreciated!
 
rbouza1
Old
#2  
Senior Member
Thanks Meter 48
Posts: 288
Join Date: May 2013
Location: midland

 
DONATE TO ME
Quote:
Originally Posted by Boot329 View Post
Hello everyone,

I've been using xposed module with no problems until recently I installed the "xMultiWindow" , "Floating Window/App", and "Simple Battery Percentage" through the xposed module.

Now my phone randomly reboots every 5 minutes.. I uninstalled the apps..uninstalled xposed.. and performed a data wipe.. which works until I install xposed.. which continues to randomly reboot.

I have NO idea on how to approach this so any pointers are greatly appreciated!
how do you have installation set? to system or recovery? maybe cha ge that and try
 
Crew One
Old
#3  
Member
Thanks Meter 7
Posts: 65
Join Date: Aug 2009
I must say, I have *exactly* the same.

I got a brand new, stock, M8. Rooted it. It ran fine.

Then installed xposed (using TWRP) and the random rebooting started.

Tried rebooting in safe mode and doing a cache wipe, no effect.

Even after un-installing Xposed, the rebooting continued. Only a factory reset fixed it.

After the factory reset, I re-installed all my apps - phone ran fine.

Only after installing Xposed framework (no modules!) the phone starts to random reboot - again.
 
ab.riyami
Old
#4  
Member
Thanks Meter 6
Posts: 83
Join Date: Nov 2011
I have a similar issue, phone reboots every minute but only when I uninstalled Xprivacy, I tried wiping cache and dalvik cache but it didnt work, I didnt uninstall Xposed, only disabled and uninstalled Xprivacy.

but I reckon the issues are similar.
 
vosg
Old
#5  
Junior Member
Thanks Meter 3
Posts: 28
Join Date: Sep 2010
Location: Antwerp, BE
Default ART?

Are you guys running ART? Xposed doesn't play nice with that. Try reverting to Dalvik.
 
ab.riyami
Old
#6  
Member
Thanks Meter 6
Posts: 83
Join Date: Nov 2011
Quote:
Originally Posted by vosg View Post
Are you guys running ART? Xposed doesn't play nice with that. Try reverting to Dalvik.
Yup it doesnt, Im running Dalvik

Anyways, I've updated Xprivacy ill try uninstalling it again.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes