Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,607 Members 52,312 Now Online
XDA Developers Android and Mobile Development Forum

Updating Android 4.1

Tip us?
 
boxer3310
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Default Updating Android 4.1

Hey there, guys. I've been around XDA a while & have messed around with different ROMS. I had found one that I liked (decent battery life is the most important for me) & stuck with ParanoidAndroid 3.60 (4.2 based ROM) for Android 4.1 (I believe the firmware version is 10.4.2.20). TWRP is 2.5.0.0. This was around 1-2 years ago, and I finally decided it was time to upgrade it.

Can anyone point me the direction on where to start? I would like to update to the latest (or most stable) android version, if possible. I have a basic knowledge of fastboot & how it works.
 
Duchman
Old
(Last edited by Duchman; 28th June 2014 at 02:30 AM.)
#2  
Member
Thanks Meter 8
Posts: 30
Join Date: Jan 2013
Location: Tbilisi
First, you will have to upgrade your bootloader to the latest version to run the latest recovery. I don't know if there's an easier way of doing this, but I'd suggest installing a stock ROM and then unlocking/rooting/installing recovery again.
You can download the latest official firmware from here (assuming you have a TF300T model): http://www.asus.com/Tablets_Mobile/A...Desk_Download/
Make sure to select the one with the correct SKU.
Then, follow this guide: http://forum.xda-developers.com/show....php?t=1757077
This will wipe all your data so make sure to backup all the files you need.
The bootloader will most likely remain unlocked, so what you need now is root and recovery. There are plenty of guides for those, so find the right one for you. You can download the latest TWRP from here: http://teamw.in/project/twrp2/97
An installation guide is on the same page, but make sure to download the one ending with 4.2 since you will be on the latest firmware version (here's the name of the file you'll probably need if you have a TF300T model: openrecovery-twrp-2.6.3.0-tf300t-4.2.blob).
Hope this will help
Press the "Thanks" button if you think I helped!
The Following User Says Thank You to Duchman For This Useful Post: [ Click to Expand ]
 
boxer3310
Old
(Last edited by boxer3310; 28th June 2014 at 07:15 AM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Quote:
Originally Posted by Duchman View Post
First, you will have to upgrade your bootloader to the latest version to run the latest recovery. I don't know if there's an easier way of doing this, but I'd suggest installing a stock ROM and then unlocking/rooting/installing recovery again.
You can download the latest official firmware from here (assuming you have a TF300T model): http://www.asus.com/Tablets_Mobile/A...Desk_Download/
Make sure to select the one with the correct SKU.
Then, follow this guide: http://forum.xda-developers.com/show....php?t=1757077
This will wipe all your data so make sure to backup all the files you need.
The bootloader will most likely remain unlocked, so what you need now is root and recovery. There are plenty of guides for those, so find the right one for you. You can download the latest TWRP from here: http://teamw.in/project/twrp2/97
An installation guide is on the same page, but make sure to download the one ending with 4.2 since you will be on the latest firmware version (here's the name of the file you'll probably need if you have a TF300T model: openrecovery-twrp-2.6.3.0-tf300t-4.2.blob).
Hope this will help
Thanks for replying! I got it to boot, but it stays stuck on the Asus logo with the loading circle. I installed the correct TWRP recovery. I tried rebooting, but it says no OS installed. Furthermore, it does not mount the External storage. I can browse the files through the file Manager in TWRP.

EDIT: It rebooted & I have everything back. It just took forever to reboot. Thanks for your help!!
 
Duchman
Old
#4  
Member
Thanks Meter 8
Posts: 30
Join Date: Jan 2013
Location: Tbilisi
Quote:
Originally Posted by boxer3310 View Post
Thanks for replying! I got it to boot, but it stays stuck on the Asus logo with the loading circle. I installed the correct TWRP recovery. I tried rebooting, but it says no OS installed. Furthermore, it does not mount the External storage. I can browse the files through the file Manager in TWRP.

EDIT: It rebooted & I have everything back. It just took forever to reboot. Thanks for your help!!
I'm glad I was able to help. Could you tell me the order of your actions and what happened after what? I'm a bit confused as to why it'd get stuck like this.
Also, you might need a newer recovery for more recent ROMs. There are both 2.7.0.1 and 2.7.1.0 versions available in the development section.
Press the "Thanks" button if you think I helped!
The Following User Says Thank You to Duchman For This Useful Post: [ Click to Expand ]
 
boxer3310
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Jun 2014
Quote:
Originally Posted by Duchman View Post
I'm glad I was able to help. Could you tell me the order of your actions and what happened after what? I'm a bit confused as to why it'd get stuck like this.
Also, you might need a newer recovery for more recent ROMs. There are both 2.7.0.1 and 2.7.1.0 versions available in the development section.
I did everything as you posted:

1. Downloaded the most current firmware for the TF300T from the Asus site.
2. Pushed it to my device using fastboot
3. Installed custom recovery for my version of Android
4. Rebooted.

The Installation bar completed after I pushed the firmware & recovery. It just took long to reboot. I read that you have to let the ROM "stabilize," so I suspect it might have been the cause of the hang. Everything went pretty smooth after the reboot, though. I installed TWRP 2.7.1.0 (as you posted above) and installed a new ROM. Thank you very much for taking the time to reply. I love this update!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes