Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,785,150 Members 38,087 Now Online
XDA Developers Android and Mobile Development Forum

Guide How to Read MSL/SPC code

Tip us?
 
farookh
Old
(Last edited by farookh; 27th November 2011 at 02:43 PM.)
#1  
Member - OP
Thanks Meter 61
Posts: 46
Join Date: May 2008
Default Guide How to Read MSL/SPC code

You need to get a copy of RadioComm v.11.12.2 from here http://www.mediafire.com/?aco7dzb067kxk7h




http://home2.paulschou.net/tools/xlate/


Attached Thumbnails
Click image for larger version

Name:	spc1.jpg
Views:	14940
Size:	99.0 KB
ID:	796733   Click image for larger version

Name:	spc2.jpg
Views:	13096
Size:	100.6 KB
ID:	796734   Click image for larger version

Name:	hex decode.jpg
Views:	10893
Size:	89.1 KB
ID:	796735  
The Following 35 Users Say Thank You to farookh For This Useful Post: [ Click to Expand ]
 
daddymikey1975
Old
#2  
daddymikey1975's Avatar
Senior Member
Thanks Meter 149
Posts: 1,046
Join Date: Feb 2010
i'll give it a shot.. will report back if/how well it works.
 
hdmunger
Old
(Last edited by hdmunger; 27th November 2011 at 06:22 PM.)
#3  
hdmunger's Avatar
Member
Thanks Meter 32
Posts: 97
Join Date: Jan 2011
Location: Salt Lake City
Default Success!!

This worked fine on 2 Photons with a couple of caveats...

1. I got a pink circle instead of green and the RadioComm user manual says:

Green Circle: This status means that a radio is detected and in USB Composite Device mode. (Motorola P2K Test Commands)

Pink Circle: This status means that a radio is enumerated as a USB LAN device and the socket connection was successful. (Motorola P2K or QC test commands in USB LAN mode)

2. After the first time hooking phones up and starting RadioComm, I got the pink circle, but RDELEM didn't work. Then I tried clicking the Restart button at the top center to force a restart of the phones and then the steps on the second graphic in the OP (RDELEM) worked fine.

Note: The USB mode that I started with was Charge Only, but after RadioComm does its thing it was in Motorola Phone Portal mode...not sure why or if it makes any difference...just sayin'.
The Following 2 Users Say Thank You to hdmunger For This Useful Post: [ Click to Expand ]
 
Harry_Spade
Old
#4  
Member
Thanks Meter 6
Posts: 88
Join Date: Nov 2009
It worked!!!!!!!

Only thing I had to do, I had to set the USB connection on the Phone to Motorola Portal.

I had to play with it a couple of times. Once i got a restart command to work, it was smooth as butter.
 
e240
Old
#5  
Senior Member
Thanks Meter 14
Posts: 276
Join Date: Feb 2011
so im guessing this wont work on cm7 since you cant get to the moto phone portal option.. and also because i connected it and got a pink circle instead of green..any ideas to get it to work on cm7?
 
hdmunger
Old
#6  
hdmunger's Avatar
Member
Thanks Meter 32
Posts: 97
Join Date: Jan 2011
Location: Salt Lake City
pink might still work...it did for me on stock rooted.
 
Harry_Spade
Old
#7  
Member
Thanks Meter 6
Posts: 88
Join Date: Nov 2009
Pink circle really does not matter I think, give it a try and see what happens, try to change to one of the other modes, also, in the program, the mode should be suspend, on top left. My worked while it was on pink circle

PS. you need to input those values, the ones given on the second screenshot
 
countryfried
Old
#8  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Oct 2010
Location: T-Town, OK

 
DONATE TO ME
Good stuff. ty Took a little while to get the hang of it, but I was able to obtain my MLS. I also got the "pink" light and then Green on test.

Very handy.
 
bearw815
Old
(Last edited by bearw815; 27th November 2011 at 08:26 PM.)
#9  
bearw815's Avatar
Senior Member
Thanks Meter 181
Posts: 365
Join Date: Aug 2010
Location: AZ
No it won't work with cm7, most of these things won't including data codes.

Has anyone with a unlocked bootloader with stock rom been successful?

Who is doing what with the data collected by that website?
 
e240
Old
#10  
Senior Member
Thanks Meter 14
Posts: 276
Join Date: Feb 2011
Quote:
Originally Posted by Harry_Spade View Post
Pink circle really does not matter I think, give it a try and see what happens, try to change to one of the other modes, also, in the program, the mode should be suspend, on top left. My worked while it was on pink circle

PS. you need to input those values, the ones given on the second screenshot
did all that and im getting

Sending 'RDELEM' command with data '278600010000000E' to the radio...
Sent to radio:
TC Send Header: 0000002000080000
TC Send Data: 278600010000000E

Returned from radio:
TC Receive Header:
TC Receive Data:

RDELEM ==>FAILED
Driver answer ==> -256
Error Description ==> PST: Handle to device is invalid - no device present
Time to execute command: 0 seconds.
Command timeout set to : 15 seconds.

Tags
msl, spc
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes