Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,530 Members 42,358 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Problem with my xperia neo l

Tip us?
 
ashish_bh87
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Jun 2014
Default [Q] Problem with my xperia neo l

Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish
 
Samak
Old
(Last edited by Samak; 30th June 2014 at 04:22 PM.)
#2  
Samak's Avatar
Senior Member
Thanks Meter 280
Posts: 485
Join Date: Jun 2012
Location: Siliguri
Quote:
Originally Posted by ashish_bh87 View Post
Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish
I think Your phone's motherboard is okay... Its display problem... Do u still receive calls & messages?

Sent from my Xperia ZR using Tapatalk
 
rjbaraiya
Old
#3  
Junior Member
Thanks Meter 3
Posts: 20
Join Date: Jun 2013
Location: Vadodara
Quote:
Originally Posted by ashish_bh87 View Post
Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish
Now Try this :
1 - Remove your battery
2 - Reinsert and then hold the (go back) button and insert the usb cable keeping it connected to your computer.
3 - check if the green light flashes
4 - if it is flashing, then you will be able to flash your stock rom and maybe if there is any problem with kernal or your rom then it will be solved automatically.
5 - so flash your stock ftf and kernal after disabling the final verification checkmark in the flashtool
6 - once over, your phone should start without any problems if there is no problem with your display

Give this a try once.... Hope this helps
Hit thanks if it helps
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes