Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Problem with my xperia neo l

OP ashish_bh87

30th June 2014, 09:49 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jun 2014
Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish
30th June 2014, 05:20 PM   |  #2  
Samak's Avatar
Senior Member
Flag Siliguri
Thanks Meter: 280
 
485 posts
Join Date:Joined: Jun 2012
More
Quote:
Originally Posted by ashish_bh87

Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish

I think Your phone's motherboard is okay... Its display problem... Do u still receive calls & messages?

Sent from my Xperia ZR using Tapatalk
Last edited by Samak; 30th June 2014 at 05:22 PM.
2nd July 2014, 09:09 AM   |  #3  
Junior Member
Flag Vadodara
Thanks Meter: 3
 
20 posts
Join Date:Joined: Jun 2013
More
Post
Quote:
Originally Posted by ashish_bh87

Sorry for my bad English.

Last week, when i tried to check a Whatsapp message, my phone didn't start up. There was no display. Whenever i try to switch it on, it does not start, just vibrate. I tried to repair it by Sony Companion and Sony update software, and after a full process, it says it is updated/repaired, please restart. But still there was no display. Sony software is detecting it and it is charging.

I have also rooted my phone 6 months back. So i tried to re flash, But i am not able root it again because i had unchecked the USB debugging option a few months bk and i am not able to start as the phone is starting up. So i have just re flashed it.

I took this phone to a Sony Service centre; they kept it for more than one day.Then I got a call that I have to pay 80 PERCENT of the cost of this phone for the repair. Next day when i went to get my phone, they just said "its has motherboard problem". So i took it back as i am not able afford 80% cost.

That if my Sony software is able to detect and repair this phone then how can there be a motherboard problem.

Please help

-Ashish

Now Try this :
1 - Remove your battery
2 - Reinsert and then hold the (go back) button and insert the usb cable keeping it connected to your computer.
3 - check if the green light flashes
4 - if it is flashing, then you will be able to flash your stock rom and maybe if there is any problem with kernal or your rom then it will be solved automatically.
5 - so flash your stock ftf and kernal after disabling the final verification checkmark in the flashtool
6 - once over, your phone should start without any problems if there is no problem with your display

Give this a try once.... Hope this helps
Hit thanks if it helps
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes