Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,784,443 Members 49,034 Now Online
XDA Developers Android and Mobile Development Forum

Active sync - Exchange: SSL over a non-default port

Tip us?
 
Lukasss
Old
#1  
Senior Member - OP
Thanks Meter 0
Posts: 169
Join Date: Dec 2007
Location: Antwerp
Default Active sync - Exchange: SSL over a non-default port

My ISP blocks all ports below 1024 so I had to setup my SBS2003 Exchange server to run on port 8080 (HTTP) & 4443 (HTTPS), which works perfectly (tested locally & on remote locations).

When I add the correct secure portnumber to the server address (ActiveSync > Tools > Configure Server Source), ActiveSync cannot find our Exchange Server. When I remove the portnumber everything works fine as long as I'm on my local network.

I enter it like this: exchangeserverdomain.com:4443

I have OWA running perfectly by using the same external server address:<port>, and all needed certificates are on my WM6 device (it's the HTC Touch Dual).

Seems like ActiveSync doesn't like portnumbers.

Any tips?
 
pozi
Old
#2  
Member
Thanks Meter 10
Posts: 73
Join Date: Apr 2007
Default Me 2

I'm having a similar problem.

Anyone can help?

Many thanks in advance.
Pozi.
 
mtn_lion
Old
#3  
Member
Thanks Meter 2
Posts: 71
Join Date: May 2005
Location: Boulder CO
If anyone has found a solution for this, I sure would appreciate knowing. As I'm sure you found, older stuff retrieved by Google makes it clear that MS just didn't provide support for ActiveSync on custom ports in previous WM versions, but couldn't they have remedied this oversight by now? Reg key?
Paul
 
kmolkens
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2009
Default Active sync - Exchange: SSL over a non-default port - Solved in WM65 ?

Any idea if there is a workaround for this problem in WM 6.5 ?

thanks,
Koen.
 
mtn_lion
Old
#5  
Member
Thanks Meter 2
Posts: 71
Join Date: May 2005
Location: Boulder CO
No, I don't know if WM6.5 finally added the ability to specify port number for Activesync server.

We solved this need by using "SSL host headers," which permit multiple IIS sites to use the default SSL port 443 with different host names. Although the IIS (6.0) GUI doesn't provide this capability, it can be done at the command line using adsutil.vbs found in Inetpub\adminscripts. It requires a wildcard SSL certificate, is a little tricky to get right, and results in a misleading error message in the event log every time IIS starts, but it does work reliably.

See:
http://www.microsoft.com/technet/pro....mspx?mfr=true
Paul
 
kmolkens
Old
#6  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Jun 2009
Default ISP blocks all well-known ports - server activesync not working

thanks for the information, the configuration of Exchange is indeed not an issue.
Problem is that my ISP blocks all well-known (service) ports like 443,...

I would like to configure server activesync to use a different port (above 1024).
The Activesync interface on Windows mobile does not allow to enter a port number to specify the protocol.
eg. remote.company.com:4433 is automatically changed back to remote.company.com.

Any idea of a reg-key on WM to change the port to use for server activesync ?
 
mtn_lion
Old
#7  
Member
Thanks Meter 2
Posts: 71
Join Date: May 2005
Location: Boulder CO
If there is a way to do that in WM65, I don't know about it.

What kind of ISP "blocks all well-known ports"?

Good luck.
Paul
 
deedee
Old
#8  
deedee's Avatar
Senior Member
Thanks Meter 24
Posts: 1,033
Join Date: May 2007
Location: Coleraine

 
DONATE TO ME
Not a solution per se but could you use SevenBeta to get your mail pushed? i think it works as long as you can get to the OWA server from the device. probably wouldn't give you contacts but at least you'd get mail while out of the office.
Sony Xperia S
ROM Stock UK unbranded 1257-3921-R5E

HTC HD Mini
ROM - Stock Vodafone UK

Xperia X1
ROM - Stock O2

HTC P3600
ROM - TNYYNT 016BSN
Radio - 1.50.08.11
 
digiconstruct
Old
#9  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Apr 2011
Default It's not Exchange, but the client...

I dislike it's come to this but it's true, the iPhone handles this over custom ssl ports just fine and I have not come across anything else that does. I do not know why. With the iPhone or iPod touch too I'd guess, you just enter your email address and password. It tries the regular ports and fails, and where you enter the server you enter your port like servername:customsslport and then you have full active synch abilities, synched email, all your subfolders, and the option to synch calendar and address book too.

I recently tried an android phone and looking for a solution, at this very site found out windows phones couldn't do this either... Developers have tried to give google this code correction but they won't accept it for whatever reason. I ended up using a tether to my old iPhone just to get decent ActiveSynch over custom SSL ports until I gave in and took back the Atrix for the newer iPhone, as my old phone was falling apart and was the older slower one. I've tried 2.1 & 2.2 Android phones and when you try to enter the port using server:port syntax you get invalid server format or the save button just gets grayed out until you remove the port. There's a few buggy market apps that sorta work in a limited way. It's possible the Blackberry may allow custom ssl ports on Exchange synch setup too, but I don't know, only that Windows and Android phones had issues with this but it works perfect on the iPhone, so it can't be a limitation of Exchange exactly. I haven't run into any good desktop clients for this, but to access full mobile email, synching even sent items and pushing select custom folders, calendar and contacts the iPhone truly synchs all these fine by entering the same port you use for custom OWA ssl in the Exchange email setup. I wish even desktop Outlook handled custom ssl port synching this well, and I'm not sure how the iPhone does it, as it seems very lightweight.

http://forum.xda-developers.com/showthread.php?t=602494

Quote:
Originally Posted by Lukasss View Post
My ISP blocks all ports below 1024 so I had to setup my SBS2003 Exchange server to run on port 8080 (HTTP) & 4443 (HTTPS), which works perfectly (tested locally & on remote locations).

When I add the correct secure portnumber to the server address (ActiveSync > Tools > Configure Server Source), ActiveSync cannot find our Exchange Server. When I remove the portnumber everything works fine as long as I'm on my local network.

I enter it like this: exchangeserverdomain.com:4443

I have OWA running perfectly by using the same external server address:<port>, and all needed certificates are on my WM6 device (it's the HTC Touch Dual).

Seems like ActiveSync doesn't like portnumbers.

Any tips?
 
Selebrity
Old
#10  
Member
Thanks Meter 3
Posts: 75
Join Date: Mar 2011
hmmm this is interesting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


New Nvidia SHIELD Tablet OTA! Moto G 4G Gets Official CyangenMod 11 Nightlies – XDA Developer TV

The Nvidia SHIELD Tablet gets its … more

Prevent Apps from Locking Screen Orientation with HaveOwnOrientation

Most applications on Android play nicely with both landscape and … more

Create Your Own Launcher with HTMLauncher

There are hundreds of launcher replacement applications available for Android. Most of them are … more

First ROMs Appear for the Nvidia Shield Tablet

TheNvidia Shield Tablethas only been available for a little over a month. In that short time, … more