Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,749 Members 50,801 Now Online
XDA Developers Android and Mobile Development Forum

SOLVED: Exchange sync error 0x80072F0D

Tip us?
 
oscarsalgar
Old
(Last edited by oscarsalgar; 13th April 2008 at 03:14 AM.)
#1  
oscarsalgar's Avatar
Senior Member - OP
Thanks Meter 3
Posts: 113
Join Date: May 2007
Location: Bogotá
Default SOLVED: Exchange sync error 0x80072F0D

Hello,

My company uses Exchange server 2003 sp2. I've tried to sync my TyTN II several times but I always get this message: "The security certificate on the server is invalid. Contact your system administrator or ISP to install a valid certificate on the server and try again".

I'm actually able to access https://myserver.com/OMA (not http) using my nickname and password, but I don't even know what that means. I talked to the IT guys and they just sent me to a Microsoft page where it says: "This problem may occur because the device manufacturer locked the Windows Mobile 5.0-based device. This lock prevents you from installing Secure Sockets Layer (SSL) certificates correctly".

So, their only answer was: contact your manufacturer to see if the device is locked (??). (Although they also said I didn't need a SSL certificate)

¿Could anybody please help me to understand this? ¿Do I have to install a certificate? ¿Do the IT guys have to do it? I really need to solve this so any information is welcome

thanks a lot.
Galaxy Note N7000


Before: Galaxy S GT-i9000M, HTC TyTN II, HTC TyTN
 
DeepThought
Old
#2  
DeepThought's Avatar
Senior Member
Thanks Meter 1
Posts: 748
Join Date: Jul 2006
Location: Austria, Vienna
If it is a "self-signed" certificate (and not an official one bought f.e. via verisign.com), than you have to install it on your device to make it "valid". Additionally the Hostname provided in the certificate must exactly match the hostname of your exchange-server otherwise it won't work either. HTH

----------------------------------------------------------------------------------------------------
History: Wallaby > Himalaya > Blue Angel > Universal > Hermes > Palm Treo 750 > Kaiser > Raphael
My Apps: hTorch v3.2 | using camera LED as flashlight --> Last Updated: 2008-11-20
 
DeepThought
Old
#3  
DeepThought's Avatar
Senior Member
Thanks Meter 1
Posts: 748
Join Date: Jul 2006
Location: Austria, Vienna
PS.: you can find out both when you access your companys exchange server via OWA (OutlookWebAccess). Once you're logged on you can examin the certificate and look if the hostname matches, if the certificate is still valid (every certificate has an expiration date) and who the "certification authority" is.

----------------------------------------------------------------------------------------------------
History: Wallaby > Himalaya > Blue Angel > Universal > Hermes > Palm Treo 750 > Kaiser > Raphael
My Apps: hTorch v3.2 | using camera LED as flashlight --> Last Updated: 2008-11-20
 
jon_k
Old
#4  
Senior Member
Thanks Meter 0
Posts: 131
Join Date: Dec 2007
You can still use OWA if the company allows you to use it unencrypted. Just uncheck use SSL during setup.

I'd be curious if anyone would know how to rip the public key from Firefox or something so it can be imported to the phone to make it work.

I have been told if you can get your exchange admin to send you the .CERT file from the IIS webserver you can run that on your phone and get it to work. However, I believe that has the public and private key pairs, which is a security risk to your entire organization if you have the private pair!
ATT Tilt
Provider ATT United States
Current ROM: Alex's ROMs v6 AT&T WM61 3.51
 
foobar1977
Old
#5  
Senior Member
Thanks Meter 0
Posts: 105
Join Date: Jan 2008
Quote:
Originally Posted by jon_k View Post
You can still use OWA if the company allows you to use it unencrypted. Just uncheck use SSL during setup.
domain credentials over unsecured channel, bad mojo man

Your IS guys should have a certificate for you to install which will resolve the problemI have a root ca certificate for my company installed on my phone so I have no problem using any certificate they sign.

As already said, check the hostname matches extacly and check the expiry date of the certificate.
Device: HTC Blackstone
Network: Orange UK
ROM: BlackDragon 2.1.1
Radio: 1.17.25.09
 
oscarsalgar
Old
#6  
oscarsalgar's Avatar
Senior Member - OP
Thanks Meter 3
Posts: 113
Join Date: May 2007
Location: Bogotá
Hey Guys, thanks for all your answers!

I'm logged on the OWA server and the certificate says "Equifax Secure global eBusiness CA-1". The expiration date is 24/02/2010. Does anybody know how can I install this on my device? I checked the hostname and it matches perfectly
Galaxy Note N7000


Before: Galaxy S GT-i9000M, HTC TyTN II, HTC TyTN
 
odie3
Old
#7  
odie3's Avatar
Senior Member
Thanks Meter 0
Posts: 570
Join Date: Sep 2005
Location: Texas
If it is like the certificate I have to use to get my Tilt/Office Exchange to work, then you just double click on it and it should say "Installed" or something like that. After that, assuming you have everything else setup, it should work like a charm.
Odie3

AT&T Tilt -
ROM: [Apr 09] Dutty's Official WM6.1 5.2.19209
ROM date: 04/09/08
Radio Version: 1.58.16.27 Niki
HTC Kaiser Hard-SPL v1
SIM Unlocked (Code for free from AT&T)
8GB Scandisk MicroSDHC
 
oscarsalgar
Old
#8  
oscarsalgar's Avatar
Senior Member - OP
Thanks Meter 3
Posts: 113
Join Date: May 2007
Location: Bogotá
thanks a lot to all you guys! Had some problems because the certificate would install in the "intermediate" store, instead of the root store, but I found this site and followed the instructions:

http://www.confusedamused.com/notebo...-certificates/

It's synchronizing right now and it's way faster than activesync!
Galaxy Note N7000


Before: Galaxy S GT-i9000M, HTC TyTN II, HTC TyTN
 
WeldingRod
Old
(Last edited by WeldingRod; 18th July 2009 at 06:48 PM.)
#9  
Member
Thanks Meter 0
Posts: 52
Join Date: Jun 2006
Well I was able to save, and copy the certificate by going to my companies OWA site.

I copied it via memory card, and was able to install it. Upon installing it I'm not asked for an option of where to install it (root vs. intermediate, etc)

Unfortunately by default it is going to intermediate.

I hope that this will fix it once I figure out how to install it into root.

For now it has not fixed my problem, still get an error synchronizing with the server.

Edit:

Strange, I re-installed the certificate, to make sure it was from the "head" title branch (my company has an extra level to the branch so I tried both), and this time instead of soft-reset, I completely shut-down the phone.
Powering it back up, it now sync's fine, and there is a 2nd verisign cert with a different expiration installed in the root store. My poor outlook is still syncing data as it catches up for the last couple weeks!

Doh.
 
longst
Old
#10  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Nov 2008
Location: Stockholm
Quote:
Originally Posted by WeldingRod View Post
Well I was able to save, and copy the certificate by going to my companies OWA site.

I copied it via memory card, and was able to install it. Upon installing it I'm not asked for an option of where to install it (root vs. intermediate, etc)

Unfortunately by default it is going to intermediate.

I hope that this will fix it once I figure out how to install it into root.

For now it has not fixed my problem, still get an error synchronizing with the server.

Edit:

Strange, I re-installed the certificate, to make sure it was from the "head" title branch (my company has an extra level to the branch so I tried both), and this time instead of soft-reset, I completely shut-down the phone.
Powering it back up, it now sync's fine, and there is a 2nd verisign cert with a different expiration installed in the root store. My poor outlook is still syncing data as it catches up for the last couple weeks!

Doh.
I also had this problem, and the sync. still does not work... if someone has some idea
Thank you

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...