Firefox OS Architecture and Collaboration Opportunities w/ Asa Dotzler – XDA:DevCon 2014

We were privileged to host many presentations … more

Unofficial Android 4.4 Lands on Three Mediatek Devices

For the last few years, devices with MTK systems-on-chip haven’t received much … more

MultiImagePicker Library for Multiple Image Selection

App developmentcan be done in more than a handful of ways. You can write every single … more

Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Thread Deleted

NRG Weather 3.0 - "The pretty version..."

OP NRGZ28

13th June 2008, 07:14 PM   |  #21  
Dees_Troy's Avatar
Senior Recognized Developer
Flag KC MO
Thanks Meter: 9,951
 
1,617 posts
Join Date:Joined: Mar 2008
Donate to Me
More
Quote:
Originally Posted by Dees_Troy

I installed on my Q9c and I still get that font issue with large text boxes in PIE, however, I'm willing to put up with it at this point since the 6-day layout means I don't have to reboot the phone to see the latest forecast.

Any idea what might be causing the font issue? Since this weather panel is basically just scripts reading XML files and making registry changes, I can't imagine that it'd be too hard to figure out what's causing the PIE font issue. The font issue isn't a huge deal and I'd completely ignore it if it weren't for the fact that the digital font makes no differentiation between upper and lower case and many special characters just show up as boxes.

I dumped the 10-day panel and added a link to the Weather Update in my links panel if I ever decide to manually update the weather.

After messing around with things for a while, I finally figured it out. I renamed \Windows\LCD.ttf to LCD.bak and rebooted. Now PIE uses its regular Courier font instead of the LCD font. Weird issue and I'm surprised that PIE seems to randomly grab a fixed-width font from \Windows but whatever. This fix probably means I can't use the LCD clock font, but I'm not using that option anyway. Probably just a Moto Q9c issue.

I'm very happy! Small Paypal donation made. (Note, Organic, your latest version thread here doesn't have a Paypal link - found it on another thread.)

While digging around, I noticed that the SPWeather.home.xml files and most of the cpr files are using the Nina font, which I don't think my phone has. My default chome_320x240.cpr file uses Segoe. Several of the portrait-style cpr files use Segoe instead of Nina.
13th June 2008, 07:43 PM   |  #22  
sergiopi's Avatar
Retired Senior Moderator
Flag Rome
Thanks Meter: 20
 
1,144 posts
Join Date:Joined: Dec 2005
Donate to Me
More
Great application! Useful, beatiful graphic, fully integrated with UI and layout; try to sell it to MS (or to HTC), before they copy the concept and the code
13th June 2008, 08:44 PM   |  #23  
Senior Member
Thanks Meter: 7
 
255 posts
Join Date:Joined: Apr 2008
right now my weather update will only go up to 20%. I have an HTC dash with the proxy...
13th June 2008, 09:13 PM   |  #24  
Member
Thanks Meter: 0
 
36 posts
Join Date:Joined: Jan 2008
Quote:
Originally Posted by pudgedaddy

this app is specifically written for the sliding panel homescreen. The sliding panel homescreen is only available on the WM 6.1 platform. So no. it does not and will not work on the WM6 interface

Thank you.
No hope it can be adapted to WM6, to use it as a plugin for home?
At present I'm using Fizz Weather, but I really like the crisp graphics of NRG Weather.
13th June 2008, 09:20 PM   |  #25  
Senior Member
Thanks Meter: 7
 
255 posts
Join Date:Joined: Apr 2008
i fixed the downloading problem, now my questions is what layout are the sample pictures using? I set the 6 day layout, but the background is not transparent like the ones displayed?

this problem is still occurring??? I dont get it. i can go to PIE and it that works fine.
Last edited by dbldown768; 13th June 2008 at 10:03 PM.
13th June 2008, 09:24 PM   |  #26  
pudgedaddy's Avatar
Retired Moderator
Flag Broken Arrow, OK
Thanks Meter: 5
 
906 posts
Join Date:Joined: Nov 2006
More
Quote:
Originally Posted by dbldown768

i fixed the downloading problem, now my questions is what layout are the sample pictures using? I set the 6 day layout, but the background is not transparent like the ones displayed?

He's using a dark, but partially transparent image on the slide, this is due to the fact that he's trying to make all of the info appear better on the screen as to adapt to different types of wallpapers people use. If you used a very light background image for example, and he didnt use that filter, the white text would be difficult to see.
13th June 2008, 09:32 PM   |  #27  
NRGZ28's Avatar
OP Retired Senior Mod & Senior RD - (old) King of WinMo
Flag XDA-Developers
Thanks Meter: 10,028
 
10,471 posts
Join Date:Joined: Apr 2007
More
Is anybody experiencing any alignment problems with the bottom temps on the new layout ?
13th June 2008, 10:23 PM   |  #28  
bowenar57's Avatar
Junior Member
Flag Cardiff
Thanks Meter: 0
 
11 posts
Join Date:Joined: Mar 2008
More
Quote:
Originally Posted by OrganicM

Is anybody experiencing any alignment problems with the bottom temps on the new layout ?

Afraid so... but I'm sure you can fix it!
Patience is a virtue!
Adrian
13th June 2008, 10:41 PM   |  #29  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jun 2008
Nope, no problems here!

Patience is Virtue!
Adrian


wtf? Another Adrian? haha.
13th June 2008, 11:01 PM   |  #30  
AbsoluteDesignz's Avatar
Senior Member
Flag New Jersey
Thanks Meter: 43
 
1,579 posts
Join Date:Joined: Sep 2007
More
EDIT: NM, fixed it.

Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes