Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,619 Members 52,214 Now Online
XDA Developers Android and Mobile Development Forum

My 8525 keeps shutting down by its self

Tip us?
 
brain boy
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2007
Unhappy My 8525 keeps shutting down by its self

When I turn it on, it stays for a while and shuts down
same thing happens over and over

Does anyone have an idea about this problem?
 
MikeChannon
Old
#2  
MikeChannon's Avatar
Forum Administrator
Thanks Meter 3592
Posts: 11,136
Join Date: Sep 2006
We need more detail.
  1. How long is a "while"
  2. Does it always do this or is it random behaviour?
  3. Is the battery fully charged?
  4. Have you tried soft / hard resets?
  5. Does the device go completely off or is it just the screen that goes off? (i;e; when you switch the device back on, do you need a long press on the power button or just a quick press?)
Mike
Forum Administrator
 
brain boy
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Dec 2007
it shuts down completely(i need a long press to turn it back on)
sometimes it stays for 5 minutes sometimes 20 minutes
and the battery is fully charged
 
MikeChannon
Old
(Last edited by MikeChannon; 12th February 2009 at 02:36 PM.)
#4  
MikeChannon's Avatar
Forum Administrator
Thanks Meter 3592
Posts: 11,136
Join Date: Sep 2006
Quote:
Originally Posted by brain boy View Post
it shuts down completely(i need a long press to turn it back on)
sometimes it stays for 5 minutes sometimes 20 minutes
and the battery is fully charged
OK, it sounds like you have the poor battery contacts problem. To be sure, you can do a hard reset to rule out any software issues. If you have no backup program installed then you will lose anything you have installed to the phone however.

So you could go straight to a simple fix for this problem. That is a strip of card to push the battery more firmly against the gold connectors. First make sure the connectors are all clean:


In some rarer cases the connector block with all the gold contacts has actually become partially detached from the board - perhaps a hairline crack in the soldered contacts. Hopefully yours does not have this problem though.

Mike
Forum Administrator
 
joeadamou@gmail.com
Old
#5  
joeadamou@gmail.com's Avatar
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Feb 2008
my m3100 has just been doing this, i phoned orange and they said i needed a new batery which i cba with. so i hard reseted to no effect, last step reflashed, been working fine for two days now. so my suggestion is reflash your rom
SPV M3100- diamond theme, spb shell diamond theme, diamond keyboard
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes