Post Reply

"With a Little Help from My Friends"... New Themes (WM6.1)

OP BenThon

8th October 2008, 05:10 PM   |  #11  
BenThon's Avatar
OP Senior Member
Thanks Meter: 0
 
173 posts
Join Date:Joined: Apr 2006
Quote:
Originally Posted by digitaleit

They doesn't work with my X1!!!

Do you want me to send you the default ones?

Ciao

Yes, Thanks in advance !
my mail is there : http://www.codeppc.com/developpeurs/benoitthonnart.htm
10th October 2008, 08:13 AM   |  #12  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Sep 2008
sent

check your email
10th October 2008, 08:48 AM   |  #13  
BenThon's Avatar
OP Senior Member
Thanks Meter: 0
 
173 posts
Join Date:Joined: Apr 2006
Thanks for sending themes from your XPERIA. The theme which is of interest is "XPERIA Black.tsk".

Analyzing it with my freeware MSCEInf, we have :
Code:
[Version]
Signature = "$Chicago$"
CESignature = "$Windows CE$"
Provider = "SEUS"
[CEStrings]
Appname = "XPERIA Black"
InstallDir = "%CE1%\%AppName%" ; (%CE1%\XPERIA Black)
[CEDevice]
VersionMin = 4.0
VersionMax = 6.99
BuildMax = -536870912; Support square screen and screen rotation
[SourceDisksNames]
3 = ,"Dir3",,.\Windows
[SourceDisksFiles]
"stwater_800_480.bmp" = 3 ; 001
"stwater_480_800.bmp" = 3 ; 002
[DefaultInstall]
AddReg = ClesRegistre
CopyFiles = CopierVersDir01
[CopierVersDir01] ; (%CE2% : \Windows)
"stwater_800_480.bmp"
"stwater_480_800.bmp"
[DestinationDirs]
CopierVersDir01 = 0, %CE2%
[Strings]
reg_path00 = Software\Microsoft\Today\XPERIA Black.tsk
reg_path01 = Software\Microsoft\Today
reg_path02 = Software\Microsoft\Color
[ClesRegistre]
HKCU,%reg_path00%,Color_CommandBarText,0x00000001,DD,DE,DD,00
HKCU,%reg_path00%,Color_CaptionFlat,0x00000001,55,57,55,00
HKCU,%reg_path00%,Color_SoftkeyFlatCenter,0x00000001,00,00,00,00
HKCU,%reg_path00%,Color_CommandBarSip_Highlight,0x00000001,00,00,00,00
HKCU,%reg_path00%,Color_TitleFlatCenter,0x00000001,00,00,00,00
HKCU,%reg_path00%,Color_NavBarText_Highlight,0x00000001,00,00,00,00
HKCU,%reg_path00%,Color_HighlightText,0x00000001,00,00,00,00
HKCU,%reg_path00%,Color_Highlight,0x00000001,BF,BE,BE,00
HKCU,%reg_path01%,DPI,0x00010001,192
HKCU,%reg_path01%,UseStartImage,0x00010001,1
HKLM,%reg_path02%,14,0x00000001,00,00,00,00
HKLM,%reg_path02%,25,0x00000001,00,00,00,00
HKLM,%reg_path02%,11,0x00000001,69,69,6A,00
HKLM,%reg_path02%,40,0x00000001,D5,D5,D5,00
HKLM,%reg_path02%,4,0x00000001,EC,EC,EC,00
HKLM,%reg_path02%,16,0x00000001,C8,C8,C8,00
HKLM,%reg_path02%,9,0x00000001,DD,DE,DD,00
HKLM,%reg_path02%,12,0x00000001,00,00,00,00
HKLM,%reg_path02%,BaseHue,0x00010001,123
HKLM,%reg_path02%,13,0x00000001,9C,9D,9D,00
HKLM,%reg_path02%,35,0x00000001,FF,FF,FF,00
HKLM,%reg_path02%,34,0x00000001,4C,4C,4C,00
HKLM,%reg_path02%,6,0x00000001,4A,4A,4A,00
HKLM,%reg_path02%,39,0x00000001,E2,E1,E1,00
HKLM,%reg_path02%,15,0x00000001,FF,FF,FF,00
The 2 images are bmp with 16 bits / pixel and 72 DPI.

UseStartImage is set, so only the 2 Start images (for portrait and landscape are defined) with the names :
  • stwater_800_480.bmp
  • stwater_480_800.bmp
and these files are defined with no flags, whereas ThemeGenCE set the flags for images to 0x40000000.

There is another string defined in the TSK (CAB) which is "Start Menu". This string seems to be unused.

These are my first constatations. But I still need "A little Help from my Friends" to make ThemeGenCE compatible for these PDAs.

Thanks in advance.
10th October 2008, 09:15 AM   |  #14  
BenThon's Avatar
OP Senior Member
Thanks Meter: 0
 
173 posts
Join Date:Joined: Apr 2006
Provider for this theme is SEUS !

Sony Ericsson Update Service ? So, there is maybe a theme generator with this service for Xperia ? http://www.sonyericsson.com/cws/supp...application/x1
18th November 2008, 11:45 PM   |  #15  
Member
Thanks Meter: 0
 
42 posts
Join Date:Joined: Nov 2008
nope, no theme generator in the update service
20th November 2008, 06:32 PM   |  #16  
Member
Thanks Meter: 0
 
42 posts
Join Date:Joined: Nov 2008
I tried them, didnt work very well... I made some of my own as well, the colours dont seem to work very well, for example the bars on the top/bottom, even though i put black over black on theme gen ce, came out grey-ish. Furthermore i think the 192dpi setting on themegen is low for the xperia because the pic i used even though it was 480x800 was appearing kinda blurry... If you do the math, it comes out that the xperia's screen is operating at far more than 192dpi
20th November 2008, 06:34 PM   |  #17  
Member
Thanks Meter: 0
 
42 posts
Join Date:Joined: Nov 2008
if my calculations are correct it should be: Xperias DPI = (sqrt(480x800)) / 3 = 206
20th November 2008, 07:05 PM   |  #18  
BenThon's Avatar
OP Senior Member
Thanks Meter: 0
 
173 posts
Join Date:Joined: Apr 2006
Quote:
Originally Posted by tony1985

Furthermore i think the 192dpi setting on themegen is low for the xperia because the pic i used even though it was 480x800 was appearing kinda blurry... If you do the math, it comes out that the xperia's screen is operating at far more than 192dpi

I think that 192 DPI is the correct value for the XPeria X1.

See Microsoft references :

New emulator image resolutions:
  • Windows Mobile 6.1 Standard
    DPI: 131 - Resolution: 320 x 320 pixels
    DPI: 131 - Resolution: 400 x 240 pixels
    DPI: 131 - Resolution: 440 x 240 pixels
  • Windows Mobile 6.1 Professional
    DPI: 96 - Resolution: 240 x 400 pixels
    DPI: 192 - Resolution 480 x 800 pixels
Thanks for testing.
27th November 2008, 06:22 PM   |  #19  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jan 2006
How can I help you?
Quote:
Originally Posted by BenThon


These are my first constatations. But I still need "A little Help from my Friends" to make ThemeGenCE compatible for these PDAs.

Thanks in advance.

Hi BenThon,

I'm also an owner of the Xperia X1 and also interested in wvga themes. Are there any further information you'll need for development or can I help you by testing themes or something like this???

Best regards,

Joern2001
28th November 2008, 11:06 AM   |  #20  
BenThon's Avatar
OP Senior Member
Thanks Meter: 0
 
173 posts
Join Date:Joined: Apr 2006
Thanks for your help.

The things I want to know : In the XPERIA, do you have themes with specific files in it like this
stwater_480_800
stwater_800_480
tdywater_480_800
tdywater_800_480
If yes, could you post or send me these themes ?

Else if it is not possible, you can do themes for Xperia by using in Options the user sizes, or adapt this tutorial (made for WQVGA) for your Xperia.

Post Reply Subscribe to Thread

Tags
themegence, themes, wm6.1, wqvga, wvga
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Upgrading, Modifying and Unlocking by ThreadRank