MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more

Welcome to the New XDA-Developers Portal!

You may recall that a few weeks ago, we opened up the XDA-2015 forum themesto intrepid users … more

An Android Enthusiast’s Apple iPhone 6 Challenge

The media has gone batty again over Apple “revolutionizing” smartphones. … more

Sony to Extend its AOSP Program to Other Devices

Sony will be offering its users the possibility to use AOSP ROMs as an alternative to the … more
Post Reply

Need SSD help from 7510 owners!

4th November 2008, 10:11 AM   |  #1  
keithwwalker's Avatar
OP Senior Member
Thanks Meter: 1
 
296 posts
Join Date:Joined: Jul 2007
More
If any 7510 owners can scan their registry, I am searching for any drivers associated with the SSD. Can you help out? This is in relation to trying to upgrade the 7500/7501 to a 16GB SSD.

Keith Walker
Last edited by keithwwalker; 4th November 2008 at 10:22 AM.
4th November 2008, 10:59 AM   |  #2  
Senior Member
Flag Plymouth
Thanks Meter: 0
 
151 posts
Join Date:Joined: Aug 2007
More
Hi Keith,

I take it you're looking for the drivers for the flash storage and that you're working on porting AP4 to x7510?

If not, please could you let us know what else you need?
4th November 2008, 11:15 AM   |  #3  
Retired Recognized Developer
Flag Budapest
Thanks Meter: 49
 
3,039 posts
Join Date:Joined: Jul 2006
More
Quote:
Originally Posted by keithwwalker

If any 7510 owners can scan their registry, I am searching for any drivers associated with the SSD. Can you help out? This is in relation to trying to upgrade the 7500/7501 to a 16GB SSD.

Keith Walker


just go get one of the x7510 rom images from the x7510 hardspl thread i made (stickied, easy to find) and dump the registry and files.

easiest test might be flash the rom as is, but make sure you got 3.5 SPL and not 1.2.

note, someone tried this already (i've talked to him in PM) and SSD wasn't working. which SSD driver did you install? same as x7510?
4th November 2008, 11:15 AM   |  #4  
Senior Member
Flag Plymouth
Thanks Meter: 0
 
151 posts
Join Date:Joined: Aug 2007
More
Copy text between lines and save as .REG

__________________________________________________ _____________
[HKEY_LOCAL_MACHINE\Drivers\BuiltIn\SDBusDriver]
"IClass"=multi_sz:"{20FA98A8-B298-4b32-8D72-C716AEE2FA84}=%b","{6F40791D-300E-44E4-BC38-E0E63CA8375C}=%b","",""
"Flags"=dword:00010000
"RequestListDepth"=dword:00000030
"ThreadPriority"=dword:00000064
"Prefix"="SDC"
"Dll"="SDBus.dll"
"Order"=dword:00000015
__________________________________________________ _____________

I'll see in a while if I can extract SDBus.dll
4th November 2008, 11:18 AM   |  #5  
Senior Member
Flag Plymouth
Thanks Meter: 0
 
151 posts
Join Date:Joined: Aug 2007
More
I guess there might be some sort of race going on here to see who can be 1st to port AP4 to x7510!
Whichever way it goes, if successful we all win.
4th November 2008, 06:10 PM   |  #6  
keithwwalker's Avatar
OP Senior Member
Thanks Meter: 1
 
296 posts
Join Date:Joined: Jul 2007
More
I am not working on porting AP4 to the 7510, but working on getting the Transcend 16gb SSD recognized in the 7500/7501. I have the 7510 ROM that was modified to work with the 7500/01 but the SSD is not recognized as of yet. I plan to run WM5torage and see if the USB recognizes the SSD.

I don't think that our objectives are mutually exclusive. If the drivers from the 7510 can be extracted to work with the Transcend SSD in the 7500/7501; then surely those drivers can be put into the AP4 ROM.

Thanks for the info so far, fyi, I have SPL3.5

Quote:
Originally Posted by NanoRuler

Hi Keith,

I take it you're looking for the drivers for the flash storage and that you're working on porting AP4 to x7510?

If not, please could you let us know what else you need?

5th November 2008, 06:23 AM   |  #7  
keithwwalker's Avatar
OP Senior Member
Thanks Meter: 1
 
296 posts
Join Date:Joined: Jul 2007
More
I ran v1.73 of WM5torage and the SSD is recognized under USB connection.

It is titled WM5torage ATHE400 USB Storage Device. It is not formatted so the capacity still reads 0

Question is how to format it through WinXP or Vista????

If one of you guys has WM5torage, can you hook up your 7510 to your PC and then right click on your SSD?
It should show up as a removable disk. Right click on Properties, then under the Hardware tab, there should be a list of drives.
Click on the ATHE400 device and then hit Properties Button again.
A new window should openand then go to Driver tab.
Tell me what drivers are listed for your SSD once you hit the Driver Details button?

On mine they are:
c:\windows\system32\drivers\disk.sys
c:\windows\system32\drivers\PartMgr.sys

Let me know if you have anything different!
Last edited by keithwwalker; 5th November 2008 at 06:46 AM.
5th November 2008, 08:19 AM   |  #8  
Senior Member
Flag Plymouth
Thanks Meter: 0
 
151 posts
Join Date:Joined: Aug 2007
More
Keith, surely if you can see it under XP or Vista then you can format it? Is anything preventing you from formatting it as a removable storage device?
5th November 2008, 09:57 PM   |  #9  
Retired Recognized Developer
Flag Budapest
Thanks Meter: 49
 
3,039 posts
Join Date:Joined: Jul 2006
More
Quote:
Originally Posted by keithwwalker

I have the 7510 ROM that was modified to work with the 7500/01 but the SSD is not recognized as of yet.

this is the mistake

flash an *unmodified* x7510 rom from the thread i mentioned, and see if SSD works in that. you can always reflash to x7500 rom to fix the annoyances coming from the ROM not being fully compatible but this is just fine to test the SSD itself.
6th November 2008, 05:47 AM   |  #10  
keithwwalker's Avatar
OP Senior Member
Thanks Meter: 1
 
296 posts
Join Date:Joined: Jul 2007
More
I will try that Cmonex. But I thought that the ROM would not upload if the device was not an ATHE400. I will try it anyway.

With regard to formatting the SSD under USB connection. The only formatting available under my XP unit at home was FAT12. With FAT12, the SSD only had 78mb, dissappointing.

FAT32 wasn't an option, which was strange.

I sent that SSD back to Transcend, and now have the new one installed.

Does anyone have the link for the std. ROM? I downloaded a zip file, but it is fragmented file with .raw extensions. How to extract?
Last edited by keithwwalker; 6th November 2008 at 08:28 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes