5,606,530 Members 34,450 Now Online
XDA Developers Android and Mobile Development Forum

[Jan. 9 Update, sticky?] aGPS fix after running Leaked VZW Customizations

Tip us?
 
brsev
Old
(Last edited by brsev; 10th January 2009 at 07:14 AM.)
#1  
Member - OP
Thanks Meter 0
Posts: 84
Join Date: Aug 2008
Thumbs up [Jan. 9 Update, sticky?] aGPS fix after running Leaked VZW Customizations

January 9 Update: aGPS now working. If you're having QPST issues, try the bigjr99's fix that ScratchyPDX recommended here. This allowed me to get QPST to recognize my Vogue in XP. THe real issue, though, was allowing the leaked Verizon ROM to run its customizations. This installed custom Verizon drivers that essentially lock down the GPS even if you reflash the radio. The fix I used can be found here.


-------------ORIGINAL POST-----------------

I posted this over at PPCGeeks, but I figured I'd try XDA too. I've tried the instructions both on the XDA wiki and on the PPCGeeks post, unsuccessfully. I'm not sure what the problem is. I haven't seen anyone with a similar issue, and I've been fiddling with various settings for a while.

Quote:
I'm still having a problem getting this to work. It doesn't automatically install the drivers, I have to manually select them (plus, it only works in Vista). So then I follow all the steps exactly, the only difference is I only get one COM port in QPST (com3, which says SURF... next to it). So once I set everything up, GMaps and LiveSearch both find the GPS but never find any satellites.

My Vogue was set up as follows: xv6900 > official leaked Verizon ROM > 2.31 unlocker > NFSFAN Verizon 1.09, and uses the 3.77 radio. I had GPS working great with the Valhalla CAB on the leaked ROM, and I'm considering reverting back to that.

Please help! Is anyone having the same problem?
Edit: I'm evidently not the only one with this problem. Hopefully it'll get some more visibility.
BRSEV | HTC Droid Incredible | VZW | Stock/unrooted...so far
 
fabioc
Old
#2  
fabioc's Avatar
Junior Member
Thanks Meter 8
Posts: 15
Join Date: Apr 2006
I am experiencing the same issue. Trying NFSFAN 1.10 right now. I'll let you know if I find a solution, it could work for you as well...
 
brsev
Old
#3  
Member - OP
Thanks Meter 0
Posts: 84
Join Date: Aug 2008
Thanks for the reply-glad I'm not the only one. I quite like my current ROM in terms of speed and stability, and I've read reports of it working on NFSFAN Verzion 1.08, so hopefully it get sfigured out soon.
BRSEV | HTC Droid Incredible | VZW | Stock/unrooted...so far
 
bigjr99
Old
(Last edited by bigjr99; 5th January 2009 at 02:35 AM.)
#4  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Nov 2008
Same issue here. I've tried using NSF's 1.10 and Drellisdee's 1.12 and can't get either to work. I haven't reverted back to the leaked rom yet, but I was working fine with the leaked rom and valhalla also. Hope someone can find the fix.
 
ScratchyPDX
Old
#5  
Member
Thanks Meter 0
Posts: 30
Join Date: Aug 2008
Take a look at this post:

http://forum.xda-developers.com/show...50&postcount=7

If I understand your problem description, I was having the same problem until I read that post. It worked!

Good luck.

BTW - I'm using NFSFAN's Verizon 1.09 ROM
 
madsuse
Old
#6  
madsuse's Avatar
Member
Thanks Meter 0
Posts: 66
Join Date: Feb 2008
Default same issue here with OMJ ROM

I was able to get through the qpst programming and loaded the GC VerizonaGPSfix cab. I still can't lock on any satellites.

Maybe not ROM Specific.
I am using Radio 3.42.50.
Carrier: Verizon
Phone: VX6900
ROM: Undecided still testing
Radio: 3.42.xx
 
bigjr99
Old
#7  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Nov 2008
My issue is not getting qpst to work as i have already done this. It seems that there is a gps issue with using the 3.37 radio on these roms even if you have gotten it running on the stock leaked rom with customizations run.

madsuse, you must be having some other issues as with your radio veraion and a properly run agps fix you should have no problem with omj's roms. I had the same set up as you prior to the leaked rom with no issues.
 
brsev
Old
(Last edited by brsev; 6th January 2009 at 03:57 AM.)
#8  
Member - OP
Thanks Meter 0
Posts: 84
Join Date: Aug 2008
This thread at PPC Haven might help: http://www.ppchaven.com/viewtopic.ph...&sd=a&start=25

I've tried some of what was suggested, it still isn't working for me, but it might help. Some people are having similar problems.

@bigjr99: I think that might be it. Quite a few people have had trouble with the aGPS fix and NFSFAN ROMs, especially on the VZW radio. However, it has been done before, so I'm really not positive. I"m going to try the new Bell radio 3.42.50 and see if it makes a difference, then I'll give up on NFSFAN (apparently he's left several forums now, once for warez and then just recently for abusing moderator priveleges) and switch to either OMJ or WDM.

@ScratchyPDX: thanks! it works on my computer (in XP) now, no need to borrow a vista one. But it doesn't change anything else, I can reach QPST and successfully program w/out getting any satellites.
BRSEV | HTC Droid Incredible | VZW | Stock/unrooted...so far
 
bigjr99
Old
#9  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Nov 2008
I am definately thinking it has something to do with the 3.37 radio and running customizations on the leaked rom. I tried multiple different roms including nsfan, omj, drellisdee, and one other. Neither the agps fix or valhalla worked on any of them.

I have now reloaded the leaked rom and again let customizations run. did the agps fix and google maps would show me in the middle of the pacific. Ran valhalla and moved around files to the correct places and instant dead on gps.

I don't know what the problem is, but it looks like I am stuck with the leaked rom until I go back to radio 4.42
 
brsev
Old
(Last edited by brsev; 8th January 2009 at 05:02 AM.)
#10  
Member - OP
Thanks Meter 0
Posts: 84
Join Date: Aug 2008
bigjr, you mean I guess radio 3.42?

I've confirmed the problem is related to not the radio, but the CUSTOMIZATIONS on the Verizon ROM. They replace the GPS drivers with some idiotic VZ-Navigator-specific crap. If you're feeling daring try this and let me know how it works:
http://forum.ppcgeeks.com/showpost.p...&postcount=204

So, no problem with NFSFAN or even the radio. just the customizations, which is hard to revert to (cuz there's no previous VZW ROM, and running Bell/Sprint customization willl prob. just f*ck things up even more). I'm not sure how the 3.42 radio-only flash would affect the drivers. This is my understanding as of now, correct me if I'm wrong!


This may do the trick, I haevn't tried it yet though: http://wiki.ppchaven.com/index.php?t...IX_VERIZON_GPS
BRSEV | HTC Droid Incredible | VZW | Stock/unrooted...so far

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Speed up the ROM or Kernel Build Process

Creating a kernel, ROM, or any other development projectrequires knowledge and tools. While … more

Google Glass Now Open to Anyone… with $1500 to Spend (Update: Not Anymore)

Google Glass, which recently received its official update … more

Android 4.4.2 OTA Now Available for the Verizon Droid DNA

A couple of days ago, we talked about how the Android 4.4.2 upgrade for the HTC … more