Enable Call Recording on Xperia Z2 and Z3

Call recording, while not legal in every part of the world, is quite handy in certain situations. … more

Google Play Store Payments Available in China

Google has taken a big step to make its services accessible globally. Since the introduction of … more

How to Set a Video as Your Boot Animation

If you wish to make your phone truly unique, you may want to consider adding a nice boot animation. … more

TWRP for Nexus 6 and 9 Available, Unofficial CM12 Alpha for HTC Explorer! – XDA TV

Team Win Recovery Project for the Nexus 6 and Nexus … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Jan. 9 Update, sticky?] aGPS fix after running Leaked VZW Customizations

OP brsev

4th January 2009, 02:22 AM   |  #1  
OP Member
Thanks Meter: 0
 
84 posts
Join Date:Joined: Aug 2008
January 9 Update: aGPS now working. If you're having QPST issues, try the bigjr99's fix that ScratchyPDX recommended here. This allowed me to get QPST to recognize my Vogue in XP. THe real issue, though, was allowing the leaked Verizon ROM to run its customizations. This installed custom Verizon drivers that essentially lock down the GPS even if you reflash the radio. The fix I used can be found here.


-------------ORIGINAL POST-----------------

I posted this over at PPCGeeks, but I figured I'd try XDA too. I've tried the instructions both on the XDA wiki and on the PPCGeeks post, unsuccessfully. I'm not sure what the problem is. I haven't seen anyone with a similar issue, and I've been fiddling with various settings for a while.

Quote:

I'm still having a problem getting this to work. It doesn't automatically install the drivers, I have to manually select them (plus, it only works in Vista). So then I follow all the steps exactly, the only difference is I only get one COM port in QPST (com3, which says SURF... next to it). So once I set everything up, GMaps and LiveSearch both find the GPS but never find any satellites.

My Vogue was set up as follows: xv6900 > official leaked Verizon ROM > 2.31 unlocker > NFSFAN Verizon 1.09, and uses the 3.77 radio. I had GPS working great with the Valhalla CAB on the leaked ROM, and I'm considering reverting back to that.

Please help! Is anyone having the same problem?

Edit: I'm evidently not the only one with this problem. Hopefully it'll get some more visibility.
Last edited by brsev; 10th January 2009 at 08:14 AM.
4th January 2009, 06:56 AM   |  #2  
fabioc's Avatar
Junior Member
Thanks Meter: 8
 
15 posts
Join Date:Joined: Apr 2006
I am experiencing the same issue. Trying NFSFAN 1.10 right now. I'll let you know if I find a solution, it could work for you as well...
4th January 2009, 10:35 AM   |  #3  
OP Member
Thanks Meter: 0
 
84 posts
Join Date:Joined: Aug 2008
Thanks for the reply-glad I'm not the only one. I quite like my current ROM in terms of speed and stability, and I've read reports of it working on NFSFAN Verzion 1.08, so hopefully it get sfigured out soon.
4th January 2009, 11:58 PM   |  #4  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Nov 2008
Same issue here. I've tried using NSF's 1.10 and Drellisdee's 1.12 and can't get either to work. I haven't reverted back to the leaked rom yet, but I was working fine with the leaked rom and valhalla also. Hope someone can find the fix.
Last edited by bigjr99; 5th January 2009 at 03:35 AM.
5th January 2009, 07:00 PM   |  #5  
Member
Thanks Meter: 0
 
30 posts
Join Date:Joined: Aug 2008
Take a look at this post:

http://forum.xda-developers.com/show...50&postcount=7

If I understand your problem description, I was having the same problem until I read that post. It worked!

Good luck.

BTW - I'm using NFSFAN's Verizon 1.09 ROM
5th January 2009, 08:09 PM   |  #6  
madsuse's Avatar
Member
Thanks Meter: 0
 
66 posts
Join Date:Joined: Feb 2008
same issue here with OMJ ROM
I was able to get through the qpst programming and loaded the GC VerizonaGPSfix cab. I still can't lock on any satellites.

Maybe not ROM Specific.
I am using Radio 3.42.50.
5th January 2009, 09:01 PM   |  #7  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Nov 2008
My issue is not getting qpst to work as i have already done this. It seems that there is a gps issue with using the 3.37 radio on these roms even if you have gotten it running on the stock leaked rom with customizations run.

madsuse, you must be having some other issues as with your radio veraion and a properly run agps fix you should have no problem with omj's roms. I had the same set up as you prior to the leaked rom with no issues.
5th January 2009, 09:31 PM   |  #8  
OP Member
Thanks Meter: 0
 
84 posts
Join Date:Joined: Aug 2008
This thread at PPC Haven might help: http://www.ppchaven.com/viewtopic.ph...&sd=a&start=25

I've tried some of what was suggested, it still isn't working for me, but it might help. Some people are having similar problems.

@bigjr99: I think that might be it. Quite a few people have had trouble with the aGPS fix and NFSFAN ROMs, especially on the VZW radio. However, it has been done before, so I'm really not positive. I"m going to try the new Bell radio 3.42.50 and see if it makes a difference, then I'll give up on NFSFAN (apparently he's left several forums now, once for warez and then just recently for abusing moderator priveleges) and switch to either OMJ or WDM.

@ScratchyPDX: thanks! it works on my computer (in XP) now, no need to borrow a vista one. But it doesn't change anything else, I can reach QPST and successfully program w/out getting any satellites.
Last edited by brsev; 6th January 2009 at 04:57 AM.
6th January 2009, 12:58 PM   |  #9  
Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Nov 2008
I am definately thinking it has something to do with the 3.37 radio and running customizations on the leaked rom. I tried multiple different roms including nsfan, omj, drellisdee, and one other. Neither the agps fix or valhalla worked on any of them.

I have now reloaded the leaked rom and again let customizations run. did the agps fix and google maps would show me in the middle of the pacific. Ran valhalla and moved around files to the correct places and instant dead on gps.

I don't know what the problem is, but it looks like I am stuck with the leaked rom until I go back to radio 4.42
7th January 2009, 04:32 PM   |  #10  
OP Member
Thanks Meter: 0
 
84 posts
Join Date:Joined: Aug 2008
bigjr, you mean I guess radio 3.42?

I've confirmed the problem is related to not the radio, but the CUSTOMIZATIONS on the Verizon ROM. They replace the GPS drivers with some idiotic VZ-Navigator-specific crap. If you're feeling daring try this and let me know how it works:
http://forum.ppcgeeks.com/showpost.p...&postcount=204

So, no problem with NFSFAN or even the radio. just the customizations, which is hard to revert to (cuz there's no previous VZW ROM, and running Bell/Sprint customization willl prob. just f*ck things up even more). I'm not sure how the 3.42 radio-only flash would affect the drivers. This is my understanding as of now, correct me if I'm wrong!


This may do the trick, I haevn't tried it yet though: http://wiki.ppchaven.com/index.php?t...IX_VERIZON_GPS
Last edited by brsev; 8th January 2009 at 06:02 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes