Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,816 Members 39,008 Now Online
XDA Developers Android and Mobile Development Forum

[ROM] JACHero 2.3.5 - Fully Optimized HTCHero Port 7/6/09 8:00PM

Tip us?
 
justanothercrowd
Old
(Last edited by justanothercrowd; 8th July 2009 at 06:15 AM.) Reason: fixed link to update
#1  
Senior Member - OP
Thanks Meter 23
Posts: 775
Join Date: Jan 2009
Default [ROM] JACHero 2.3.5 - Fully Optimized HTCHero Port 7/6/09 8:00PM

WWARNING:You must Have The Correct Radio and Latest SPL! You can find them here (RADIO MUST BE INSTALLED FIRST) You can find it here

PLEASE DO YOUR RESEARCH BEFORE FLASHING ANY ROM INCLUDING MINE!!!


Please give credit if you use my work


This ROM is built from the WWE HTC Hero leak.

As with any other ROM there is a risk involved in the process, I'f you have any doubts you should just leave it alone or do some more research and get comfortable with what you are actually doing before proceeding!


Me and Drizzy will be teaming up to bring you new releases from now on. Soon 2.4 with alot more modifications, new kernel etc but untill then its BT time

DrizzyJAC r2.3.6
-Drizzy/JAC collab
-Pretty much the same as 2.3.5 but with framework/.apk's optimized
-Changed a2sd config to try and decrease loops
-/system/media moved to sdcard

JACHero r2.3.5
-app_s now moved to the sdcard @ system/sd/data/app_s
-Modified Rosie from coolbho3000 (thanks)
-CPU freq modifications in init.rc thanks to Cyanogen
-No longer overclocked by default set @ 384
-SMSReceiver service set to Highest priority
-Busybox only @ /sbin now
-apns-conf.xml update
-AudioFilter changes (should slightly increase volume and lower mic sensitivity)
-Added userinit.sh run support
-3G icon instead of H for Data
-App setup reverted to WWE format, only 3rd part apps in /data/app
-Cleaned up a2sd.sh script to prevent mounting and parsing redundancy and removed unneeded code for Hero builds
-Cleaned up update-script
***KNOWN ISSUE - use 3G/Edge to accept TOS for Market no WiFi, also first browser page on Wifi doesnt want to load at first on WiFi, go to any other site and you should be good
***Also swapper at 32/60 seems to be a sweet spot

JACHero r2.3.3
-Modified Rosie.apk
-db.hates.you custom wallpaper for JACHero

JACHero r2.3.2 - Had to pull the modified Rosie before releasing 2.3.2 it will be done soon.
-Removed cache_pressure from sysctl.conf
-Reverted AudioMOD
-updated contributors.html

JACHero r2.3.1
-replaced BT firmware in system/etc/firmware
-Max CPU set to 528
-APN changes in system/etc
-sysctl.conf changes system
-cleaned up unused/unneeded files in system/etc
-AudioMOD in /system/etc
-BT changes to enable pramods BT fix
-HCItool added to /system/bin to enable pramods BT fix
-Boot.img changes to conform to pramods BT fix
-removed launcher.apk/.odex
-removed learnmore.apk/.odex
-removed footprints/footprintswidget .apk/.odex
-removed HTCsync

JACHero r2.3
-Auto APPS2SD w/EXT2/EXT3 included script @ /system/bin/a2sd.sh
-2.6.27 Kernel - will be moving back to 2.6.29 eventually
-RAMDISK modifications
~auto mount for EXT2/3 partitions with noatime, nodirtime
~Updated sbin
~updated Trigger Binary
~calls to /data/init/rc system/init/rc
~PATH changes
~BlueTooth changes from Hero init.hero.rc and init.rc imported
-DalvikVM optimized
-Superuser Binary
-SD card placeholder
-BusyBox
-Added APN's for T-mobile users (SMS fix inlcuded in apn-conf.xml Thanks Horrorwolf)
-Trout keymappings
-Camera replaced with working Hero camera (still has rotate issue)
-Updated trout gps
-Multi-Touch
-Working WiFi
-Flash 9
-Audio libs updated (working audio and HTCMusic.apk)
-build.prop modifications to reflect proper device
-Sensor updates for Auto-Rotate (TouchFlo still won't rotate of course)
-sysctl.conf added to /system/etc
-auto backlight turned off by default in build.prop
-Wifi tether
-Swapper included
-changes to /data/app removed any .odex'd apps due to upgrade issues
-/system/lib files updated



PLEASE SUBMIT BUGS HERE http://code.google.com/p/jacheroplus


**********PLEASE READ BEFORE INSTALLING*********

Please use Cyanogen's recovery image!

Make sure you have a partitioned SD card with a FAT32 partition and a EXT3 partition. (EXT2 is supported also) If you do not this ROM will install but you will have little space left due to APPS2SD not running. I personally like the clean slate location for Hero and then i use the widgets i need if any.

When I install I check the ext filesystems first, if it tells you to go to console to manually check do it! After I've repaired the EXT partition or if it didn't need repair I will now wipe and then apply the update and reboot.

A walkthrough by forum member sxfx is posted one post below for install.

ALSO run as few widgets as possible folks!


DOWNLOADS

JACHero r2.3.6 SYM/BIND APPS2SD - MD5: 2A64747A1048FD175B1C1667D17E50FA
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.6.zip

JACHero r2.3.5 SYM/BIND APPS2SD - MD5: D80155D128ECCD3010768B52D9FB8EC0
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.5.zip

JACHero r2.3.3 SYM/BIND APPS2SD - MD5: 417ADE957153FD0BE5F3C7C9816B276F
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.3.zip

JACHero r2.3.2 SYM/BIND APPS2SD - MD5: a05c4d8d5abccd19c416b6febe40d6d2
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.2.zip

JACHero r2.3.1 SYM/BIND APPS2SD - MD5: 28f0afcc47d7766c71ecdb71e74e332a
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.1.zip

JACHero r2.3 SYM/BIND APPS2SD - MD5: D40A33ED2B1DED9181E1EA7B0AA96CC4
http://www.justanotherdev.slackdev.com
http://altepeter.com/justanotherdev/JACHero2.3.zip

JACHero r2.2.1 SYM/BIND APPS2SD - MD5: 35ad30f844862fb559ffcddadd4d49d2
http://www.justanotherdev.slackdev.com

JACHeror2.2.1 Fatality Merge SYM/BIND APPS2SD - MD5:87b22fc0baf6fc4138c48114388990b5
http://www.justanotherdev.slackdev.com



Thanks to daproy, JesusFreke, Cyanogen, Haykuro , xDan, Sangeet.003, Twisted Umbrella, and everyone else in the android community helping out.



If you like my work visit me at my Twitter.
 
justanothercrowd
Old
(Last edited by justanothercrowd; 3rd July 2009 at 02:10 AM.)
#2  
Senior Member - OP
Thanks Meter 23
Posts: 775
Join Date: Jan 2009
Default No Off-Topic Posts!!!!!! This is not a general support thread!!!!

CREDIT:sxfx

Ok Guys.

I created this thread cause in the JACHero thread on at least every page everyone asks how to install it, what am I doing wrong, and why is it broken.

So let me give you step by steps of what exactly I have done for me and others to run Hero with out a problem. I will also create a thread with step by step on how to use Ubuntu Linux Live distro to partition your card.

Things you will need to make this work.

Your Brain
G1 Phone
SD Card reader
And the files I included in this thread.

My phone right now is running.

JACHero 2.3
NEW SPL
cyanogens recovery 1.2
8gb class 6sd with Swapper(Swap file on ext2 sd)
setCPU slightly overclock.

Results.

Ever since I did my new Buttons, and the SPL I included in this write up, I have not had one problem flashing any hero rom at all on my phone, nor did I ever have problem actually running hero roms.

So here goes.

First before you partition your card or do anything make sure your card is at least portioned to fat32, don't worry about any other partitions yet.

OK once you do that go ahead and take the radio zip file I am including in this thread and flash it on your phone.

But first make sure you don't already have new radio installed which is 2.22.19.26I THIS IS VERY IMPORTANT. To check what radio you have, power off your phone, and power it on while holding the camera button.

If you do have new radio you can continue on to flashing the new SPL.

Flashing your SPL. (PLEASE MAKE SURE YOU HAVE THE NEW BUTTONS INSTALLED)

Ok this is where it might get a little tricky, and you might require a SD card reader I know I did and frankly I think this is the best way to do it and I recommend every time you do put a new update on your sd card to update your phone do it through a card reader.

Now after you flash your SPL you might or I should say more then likely will get stuck at the T-Mobile G1 screen, this also might happen after new radio flash in the previous step. If this is the case do not freak out it's normal and your phone is not bricked, but this is why having a sd card reader is important.

Ok so Here is what you do after you have flashed new Radio and SPL(Note:The steps on running Linux live distro and using it to partition your card is coming up). Boot up Live distro of Ubuntu, when its done booting, go ahead and go into the partitioning program while your sd card is hooked up in the computer.

Go ahead and set up two partitions at this time. One EXT3, and of course the other one Fat32. Your ext3 partition doesn't have to be all that big. I actually have mine set up to 512.

Once you are done creating partitions, go ahead and put the latest JACHero on the FAT32 portion and flash away (don't forget to rename to update.zip).

At this point if you follow all of these steps there is no way possible that your phone should not boot right into the system to run the initial setup.

These steps pretty much walk you through steps as if you were starting with a phone that has completly nothing on it.

Also the first boot up after flashing the new ROM, might take a few mins at the HTC screen.

Once your phone loads up and you go through the setup process go ahead and run swapper, it should be an APP that's already pre-installed.

Once you run swapper go into the setting and change the location of your swap file from /sdcard/swapfile.swp to /system/sd/swap.swp

Here is the reason why. The default location is your FAT32 partition. If you all of a sudden mount your phone to the computer with the swap file running on FAT32 you will corrupt your sd card, and then you will have to wipe and reinstall everything.

If you set the location of your swap file on /system/sd/ that's actually your ext2/3 partition and never gets mounted and you never have to turn swapper off.

Well I hope this helps some of you out. I will be writing the walk through on loading up live distro of Linux and partitioning your card sometime today.

I have used this method on a couple different phones and it has worked each time. Also I really recommend installing cyanogens recovery 1.2, as its an excellent way of making a back up of your phone and doing future flashing.

If there is anything anyone thinks that could be done better feel free to post in here.

Remember different people have different ways. I have posted this way cause it has worked for me on my phone and two other phones I setup, and each time there was no hicups.

FILES:
Radio 2_22_19_26I
NEW SPL
CM-Recovery-1.2
Ubuntu Linux Download

DISCLAIMER:
I am not responsible for anything that you might have done to your phone by following these directions. Like I mentioned before so far every time I have used this method, I have had nothing but success.

================================================== =============================
XDA Users, KEEP THIS THREAD ON TOPIC OR IT TOO WILL GOTO THE TRASH!!!
================================================== =============================
[/CENTER]
 
zgmf-x322a
Old
#3  
zgmf-x322a's Avatar
Senior Member
Thanks Meter 19
Posts: 679
Join Date: Sep 2008
Quote:
Originally Posted by ArmandHammer View Post
old one is on this site and on the market,
the new one is also on this site and on the market,
just search
at least u can tell me what should i search for in the market....?
Current Devices:
Pantech Vega Secret Note A890 (4.4.2 rooted)
Google Nexus 7 [2013]
ASUS Transformer Pad TF300T
Apple iPad 2
----------------
The Past:
Asus P535
Dell Streak
HTC Dream, Sensation
Motorola Xoom, Milestone
NEC N830, N840
Nokia 3310, 8250
Pantech Vega A860
Samsung Note1, Note2 LTE, S3, Omnia i900, Galaxy Tab 7.7
Sharp GX22
Sony J5
Xiaomi RedMi
----------------
Japanese phone collection:
Docomo SH-01A, SH-01D
Softbank 920sc, 910sh
Vodafone 802sh, 903sh, 904sh
 
Audi4style
Old
#4  
Audi4style's Avatar
Member
Thanks Meter 0
Posts: 53
Join Date: May 2009
Quote:
Originally Posted by ArmandHammer View Post
CHMOD didnt work for me,
chmod did,
ill report back on the apps to sd

After using the old apps2sd app i got an infinite loop.
Yeep I was running into the same problem. It wasn't working for me in upper case either. It started working once I did it as

su <enter>
chmod 777 /data/app <enter>
exit <enter>
exit <enter>

I think it should be noted on the first pase that chmod 777 should be in lowercase.
 
ArmandHammer
Old
#5  
ArmandHammer's Avatar
Senior Member
Thanks Meter 2
Posts: 260
Join Date: Apr 2009
Location: Ohio
Quote:
Originally Posted by zgmf-x322a View Post
at least u can tell me what should i search for in the market....?
AppsToSd search that in the market(old version)
I didnt buy the new one, its in the new and improved apps to sd thread

Alright back on topic
 
Audi4style
Old
#6  
Audi4style's Avatar
Member
Thanks Meter 0
Posts: 53
Join Date: May 2009
Okay so 1.4 is out now. He says Apps2Sd is included. I've never used Apps2sd and really don't know how to. So do I have to do anything with the 1.4 build to move it onto my sd card or will it automatically do it for me?
 
justanothercrowd
Old
(Last edited by justanothercrowd; 5th June 2009 at 04:25 AM.)
#7  
Senior Member - OP
Thanks Meter 23
Posts: 775
Join Date: Jan 2009
Run the APPS2D app with your EXT2/FAT32 partitioned SD card in and reboot that is all.

To make sure it is mounted go to the Terminal and type df, you should see

system/sd with your partitions size attributes etc

EXT3 support is next on the list.
 
Audi4style
Old
#8  
Audi4style's Avatar
Member
Thanks Meter 0
Posts: 53
Join Date: May 2009
Quote:
Originally Posted by justanothercrowd View Post
Run the APPS2D app with your EXT2/FAT32 partitioned SD card in and reboot that is all.

To make sure it is mounted go to the Terminal and type df, you should see

system/sd with your partitions size attributes etc
Perfect thanks! Is this the only difference in 1.4? So I have to create the partition myself first correct? I thought Apps2sd created the partition for me. Oh well let me go create the partitions lol.

PS: the CHMOD command doesnt seem to work in upper case. Lower case only.
 
chrisrj28
Old
#9  
chrisrj28's Avatar
Senior Member
Thanks Meter 376
Posts: 2,466
Join Date: Apr 2008
Location: Sacramento, CA
So will this new Rom with the app2sd app move everything but leave rosie.apk & launcher on the phone memory? Or is there something else that needs to be done?
Proud owner of a T-Mobile HTC One M8
OS: InsertCoin 3.0.8 | 1.54.401.10 | Android 4.4.2 & Sense 6
Kernel: ElementalX 14.8

and don't forget to thank me if I have assisted you in any way
 
juangil
Old
#10  
juangil's Avatar
Senior Member
Thanks Meter 102
Posts: 1,482
Join Date: Jan 2009
Location: PhOeNiX ArIzOnA
Quote:
Originally Posted by justanothercrowd View Post
Run the APPS2D app with your EXT2/FAT32 partitioned SD card in and reboot that is all.

To make sure it is mounted go to the Terminal and type df, you should see

system/sd with your partitions size attributes etc

EXT3 support is next on the list.
thanks a lot, you are doing it just right
question, if my apps are already in ext2 (system/sd/app) will it work? or they will now be located in : system/sd/app_s ?
thank you
LG G2 d801
Recovery: 2.6.3.5
Powered by: RayGlobe 4.0_GFlex


HTC ONE
powered by: RAYGLOBE

HTC One S
quietly S-OFF'd
Recovery: TWRP v2.4.3.0
HBoot: 1.09
Radio: 1.08ts.50
Powered By: $Droyd$'s 4.1 AOKP_ville



OS X Mountain Lion
-_- -_- -_- -_- -_- -_-


THREAD CLOSED
Subscribe
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes