Post Reply

WM6.1 - Disable Server Certificate Verification

28th August 2009, 09:12 PM   |  #1  
Wanaco's Avatar
OP Member
Flag Montréal
Thanks Meter: 0
 
49 posts
Join Date:Joined: Aug 2009
More
[SOLVED]
I had to install the certificates on my Diamond!


Hi Everyone,

I'm having trouble finding a way to disable the server certificate verification. I've searched everywhere but any of the solutions worked for me.

Here my problem:
I'm trying to connect (ActiveSync) to an exchange server - OWA (i.e. webmail.companyname.com) from my HTC Touch Diamond (WM6.1) phone but I keep having the "Invalid Certificate" message.

What I've found:
I've found few solutions to disable the server certificate verification but none fits my needs.
  • Hacking your Windows Mobile 5.0 Registry (Solution found here!)
    Very interesting since it only requires a registry modification... But I think it only works on Windows Mobile 5.0!

I'm looking for a registry hack to disable that verification so I can connect to the exchange server!

What's crazy is that other colleges have iPhones and they don't have any problem connecting to the server !

Please help me overcome this problem without having to ask the IT helpdesk for the certificates... It will take ages before they could do something!

Thank in advance!
(I'm pretty sure there's a way but I couldn't find it by myself)
Last edited by Wanaco; 14th September 2009 at 02:40 PM. Reason: Problem Solved
22nd October 2009, 02:06 AM   |  #2  
Senior Member
Flag NYC/Atlanta
Thanks Meter: 3
 
115 posts
Join Date:Joined: Jun 2006
More
what did u do, get the cert from IT?

I'm having this problem with google so I can't get the cert.


-Kenny
24th November 2009, 12:12 PM   |  #3  
Senior Member
Thanks Meter: 8
 
522 posts
Join Date:Joined: Jun 2006
me too - same problem..
Post Reply Subscribe to Thread

Tags
server certificate
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in General by ThreadRank