Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,733,198 Members 40,643 Now Online
XDA Developers Android and Mobile Development Forum

an accelerometer issue ive seen in a few myTouch phones.

Tip us?
 
airbag22
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 7
Join Date: Sep 2009
Location: Austin
Default an accelerometer issue ive seen in a few myTouch phones.

Ive had a few customers come in over the last week with screens that wont rotate. i read on the t-mobile forums that sometimes you need to tap the phone to get the accelerometer "unstuck" (which has never fixed it). instead i did a master reset and it fixed the issue on all the devices. one phone had tons of apps installed, which could have been an explanation, but today the guy had a brand new one purchased yesterday w/ no apps that wouldnt rotate until we reset it. he says it rotated at first then stopped.

and fyi, rotation was enabled in the settings

any ideas? it seems software related.
Bronze and Black G1's
MyTouch 3G Black
 
SyntaxTerror
Old
#2  
Junior Member
Thanks Meter 0
Posts: 13
Join Date: Jul 2008
Hi mate, this site shows you how to fix it:
http://ostebaronen.dk/?p=148
 
str4vag
Old
#3  
str4vag's Avatar
Senior Member
Thanks Meter 0
Posts: 287
Join Date: Jul 2009
Location: Kuala Lumpur
Have the same issue. 3 hours ago i had no problems with the accelerometer at all. everything was working fine.
then all of a sudden i notice that its not working. only change i did was upgrading from RA recovery 1.2.1H to 1.2.3H. after that, all was still ok. then now its not working all of a sudden.



Quote:
Originally Posted by SyntaxTerror View Post
Hi mate, this site shows you how to fix it:
http://ostebaronen.dk/?p=148
tried that. still not working.
Compass app is not pointing north,
abduction is no responding to tilts.

followed the instruction to the letter. and still nothing.

could this be a hardware issue?
----------------------------------------
----------------------------------------
 
bonesy
Old
(Last edited by bonesy; 14th October 2009 at 11:02 PM.)
#4  
bonesy's Avatar
Senior Member
Thanks Meter 298
Posts: 2,091
Join Date: Jan 2009
Location: Cornwall, united kingdom

 
DONATE TO ME
Same issue.I've tried redoing sappimg.nbh still nothing if I restore nandroid backup,fresh wipe tjen update rom it will work fir a bit then dies.evwn tried amon ra fix in recovery.

EDIT: Fixed my issue! Found that my case hsa metal in the back part, this has become magnetic thus stopping my gsensor
I have a pda flip case from ebay like this.....
Attached Thumbnails
Click image for larger version

Name:	HTC_CAS464_b.jpg
Views:	11
Size:	48.2 KB
ID:	237263  
Old devices: Touch HD > Magic X2 > Hero > Acer BeTouch E400 > Legend > Sensation > Desire > Nexus 7 > HTC One
I won't thank anyone who has "Press Thanks" in their sig.It's a choice to thank
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes