Firefox OS Architecture and Collaboration Opportunities w/ Asa Dotzler – XDA:DevCon 2014

We were privileged to host many presentations … more

Unofficial Android 4.4 Lands on Three Mediatek Devices

For the last few years, devices with MTK systems-on-chip haven’t received much … more

MultiImagePicker Library for Multiple Image Selection

App developmentcan be done in more than a handful of ways. You can write every single … more

Shoot Troubles, Not Users w/ Alex Boag-Munroe – XDA:DevCon 2014

In presenting the various sessions from XDA:DevCon 2014, weve mainly … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

SMS Message Problem!

OP weareborg

15th November 2009, 05:23 PM   |  #1  
weareborg's Avatar
OP Senior Member
Flag Dublin
Thanks Meter: 0
 
120 posts
Join Date:Joined: Aug 2006
More
Hi guys,
I'm having some difficulty with sending SMS messages. Its sporadic. Sometimes they send immediately, sometimes not at all. Its very frustrating.

For example, the day I got the phone (last week) I sent 2 text messages. I didn't hear back from anyone but thought nothing off it. I checked my messages and they were time stamped with the time I sent them at so I presumed they had gone.
That evening, about 6 hours later, I got my two replies. The people had only just got them, hours later. One of them wasn't impressed because it was intructions for something they needed to do 4 hours previously!

So, I turned on delivery reports on each sent message to make sure they sent.
Over, the next two days, I had no problems, delivery reports come in immediately within seconds of me sending my SMS message.

Meanwhile, I called my network (Vodafone) to see if there were any issues with network. they reported none. I checked the message centre number and verified it against the network one. They matched, so I thought all was in order... except I would have to get annoying delivery reports cluttering up my Text message inbox until I was sure the service was working 100%.

Earlier today, I sent about 3 important text messages, got no delivery reports, so I texted my other phone to see if the messages were going through. Nada. I was annoyed.
I'm thinking.. whats going on?
So about 10 minutes ago I shut down the phone and booted up again. Within 10 minutes I was getting all my delivery reports and replies from people!

Does anyone know what I could be doing wrong, what setting needs to be activated etc?

Obviously I can't use the text messaging on the device if I can't trust it to just work like pretty much every handset I've owned since... year dot.

PS: I spoke to Vodafone care team who said my sim card must be old; newer sim cards (128k) are needed for these "high tech" phones.
But I just took my sim out of my Nokia N97 (never had a problem) last week AND messages ARE going through on the Leo occasionally and only after a reboot, which is utterly pointless.
This is the last thing I thought I'd have issues with on a device like this..

Any advice? Have I missed something?

Thanks.
15th November 2009, 05:28 PM   |  #2  
Junior Member
Thanks Meter: 1
 
28 posts
Join Date:Joined: Nov 2009
More
Same here, I thought I messed up something in the sms service or so.
Done many hard resets and soft resets. But still no help.
15th November 2009, 05:37 PM   |  #3  
Member
Thanks Meter: 0
 
43 posts
Join Date:Joined: Nov 2009
More
I'm experiencing exactly the same problems. Also Vodafone and no one seems to get any sms from me.
15th November 2009, 05:38 PM   |  #4  
weareborg's Avatar
OP Senior Member
Flag Dublin
Thanks Meter: 0
 
120 posts
Join Date:Joined: Aug 2006
More
Okay, this ain't good!!
15th November 2009, 05:42 PM   |  #5  
Senior Member
Thanks Meter: 1
 
269 posts
Join Date:Joined: Jul 2008
More
since you both have vodafone, and I haven't seen/heard about other people having these problems, I'd say it was voda's fault
Last edited by br3nt; 15th November 2009 at 05:48 PM.
15th November 2009, 05:43 PM   |  #6  
Junior Member
Thanks Meter: 1
 
28 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by br3nt

since you both have vodaphone, and I haven't seen/heard about other people having these problems, I'd say it was voda's fault

Now tell me, why? I've never had problems on my previous phones.
I don't think the vodafone on the Ireland branch is the same as the one in the Netherlands

Kinda happy to hear that you guys also having the same issue.
It can probally be patched/fixed by htc. I googled for "htc sms hotfix"
And htc is also facing sms issues on other devices.
Last edited by Zero Masamune; 15th November 2009 at 05:47 PM.
15th November 2009, 05:47 PM   |  #7  
Senior Member
Thanks Meter: 57
 
463 posts
Join Date:Joined: Nov 2009
sigh... How will I live without outgoing SMS capability? so lame... hope you guys will find a fix soon.
15th November 2009, 05:53 PM   |  #8  
chalid's Avatar
Senior Member
Thanks Meter: 147
 
1,009 posts
Join Date:Joined: Jan 2008
Donate to Me
More
seems to be the same like the sms bug in previous manila 2.1 build. outgoing messages weren't send, but only on some specific providers.
15th November 2009, 06:03 PM   |  #9  
weareborg's Avatar
OP Senior Member
Flag Dublin
Thanks Meter: 0
 
120 posts
Join Date:Joined: Aug 2006
More
How could such a fundamental and critical phone component get screwed up? That just doesn't make sense. Anyone got ideas out there for a fix or we we have to wait for HTC to patch this? What about people who purchased a Leo and have no knowledge of this site etc deal with something like this? They buy a 500+ euro phone, try to send a text message, no joy. Baffled, annoyed, frustrated. Phone would get returned right? Not happy.
15th November 2009, 06:06 PM   |  #10  
Member
Flag Harrisburg Pa
Thanks Meter: 2
 
87 posts
Join Date:Joined: Jul 2008
I've had this same problem on ATT in the USA

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes