FORUMS

AOSP 5.1 Lollipop for Nexus Q

Google Nexus Q is an intriguing device released with Android 4.0 Ice Cream Sandwich. It was abandoned by … more

XDA Picks: Best Apps of the Week (Apr 17 – 24)

Apps are at the front and center of any smartphone experience, and with over a … more

Glimpse Notifications: Easier Lockscreen Notifications

Lollipop brought a revamp to the lockscreen, taking away custom widgets but … more

What Are the Best Looking Apps on Android?

As more developers are updating their apps with Material Design elements, we’re … more
Post Reply Subscribe to Thread Email Thread

[ROM-DEV] 04/16/10 | Back from the dead | Coming soon

2nd December 2009, 05:42 PM |#71  
david279's Avatar
Senior Member
Flag New Orleans
Thanks Meter: 1,775
 
Donate to Me
More
Quote:
Originally Posted by quietcblongs

Hmm, the Moto Droid 2.0 build is set for an OMAP chipset, rather than msm7k, so while the apk's could work, the lib's and other "native" files would probably not work right?

A side question for this newb (me) in compiling Android, where are these ro.cdma.* (found in the Droid's build.prop) properties set?

ro.cdma.home.operator.numeric=310004
ro.cdma.home.operator.alpha=Verizon ro.cdma.homesystem=64,65,76,77,78,79,80,81,82,83
ro.cdma.data_retry_config=default_randomization=20 00,0,0,120000,180000,540000,960000

from droid system dump
 
 
2nd December 2009, 06:35 PM |#72  
toastcfh's Avatar
Retired Forum Mod / Retired Senior Recognized Developer
Flag Lakeland, FL
Thanks Meter: 1,895
 
Donate to Me
More
Anyone tried to swap apn-config files? Although in the apn-config it says it must match apninfo.xml. god... I gotta get home
2nd December 2009, 06:46 PM |#73  
flipzmode's Avatar
OP Retired Recognized Developer
Thanks Meter: 693
 
Donate to Me
More
Quote:
Originally Posted by toastcfh

Anyone tried to swap apn-config files? Although in the apn-config it says it must match apninfo.xml. god... I gotta get home

Yup, I did that before I even posted the rom and it didn't help.

I got it to recognize on sprint by changing the follwing in build.prop:

Code:
ro.telephony.default_network = 0
to

Code:
ro.telephony.default_network = 4
After that it changed from "no service" to "Sprint" and showed my signal. I'm pretty sure that's the change that did it at least. I made a few changes at once. Ha.

Another thing I've noticed is if I try swapping Phone.apk with the one from droid or with our original 1.5 then com.phone still crashes, and on top of that it goes back to "no service". However it doesn't suffer from the memory leak. So that is part of it. I'm going to rip open the apk and see if I can find anything.
2nd December 2009, 08:19 PM |#74  
Recognized Developer
Flag Walnutport, PA
Thanks Meter: 41
 
Donate to Me
More
Quote:
Originally Posted by flipzmode

Yup, I did that before I even posted the rom and it didn't help.

I got it to recognize on sprint by changing the follwing in build.prop:

Code:
ro.telephony.default_network = 0
to

Code:
ro.telephony.default_network = 4
After that it changed from "no service" to "Sprint" and showed my signal. I'm pretty sure that's the change that did it at least. I made a few changes at once. Ha.

Another thing I've noticed is if I try swapping Phone.apk with the one from droid or with our original 1.5 then com.phone still crashes, and on top of that it goes back to "no service". However it doesn't suffer from the memory leak. So that is part of it. I'm going to rip open the apk and see if I can find anything.

What if we try to pull the phone.apk from the GSM Hero 2.1 builds? My theory is maybe the Phone.apk is just the UI and as long as we have the right radio (which we do) it will work. Maybe not but figure it might be worth a shot.
2nd December 2009, 09:02 PM |#75  
flipzmode's Avatar
OP Retired Recognized Developer
Thanks Meter: 693
 
Donate to Me
More
Quote:
Originally Posted by chuckhriczko

What if we try to pull the phone.apk from the GSM Hero 2.1 builds? My theory is maybe the Phone.apk is just the UI and as long as we have the right radio (which we do) it will work. Maybe not but figure it might be worth a shot.

I tried it from the droid 2.0 and it just breaks everything. heh.
2nd December 2009, 09:24 PM |#76  
Recognized Developer
Flag Walnutport, PA
Thanks Meter: 41
 
Donate to Me
More
Quote:
Originally Posted by flipzmode

I tried it from the droid 2.0 and it just breaks everything. heh.

Yeah but I was thinking maybe the Hero phone.apk is different than the Moto apk. I'll try it when I get a chance.
2nd December 2009, 09:36 PM |#77  
flipzmode's Avatar
OP Retired Recognized Developer
Thanks Meter: 693
 
Donate to Me
More
Quote:
Originally Posted by chuckhriczko

Yeah but I was thinking maybe the Hero phone.apk is different than the Moto apk. I'll try it when I get a chance.

Oh sorry I misread what you said. But pulling it from a HTC 2.1 gsm build? That's what's in there right now. Let me know if you have any success. Toast and I have been gtalking back and forth and trying different things but he's stuck at work so he can't try anything right now. We've made progress as far as saying "ok well that isn't working because of this" but the hard work is making this work with that.
2nd December 2009, 09:43 PM |#78  
seankk's Avatar
Member
Flag NY (LI)
Thanks Meter: 1
 
More
..from
do we have any idea when this will be released as a custom stable or a upgrade via ower carrier or htc themsellves
2nd December 2009, 09:52 PM |#79  
Recognized Developer
Flag Walnutport, PA
Thanks Meter: 41
 
Donate to Me
More
Quote:
Originally Posted by flipzmode

Oh sorry I misread what you said. But pulling it from a HTC 2.1 gsm build? That's what's in there right now. Let me know if you have any success. Toast and I have been gtalking back and forth and trying different things but he's stuck at work so he can't try anything right now. We've made progress as far as saying "ok well that isn't working because of this" but the hard work is making this work with that.

Ok. I thought it might be but wasnt sure. Did we try the phone.apk from the 1.5 Hero we currently have? I cant remember
2nd December 2009, 09:53 PM |#80  
cteneyck's Avatar
Senior Member
Flag Dallas
Thanks Meter: 169
 
Donate to Me
More
if you could just take the phone .apk and recompile it for the 2.x kernel you will be ok. remember phone is an app and on the cdma hero it was compiled for 1.5 so it probly needs to have the 2.0 kernel support added to it
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes