Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[solved] Q about settings for internet sharing

OP goldsfool

18th December 2009, 06:59 AM   |  #1  
goldsfool's Avatar
OP Member
Thanks Meter: 0
 
74 posts
Join Date:Joined: Dec 2008
I'm trying to use the factory installed Internet Sharing (not the new HTC Wifi Router, not WMWifirouter, just the regular factory installed Internet Sharing) to get internet access on my PC via USB (not Bluetooth).

I've spent hours and hours reading and trying different things but it still does not work. Can someone please explain the settings they used to get this to work?

Settings for Active Sync?
Settings for Network Connections on PC?
Settings on phone?

I have tried all possible combinations of settings and am absolutely STUMPED. I'd appreciate ANY help.

FYI: My PC's running XP

EDIT:

So, I got the Internet Sharing to work and just wanted to share what I learned in case it helps someone else. I'm using the HD with stock WM 6.1 and a PC running XP with Active Sync 4.5.

My problem was that even after applying all the correct settings, Internet Sharing was never able to establish a connection (it kept saying "check USB connection"). I noticed in my PC under My Computer>Properties>Hardware>Device Manager that there was an exclamation point beside the phone network adapter, so I updated/uninstalled/reinstalled the driver with no success. This driver is normally automatically installed when you first install Active Sync and create a partnership with your phone, so then I decided to uninstall and reinstall Active Sync and then created a new partnership with my phone (I didn't have to worry about losing any of my synced contacts, notes, calender, texts, etc because I also sync with Microsoft MyPhone, which I highly recommend). Afterwards, I disconnected my phone from the PC and closed Active Sync. Then I used the following settings/steps and Internet Sharing worked flawlessly.

Here are the settings I used:
-in Active Sync: unchecked "allow usb connection", unchecked "allow connections to one of the following", "this computer is connected to" set to automatic, checked "open active sync when my device connects", checked "allow wireless connection on device when connected to the desktop"
-in PC: disable Windows Firewall and all other 3rd party firewalls
-in PC internet explorer: set LAN settings to "automatically detect settings" (in Firefox under Tools>Options>Advanced>Network>Settings set to "auto detect")
-in phone: under Start>Settings>Connections>USB to PC checked "Active Sync", unchecked "enable faster data synchronization", checked "ask me first about UBS connection type when I connect the device to the PC"

With these settings:
-connect your phone to PC (on phone, dialog box should appear showing Active Sync checked, USB unchecked, Internet Sharing unchecked)
-nothing should happen at this point
-then in phone, launch Internet Sharing, set PC Connection to "USB", set Network Connection to whatever data network your phone uses, then press "connect" (the status will change from "disconnected" to "check USB connection"); wait about 15-20 seconds while your PC reacts (it takes this long only the first time you connect because the PC is installing the appropriate drivers)
-the Internet Sharing status should change to "connected" and now you can use the internet on your PC through the data connection on your phone. So simple if everything works properly.

FYI:
-if you go back to PC under My Computer>Properties>Hardware>Device Manager you will see your phone network adapter (no longer with an exclamation point) called "Windows Mobile-based Internet Sharing Device"
-f you go to PC Network Connections you will see your new phone LAN connection
-if your phone falls asleep while connected, the internet connection does NOT get interrupted; I also received a text while it was connected with no problem

To Disconnect Internet Sharing:
-close all browsers, press disconnect on your phone, then unplug your phone from the PC
-you can now turn active sync back on by checking "allow usb connection" and turn your PC firewalls back on

Wow, sorry so long, hope it helps someone.
Last edited by goldsfool; 19th December 2009 at 05:56 AM.
18th December 2009, 10:40 AM   |  #2  
Fallen Spartan's Avatar
Moderator Committee - Irish Pride, Spartan Legacy
Flag Belfast, Ireland Likes: Whiskey & XDA Dislikes: No whiskey
Thanks Meter: 4,477
 
10
23,112 posts
Join Date:Joined: Nov 2007
Donate to Me
Quote:
Originally Posted by goldsfool

I'm trying to use the factory installed Internet Sharing (not the new HTC Wifi Router, not WMWifirouter, just the regular factory installed Internet Sharing) to get internet access on my PC via USB (not Bluetooth).

I've spent hours and hours reading and trying different things but it still does not work. Can someone please explain the settings they used to get this to work?

Settings for Active Sync?
Settings for Network Connections on PC?
Settings on phone?

I have tried all possible combinations of settings and am absolutely STUMPED. I'd appreciate ANY help.

FYI: My PC's running XP

If your trying to do this at work, there is most likely a firewall setup so this wouldn't be possible unless your knew access codes etc for firewall

If this is with your home pc, when connecting pc to HD using usb you should automatically be presented with a synchronization screen from activesync for setting up a connection. Ensure you select 'allow wireless data connections on your device while it is connected to your computer' before finishing
18th December 2009, 10:55 AM   |  #3  
bigdish's Avatar
Senior Member
Flag South Yorkshire
Thanks Meter: 0
 
131 posts
Join Date:Joined: Jun 2007
More
And also :-
On the Touch HD
Start - Settings - Connections - USB to PC
Check Activesync and uncheck "enable faster data synchronisation"
Spent a couple of hours trying to connect before I did this.
Hope this works for you.
r
Andrew
18th December 2009, 01:09 PM   |  #4  
goldsfool's Avatar
OP Member
Thanks Meter: 0
 
74 posts
Join Date:Joined: Dec 2008
Thanks guys for your responses.

I've already tried each one of those things. I'm at home with firewall disabled, have the correct boxes checked in Active Sync, have the correct connection settings on the phone, etc. I've tried all possible combinations.

When I go to My Computer/Properties/Hardware/Device Manager I even see the phone Network Adapter but it has an exclamation point beside it. So I try to update/uninstall/reinstall the driver and it still doesn't work. Do I need to manually install different USD Modem drivers?? This doesn't seem right because these drivers should automatically be installed when I installed Active Sync.

I'm gonna try to update everything e.g. xp service pack and uninstall/reinstall Active Sync, etc. Hopefully after all of that it will work.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes