Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,310 Members 45,466 Now Online
XDA Developers Android and Mobile Development Forum

[GUIDE] Getting MMS/AGPS To Work

Tip us?
 
Wysie
Old
(Last edited by Wysie; 10th September 2010 at 07:33 AM.) Reason: Added a link as bcpk suggested.
#1  
Senior Member - OP
Thanks Meter 6
Posts: 1,119
Join Date: Jul 2009
Default [GUIDE] Getting MMS/AGPS To Work

Summary:
Some providers make use of a different APNs for MMS and data. In such cases, leaving the APN type as "" will cause MMS not to work (see History for explanation). To fix this, we have to ensure the following:

Data APN Types are set to "default", or "default,supl" (if you're having issues with AGPS, use the supl one)
MMS APN Types are set to "mms"

In other words, APN types should not be left blank for any APN. Hope it helps. For a detailed description read below.

History:
Hi all,

I previously had MMS working perfect after following this instructions: http://www.systemscrafter.com/imho/archives/6, but since I switched to CyanogenMod BETA 3 MMS hasn't been working for me.

After some testing, I've found out the following. It seems that under APN Type, the one you use for data MUST be designated as "default", and for the MMS one, as "mms". Lower-case. The apns-conf.xml left out the "default".

Secondly, after doing that, it still did not work reliably. This was solved by removing one of the data APNs. In Cyan's apns-conf.xml, there were "Gee! (GPRS)" and "StarHub Internet". These 2 are essentially the same APN point (one uses proxy, one does not), configuration wise, just given different names. I removed "Gee! (GPRS)" and entered "default" under "StarHub Internet", and MMS is now working perfect.

Update: xiutian had a simpler fix. Simply go to "Gee! (GPRS)" and "StarHub Internet", make sure both of them are set to APN type "default". It works, just tested. In other words, never leave the "APN type" blank. It has to be either "default" or "mms". (Any other values? not too sure...)

Update #2: cyanogen has kindly informed me that setting it to "default" may cause AGPS to stop working. After doing some searching, I found this: http://www.nexusoneforum.net/forum/n...nexus-one.html. Apparently, setting it to "" makes Android use it for everything, which explains why MMS was not working for some of us. To fix the AGPS part, instead of using "default", we now use "default,supl".

Update #3: @bcpk on Twitter has kindly pointed me to the following article: http://wccftech.com/2010/09/09/solvi...enmod-6-nexus/ Do check it out if you're having issues with CM6.

Hope it helps some of you.
 
samawil
Old
#2  
Member
Thanks Meter 0
Posts: 58
Join Date: Nov 2006
Quote:
Originally Posted by Wysie View Post
Summary:
Some providers make use of a different APNs for MMS and data. In such cases, leaving the APN type as "" will cause MMS not to work (see History for explanation). To fix this, we have to ensure the following:

Data APN Types are set to "default", or "default,supl" (if you're having issues with AGPS, use the supl one)
MMS APN Types are set to "mms"

In other words, APN types should not be left blank for any APN. Hope it helps. For a detailed description read below.

History:
Hi all,

I previously had MMS working perfect after following this instructions: http://www.systemscrafter.com/imho/archives/6, but since I switched to CyanogenMod BETA 3 MMS hasn't been working for me.

After some testing, I've found out the following. It seems that under APN Type, the one you use for data MUST be designated as "default", and for the MMS one, as "mms". Lower-case. The apns-conf.xml left out the "default".

Secondly, after doing that, it still did not work reliably. This was solved by removing one of the data APNs. In Cyan's apns-conf.xml, there were "Gee! (GPRS)" and "StarHub Internet". These 2 are essentially the same APN point (one uses proxy, one does not), configuration wise, just given different names. I removed "Gee! (GPRS)" and entered "default" under "StarHub Internet", and MMS is now working perfect.

Update: xiutian had a simpler fix. Simply go to "Gee! (GPRS)" and "StarHub Internet", make sure both of them are set to APN type "default". It works, just tested. In other words, never leave the "APN type" blank. It has to be either "default" or "mms". (Any other values? not too sure...)

Update #2: cyanogen has kindly informed me that setting it to "default" may cause AGPS to stop working. After doing some searching, I found this: http://www.nexusoneforum.net/forum/n...nexus-one.html. Apparently, setting it to "" makes Android use it for everything, which explains why MMS was not working for some of us. To fix the AGPS part, instead of using "default", we now use "default,supl".

Hope it helps some of you.
I'm sorry to say that it did not help me.

I'm on Orange in Switzerland.
I had to input the apn myself and don't see where i can make it default or not.

Could you please provide me with a little more info?

Thanks
 
cyanogen
Old
#3  
cyanogen's Avatar
Retired Recognized Developer
Thanks Meter 5688
Posts: 2,485
Join Date: Jan 2009
Location: Seattle

 
DONATE TO ME
I went thru the APN list and made the necessary corrections. Will include in beta4.

The file is here if you have anything to add:

http://github.com/cyanogen/android_v.../apns-conf.xml
 
samawil
Old
#4  
Member
Thanks Meter 0
Posts: 58
Join Date: Nov 2006
Awsome

For Orange CH I've found 2 things that work for me,
1) apn internet
mcc 228
mnc 03

2) apn wap
proxi 192.168.010.002
port 8080
mcc 228
mnc 03

Both these settings work to get data, but I still havent managed to find the correct mms settings, and the shop not only wants me to leave them the phone for an hour or 2 (i wonder why) but then they want me to pay them extra for the mms info..BS

I've been searching on the web but all the settings I've found and tried are not working.
 
Wysie
Old
#5  
Senior Member - OP
Thanks Meter 6
Posts: 1,119
Join Date: Jul 2009
Quote:
Originally Posted by samawil View Post
I'm sorry to say that it did not help me.

I'm on Orange in Switzerland.
I had to input the apn myself and don't see where i can make it default or not.

Could you please provide me with a little more info?

Thanks
When entering your APN, scroll to the bottom, there's a option "APN type", tap on that and type in "default". To be honest I don't know why Google can't make it a ListBox where we can choose from...
 
samawil
Old
#6  
Member
Thanks Meter 0
Posts: 58
Join Date: Nov 2006
Quote:
Originally Posted by Wysie View Post
When entering your APN, scroll to the bottom, there's a option "APN type", tap on that and type in "default". To be honest I don't know why Google can't make it a ListBox where we can choose from...
ahhh thanks,
I always thought apn type had something to do with the operator and therefor never even tapped on in.

I'll keep trying then with some of the settings I've found online, set the internet one to default, and see what happens, as soon as I can

Lou
 
esincho
Old
#7  
esincho's Avatar
Senior Member
Thanks Meter 214
Posts: 2,384
Join Date: Dec 2008
Location: Louisiana
I'm on Centennial Wireless. I had the internet working since day 1. But this didn't help with the mms. It does seem 2 almost connect now that I put mms in type, but still no go.
Samsung Galaxy Note 3
Samsung Galaxy Note 2
Samsung Skyrocket
HTC My Touch 4G
HTC Nexus One
HTC HD2
HTC Touch Pro 2
Palm Treo 680 (2 of em)
 
samawil
Old
#8  
Member
Thanks Meter 0
Posts: 58
Join Date: Nov 2006
Default success

yeaaayyy i finally got it.

Orange switzerland has 2 sets of settings, one for data and one for mms.
I had the correct information for both, but my mistake was in the apn type field.

So I went ahead and made the main data on default,supl and the other mms et voila...thanks...that link helped

L
 
Wysie
Old
#9  
Senior Member - OP
Thanks Meter 6
Posts: 1,119
Join Date: Jul 2009
esincho: More info would be good. You put "mms" in type for your MMS APN, right? What about your Data APN? What did you put in type for that?
 
Wysie
Old
#10  
Senior Member - OP
Thanks Meter 6
Posts: 1,119
Join Date: Jul 2009
Seems that the new Nexus One update has an updated apns-conf.xml.

Some of the settings have changed, particularly StarHub.
Code:
  <apn carrier="StarHub"
      mcc="525"
      mnc="05"
      apn="internet"
      type="default,supl"
  />

  <apn carrier="Gee! MMS"
      mcc="525"
      mnc="05"
      apn="shmms"
      mmsc="http://mms.starhubgee.com.sg:8002"
      mmsproxy="10.12.1.80"
      mmsport="80"
      type="mms"
  />
I've also uploaded it here: http://www.androidspin.com/downloads...=apns-conf.xml

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Run, Jump, and Shoot in Tales of Ciaxia

There are certain types of games that have become paramount of the portable gaming world. As we have … more

Samsung Gear Live Stock Firmware Image Pulled, Temp Root

Just yesterday,XDA Recognized Developer and TV ProducerAdamOutlertore apart … more

Draw a Line and Let Your Device Do the Rest with LineitApp

Over the years, since evenbefore Android entered the scene, we have striven to … more

[APK] Chrome Beta 37 Brings First Traces of Material Design

With Android L on the horizon, it’s no surprise that Google’s … more