Android Lollipop Lands for the Sony Xperia Z Ultra

The undisputed king of the beasts–at least in Sony’s current stable,is the … more

Android 5.0 Lollipop in 3D–EVO 3D, That Is!

It is that time of the year once again. Flowers bloom (or snow falls, depending on which … more

Gaming Console with Lollipop? Ouya Gets an Android TV Port

Android is a very flexible platform, and it can be used on a large variety of … more

Android App Review: Manage Your Connections Automagically – XDA TV

Material Design is all the buzz in the Android world right now. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Latest google update broke VPN?

OP clubtech

4th February 2010, 12:25 AM   |  #1  
OP Senior Member
USA
Thanks Meter: 304
 
1,707 posts
Join Date:Joined: Jun 2007
More
Is anyone able to to connect to any VPN server with the latest firmware update ?
It simply wont connect while it was connecting on the original firmware.
5th February 2010, 02:48 PM   |  #2  
Senior Member
Flag Suffolk
Thanks Meter: 0
 
133 posts
Join Date:Joined: Jul 2009
I have the same problem.

A vpn that was working fine before the update now wont work. It looks like the session is up for about a minute, and then closed by a TermReq from the N1 end but the N1 never completes the setup to start with.

SC
5th February 2010, 03:44 PM   |  #3  
Senior Member
Flag Suffolk
Thanks Meter: 0
 
133 posts
Join Date:Joined: Jul 2009
Ok,

I think I have a solution to this.

Code:
adb remount
adb shell chmod 755 /etc/ppp/ip-up-vpn
then try and reconnect

SC
5th February 2010, 06:11 PM   |  #4  
Senior Member
Flag Rockville, MD
Thanks Meter: 50
 
589 posts
Join Date:Joined: Oct 2005
More
My original VPN configurations did not work after the upgrade. I created new VPN entries and deleted the old ones. The new entries appears to be working fine so far.
5th February 2010, 07:11 PM   |  #5  
OP Senior Member
USA
Thanks Meter: 304
 
1,707 posts
Join Date:Joined: Jun 2007
More
Quote:
Originally Posted by ScaredyCat

Ok,

I think I have a solution to this.

Code:
adb remount
adb shell chmod 755 /etc/ppp/ip-up-vpn
then try and reconnect

SC

Thanks but still having the same issue. it will connect, stay connect for a minute or so and then the network connectivity will be gone (the VPN icon will show that VPN is still connected but in reality the connection died).
This has also been the case in the original phone firmware (prior to the upgrade).
5th February 2010, 09:01 PM   |  #6  
Senior Member
Thanks Meter: 56
 
339 posts
Join Date:Joined: Mar 2006
More
Someone on Modaco did similar but with the follwing line:-

adb shell chmod 777 /etc/ppp/ip-up-vpn


I've lost the ability to connect via adb to mine from my mac for some reason, working on that !

EDIT : Just noticed you had this problem pre-upgrade. This fix is not going to resolve that. Back to VPN settings / compatability.
5th February 2010, 10:52 PM   |  #7  
OP Senior Member
USA
Thanks Meter: 304
 
1,707 posts
Join Date:Joined: Jun 2007
More
This indeed solved the problem of not being able to connect. thank you.
It did not however solved the issue where the VPN connection stops forwarding traffic after 1-2 minutes (without actually disconnecting).
It seems to randomly happen, more when connecting to the VPN server over wifi.
I checked the logs and could not find anything.
Anyone has any idea why is this happening? this VPN servers works well on my laptop and iPhone.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes