FORUMS

Top Forum Discussions

Latest google update broke VPN?

1,751 posts
Thanks Meter: 317
 
By clubtech, Senior Member on 3rd February 2010, 11:25 PM
Post Reply Subscribe to Thread Email Thread
Is anyone able to to connect to any VPN server with the latest firmware update ?
It simply wont connect while it was connecting on the original firmware.
 
 
5th February 2010, 01:48 PM |#2  
Senior Member
Flag Suffolk
Thanks Meter: 0
 
More
I have the same problem.

A vpn that was working fine before the update now wont work. It looks like the session is up for about a minute, and then closed by a TermReq from the N1 end but the N1 never completes the setup to start with.

SC
5th February 2010, 02:44 PM |#3  
Senior Member
Flag Suffolk
Thanks Meter: 0
 
More
Ok,

I think I have a solution to this.

Code:
adb remount
adb shell chmod 755 /etc/ppp/ip-up-vpn
then try and reconnect

SC
5th February 2010, 05:11 PM |#4  
Senior Member
Flag Rockville, MD
Thanks Meter: 50
 
More
My original VPN configurations did not work after the upgrade. I created new VPN entries and deleted the old ones. The new entries appears to be working fine so far.
5th February 2010, 06:11 PM |#5  
OP Senior Member
USA
Thanks Meter: 317
 
More
Quote:
Originally Posted by ScaredyCat

Ok,

I think I have a solution to this.

Code:
adb remount
adb shell chmod 755 /etc/ppp/ip-up-vpn
then try and reconnect

SC

Thanks but still having the same issue. it will connect, stay connect for a minute or so and then the network connectivity will be gone (the VPN icon will show that VPN is still connected but in reality the connection died).
This has also been the case in the original phone firmware (prior to the upgrade).
5th February 2010, 08:01 PM |#6  
Senior Member
Thanks Meter: 74
 
More
Someone on Modaco did similar but with the follwing line:-

adb shell chmod 777 /etc/ppp/ip-up-vpn


I've lost the ability to connect via adb to mine from my mac for some reason, working on that !

EDIT : Just noticed you had this problem pre-upgrade. This fix is not going to resolve that. Back to VPN settings / compatability.
5th February 2010, 09:52 PM |#7  
OP Senior Member
USA
Thanks Meter: 317
 
More
This indeed solved the problem of not being able to connect. thank you.
It did not however solved the issue where the VPN connection stops forwarding traffic after 1-2 minutes (without actually disconnecting).
It seems to randomly happen, more when connecting to the VPN server over wifi.
I checked the logs and could not find anything.
Anyone has any idea why is this happening? this VPN servers works well on my laptop and iPhone.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes