Post Reply

[Guide] Complete Newbie Guide to Root & Install a Custom Rom [Updated 26/08]

OP btdag

29th March 2010, 12:02 AM   |  #101  
mrbubba999's Avatar
Senior Member
Thanks Meter: 96
 
1,215 posts
Join Date:Joined: Mar 2010
I managed to resolve, so if anyone is still having the problem, this is how to sort it.

Fastboot the Hero (press and hold the back button whilst powering on). Connect the phone to the USB cable and to the PC. Then go to device manager and select the HTC Hero in the list and update the driver. Choose the X64 drivers that are attached in the first post.
You should now be able to just run the RUU exe file and it should work....at least it did for me.

That was the longest part of the whole process, its taken me 3 hours to do and hopefully it will be worth it. My phone is just booting up with Villain4Beta2 (takes ages to boot up!!)
29th March 2010, 12:12 AM   |  #102  
OP Senior Member
Flag Bournemouth
Thanks Meter: 19
 
827 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by PulpzillA

@btdag

ok thanks but does that mean i'll have to use the goldcard method?

Probably, but not necessarily. Try the other method and if you get access denied error (you'll understand when you see it) then you'll have to try the gold card one.

Quote:
Originally Posted by borhaj

they said my phone was bricked so they changed it for me . is it really necessary to upgrade the radio?

It isn't necessary, but as the radio deals with the signal stations which the phone connects to it is recommended to have the latest one for the best signal. To be honest I have crap signal on any of the radio's so it doesn't change much for me but each experience is different.

Quote:
Originally Posted by mrbubba999

I'm having the same issue and doing the above doesn't make a difference.

Its loads the Bootloader and then just says "Waiting for bootloader", when it gets to 90, I get the USB 171 or USB 170 error message.

i then have to remove the battery and power the phone up again. I've tried 4 times now with the exact same problem

any ideas?

Have you tried a different USB port, or a different computer? Try googling the USB 171 and USB 170 errors (quoting the exact error message).
Edit: in fact read the above post.
Last edited by btdag; 29th March 2010 at 12:15 AM.
29th March 2010, 11:23 AM   |  #103  
mrbubba999's Avatar
Senior Member
Thanks Meter: 96
 
1,215 posts
Join Date:Joined: Mar 2010
Quote:
Originally Posted by btdag

Probably, but not necessarily. Try the other method and if you get access denied error (you'll understand when you see it) then you'll have to try the gold card one.



It isn't necessary, but as the radio deals with the signal stations which the phone connects to it is recommended to have the latest one for the best signal. To be honest I have crap signal on any of the radio's so it doesn't change much for me but each experience is different.



Have you tried a different USB port, or a different computer? Try googling the USB 171 and USB 170 errors (quoting the exact error message).
Edit: in fact read the above post.

Managed to fix it (see post above yours), its to do with the USB driver not working when in bootloader, but the work around resolved it.

Been running villain4beta2 all day, its good, but noticed a bit of slow down every now and again
30th March 2010, 02:00 PM   |  #104  
Senior Member
Thanks Meter: 118
 
877 posts
Join Date:Joined: Jan 2010
Quote:
Originally Posted by btdag

Follow the instructions here: http://forum.xda-developers.com/showthread.php?t=561124



.

ive tried that, but i couldnt get adb to work, il give it another go sometime at the weekend.
30th March 2010, 06:08 PM   |  #105  
OP Senior Member
Flag Bournemouth
Thanks Meter: 19
 
827 posts
Join Date:Joined: Nov 2009
More
Quote:
Originally Posted by BigD18t

ive tried that, but i couldnt get adb to work, il give it another go sometime at the weekend.

If adb isn't working try out my adb guide for help.
30th March 2010, 11:24 PM   |  #106  
Senior Member
Flag Lund
Thanks Meter: 18
 
112 posts
Join Date:Joined: Feb 2010
More
Guide worked like a charm. Flashed DefianceCR_030710_213121_signed without any problems on my Hero, now running Android 2.1!
31st March 2010, 08:45 PM   |  #107  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Mar 2010
thankx man...
it really helps..
1st April 2010, 05:21 PM   |  #108  
Rptynan's Avatar
Junior Member
Flag Co. Laois
Thanks Meter: 0
 
20 posts
Join Date:Joined: Mar 2010
More
Quote:
Originally Posted by mrbubba999

I managed to resolve, so if anyone is still having the problem, this is how to sort it.

Fastboot the Hero (press and hold the back button whilst powering on). Connect the phone to the USB cable and to the PC. Then go to device manager and select the HTC Hero in the list and update the driver. Choose the X64 drivers that are attached in the first post.
You should now be able to just run the RUU exe file and it should work....at least it did for me.

That was the longest part of the whole process, its taken me 3 hours to do and hopefully it will be worth it. My phone is just booting up with Villain4Beta2 (takes ages to boot up!!)

Thanks for that fix, really helped me out.

Btw, Great guide btdag, Thanks
1st April 2010, 08:56 PM   |  #109  
Rptynan's Avatar
Junior Member
Flag Co. Laois
Thanks Meter: 0
 
20 posts
Join Date:Joined: Mar 2010
More
Btw, I think you should add a reminder to run a nandroid backup, (maybe even make a guide for us newbs )
I completely forget to and now I'm on VillainRom 5.02, what should I do in terms of a nandroid backup?
1st April 2010, 08:59 PM   |  #110  
Member
Thanks Meter: 0
 
50 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by Rptynan

Btw, I think you should add a reminder to run a nandroid backup, (maybe even make a guide for us newbs )
I completely forget to and now I'm on VillainRom 5.02, what should I do in terms of a nandroid backup?

in the custom recovery you can find the nand backup option also +ext

EDIT: no dalvik i ment ext

to be more precise in RA-hero-v1.6.2 (same in 1.5.2) you can find it in Backup/Restore tab
Last edited by Zero00SM; 1st April 2010 at 09:02 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes